login|Register
Forum > Debian
Post|
看2954|回0|Favorite
pixelcade 看全部
2022-5-4 13:12:01
Have been trying to get Ethernet Gadget Mode going with an Orange Pi Zero 2 that is running Debian.

i've enabled g_ether in /etc/modules

uwe5622_bsp_sdio
sprdbt_tty
sprdwl_ng
g_ether


and then I can see usb0 is here in orangepi-config

but when connecting a USB A-A cable from the onboard USB connector on the Orange Pi Zero 2 (not the USB's on the header pins), am unable to get the host (either windows or Linux) to recognize it.

any ideas would be great! thanks!

Ethernet (eth0)            ↑ │ <Activate>   │
                      │ │ * Wired connection 1       ▒ │              │
                      │ │                            ▒ │              │
                      │ │ Ethernet (usb0)            ▒ │              │
                      │ │ * Wired connection 1       ▒ │              │
                      │ │   Orange Pi ethernet       ▒ │              │
                      │ │                            ▒ │              │
                      │ │ Wi-Fi                      ▒ │              │
                      │ │   AxeyNet_5GEXT      ▂▄▆█  ▮ │              │
                      │ │   AxeyNet_EXT        ▂▄▆█  ▒ │              │
                      │ │   AxeyNet            ▂▄▆_  ▒ │              │
                      │ │                            ▒ │              │
                      │ │                            ▒ │              │
                      │ │                            ▒ │              │
                      │ │                            ▒ │              │
                      │ │                            ↓ │ <Quit>       │
                      │ └──────────────────────────────┘         

OrangePi En

Powered by Discuz! X3.4

homepage|Simple edition|Touch edition|PC