login|Register
Forum > Python
Post|
看36978|回25|Favorite
varghese 看全部
2016-12-6 04:49:53
wow ..thanks
alexp1 看全部
2017-3-5 07:29:49


Hello everyone, I'm trying this project with a more orange one just configured with armbian Ubuntu Xenial Legacy 3.4.113 (version desktop), when downloading flask me an error
exactly you get this error message " could not import setuptools which is required to install from a source distribution. please install setuptools" will post a screen ... you have suggestions on how to proceed? thank you so much
attachment: 您需要登录才可以下载或查看附件。没有账号?Register
igorpec 看全部
2017-3-5 16:35:13
Perhaps?

code:

  1. apt install python-setuptools
DjBeppee 看全部
2017-3-16 16:11:31
Hi, I followed the guide and I managed to install everything correctly. I found a problem in the use: if I use 3.3V when switch to OFF, the tension appears to be 0V, and so everything is right. But if you use the 5V switch to OFF when the voltage drops to approximately 2V and not to 0V, how come? Can it be solved?
alexp1 看全部
2017-10-10 21:07:33
Hello everyone, after a while I resumed a more orange card test, now I've been able to advance, but I still can not access the webserver, I attach a video with the procedure, and always in this post a guideline that I followed the front page of this thread and a site listed

1) I installed the image "Armbian_5.30_Orangepione_Ubuntu_xenial_default_3.4.113_desktop.img" on a 16gb sd with the ethcer portable program

2) At the first booted user root and password 1234
(1234) immediately changed to a safer one
3) created alexp user and relative password

once in ubuntu ui, set Italian keyboard and started the terminal

then in series I executed the commands as a guide
that is
1.Install flask with this page.
http://mattrichardson.com/Raspberry-Pi-Flask/

sudo apt-get install python-pip
sudo pip install flask

I created the hello-flask.py file with writer and tried it, I can not get the test here already, cmq i went on

with
2.Install WiringPi-Python-OP Library from here.
https://github.com/lanefu/WiringPi-Python-OP

git clone --recursive https://github.com/lanefu/WiringPi-Python-OP.git
cd WiringPi-Python-OP

sudo apt-get install python-dev python-setuptools swig

cd WiringPi
sudo ./build

at this point I continued with step n.3
3.Download webioOP.tar and put it in your OPI.
cd $ HOME / flask
tar xvf webioOP.tar

I created a flask name folder under home / alexp (HOME)
and pasted the previously downloaded file, executed by tar xcf webioOP.tar command from the terminal so I extracted the tar arch files in that folder

4.Start Python.
$ cd $ HOME / flask
$ sudo python ./webioOP.py

when I try to execute this step, when submitting sudo python ./webioOP.py, it sends me the following error (referring to attached photo)
how could I solve it, can anyone help me with a brief step by step explanation? thank you so much


I also uploaded a video on youtube with all the lines written and related messages that appear to me ... thank you again
https://youtu.be/_a5hxZbQ3g0

attachment: 您需要登录才可以下载或查看附件。没有账号?Register

OrangePi En

Powered by Discuz! X3.4

homepage|Simple edition|Touch edition|PC