login|Register
Forum > Network and servers
Post|
看7736|回0|Favorite
scoobyok26 看全部
2016-7-14 18:21:10
hi everyone, i'm currently trying to communicate with arduino through a webserver created with node js installed on my orange pi pc. In order to do this, i tried to use the module called 'johnny five', but the only output I receive is a bunch of errors.

I'm using raspbian v 0.8.0 for Orange pi pc.

I installed node by using this code:
wget https://nodejs.org/download/release/v0.10.0/node-v0.10.0-linux-arm-pi.tar.gz
than i unpacked the file by using:
cd /usr/local
sudo tar xzvf ~/node-v0.10.0-linux-arm-pi.tar.gz --strip=1
the version of node is 0.10.0 and the npm's version is 1.2.14. When i try to update the npm with the command "npm install npm -g" these errors came in:

Then i tried to install 'johnny-five' by following this guide: https://github.com/rwaldron/johnny-five/wiki/Getting-Started
And this happened:

if i try to run a program this happens:


Please someone helps me!!!!!! i'm so desperate, thank you for the help!!!! i'm new to this kind of things, so i don't know what to do.


attachment: 您需要登录才可以下载或查看附件。没有账号?Register

OrangePi En

Powered by Discuz! X3.4

homepage|Simple edition|Touch edition|PC