Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 4175|Reply: 5

OrangePi temperature sensors not accurate

[Copy link]

1

Threads

6

Posts

183

Credits

Registered member

Rank: 2

Credits
183
Post time 2017-2-17 00:55:43 | Show all posts |Read mode
Edited by xkzry at 2017-2-17 11:36

I have 5 Orange Pi boards, all running as headless servers using armbian.

The temperature readings of 2 boards are too low. The room temperature was 21°C yesterday :
  • OPi-PC, with 15x15x15 heat sink, no fan, temp 16-18°C.
  • OPi-PC2 with no heat sink, no fan, temp 24-27°C. With fan : 16-18°C.



Today, room temp is 22°C, the OPi-PC2 with 15x15x15 heat sink and fan :
  1. 00:34:16:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.5°C
  2. 00:34:21:  240MHz  0.00   0%   0%   0%   0%   0%   0% 13.9°C
  3. 00:34:26:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.2°C
  4. 00:34:31:  240MHz  0.00   0%   0%   0%   0%   0%   0% 13.9°C
  5. 00:34:36:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.4°C
  6. 00:34:41:  240MHz  0.00   0%   0%   0%   0%   0%   0% 14.6°C
  7. 00:34:47:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.1°C
  8. 00:34:52:  240MHz  0.00   0%   0%   0%   0%   0%   0% 14.8°C
  9. 00:34:57:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.8°C
  10. 00:35:02:  240MHz  0.00   0%   0%   0%   0%   0%   0% 13.9°C
  11. 00:35:07:  240MHz  0.00   0%   0%   0%   0%   0%   0% 14.8°C
  12. 00:35:12:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.6°C
  13. 00:35:18:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.8°C
  14. 00:35:23:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.2°C
  15. 00:35:28:  240MHz  0.00   0%   0%   0%   0%   0%   0% 14.5°C
  16. 00:35:33:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.8°C
  17. 00:35:38:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.4°C
  18. 00:35:43:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.5°C
  19. 00:35:48:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.4°C
  20. 00:35:54:  240MHz  0.00   0%   0%   0%   0%   0%   0% 15.5°C
  21. 00:35:59:  240MHz  0.00   0%   0%   0%   0%   0%   0% 14.8°C
  22. 00:36:04:  240MHz  0.00   0%   0%   0%   0%   0%   0% 16.7°C
  23. 00:36:09:  240MHz  0.29   0%   0%   0%   0%   0%   0% 16.5°C
  24. 00:36:14:  240MHz  0.27   0%   0%   0%   0%   0%   0% 14.5°C
  25. 00:36:19:  240MHz  0.25   0%   0%   0%   0%   0%   0% 12.9°C
  26. 00:36:24:  240MHz  0.23   0%   0%   0%   0%   0%   0% 16.1°C
  27. 00:36:30:  240MHz  0.21   0%   0%   0%   0%   0%   0% 15.5°C
Copy the Code


Using my finger to check the CPU temperature (when the fan is not being used), not hot, just warm. However, the temperature readings are too low.

No body has mentioned this problem in this forum, am I the only one ?

9

Threads

641

Posts

4374

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4374
Post time 2017-2-17 01:34:50 | Show all posts
Edited by igorpec at 2017-2-16 18:37

Readings are too low, yes.

There was some changes regarding temp reading on latest update and we notice this after releasing images ... Will be fixed, but we will not push update because of this issue.

1

Threads

6

Posts

183

Credits

Registered member

Rank: 2

Credits
183
 Author| Post time 2017-2-17 11:42:33 | Show all posts
igorpec replied at 2017-2-17 01:34
Readings are too low, yes.

There was some changes regarding temp reading on latest update and we no ...

Not totally related to the recent update, I think.

My OPi-PC2 is new, but I have my OPi-PC for around 2 months, its temperature was very low from the beginning.
I have another OPi-PC, its temperature was 28-30°C while the first one was 16-18°C.

9

Threads

641

Posts

4374

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4374
Post time 2017-2-17 14:05:39 | Show all posts
Possible yes.

For Opi PC2 our mainline kernel is in early stage of development. There probably nobody checked that yet ... while for H3 we have lot's of topic regarding temperature readings.

https://forum.armbian.com/index. ... ter-upgrade-to-525/
and many more. Check here:
https://www.armbian.com/search_gcse/

0

Threads

3

Posts

95

Credits

Registered member

Rank: 2

Credits
95
Post time 2017-2-21 16:53:49 | Show all posts
It also has OPI PC PLUS
I had a problem with the temperature.
3 days 30 units installed.
He always came out error.
So far installed Armbian_5.25_Orangepipcplus_Ubuntu_xenial_default_3.4.113 desktop, server.
Now it is above Armbian_5.25_Orangepipcplus_Debian_jessie_default_3.4.113
With this work.
https://www.armbian.com/orange-pi-pc-plus/



09:52:20: 480MHz 0:01 0% 0% 0% 0% 0% 0% 25  ° C
root @ orangepipcplus: ~ #

0

Threads

31

Posts

348

Credits

Intermediate member

Rank: 3Rank: 3

Credits
348
Post time 2022-2-6 13:28:46 | Show all posts
Thanks for the valid detail you have provided about the orange Pi temperature sensor which is not accurate caweedly.com and I felt that more data could have been added here which will help to get more idea about the issue related to it
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2022-5-17 18:59 GMT+8 , Processed in 0.036645 second(s), 22 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list