Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 1609|Reply: 2

"Sdcard not found" while booting from EMMC

[Copy link]

2

Threads

3

Posts

26

Credits

Novice

Rank: 1

Credits
26
Post time 2017-3-16 06:27:48 | Show all posts |Read mode
Hello!
Using debian 0.9.1 at piplus.
If I boot from SDcard, it boots well.  "install_to_emmc" is OK too.
If I boot from EMMC, it boots well too, however  sdcard does not seen by system!
(no mounts, fdisk -l sees only EMMC (mmcblk0 with its partitions), "sdcard not found" error  after "install_to_sdcard")
Yes, I insert sdcard after booting, because if I insert empty formatted sdcard before booting, booting stops after something like "cannot open console".
Some working sdcards were tried with the same result.   Any idea please?

3

Threads

79

Posts

1042

Credits

Gold member

Rank: 6Rank: 6

Credits
1042
Post time 2017-3-16 07:09:21 | Show all posts
Edited by JRios at 2017-3-16 07:13

Hi,

Don't know what could be the problem. You can try changing the sdcard detection mode in hardware configuration file (script.bin), to allow the system boot when the SD is inserted (before booting).

I don't have any OPi with eMMC so I can't test It, however It should be something like this:

  1. 1 - Go to boot directory (or the directory where script.bin is located):
  2. cd /boot

  3. 2 - Make a backup copy of the file:
  4. sudo cp script.bin script_bak.bin

  5. 3 - Convert the binary file to editable text file:
  6. sudo bin2fex script.bin script.fex

  7. 4 - Open the fex file:
  8. sudo nano script.fex

  9. 5 - Search the SDMMC controller section ([mmc0_para]) and change the line corresponding to the detection mode:
  10. Change (sdc_detmode = 3) to (sdc_detmode = 1)

  11. 6 - Save and close the file:
  12. Ctrl X, Y (Yes), Enter

  13. 7 - Convert the edited fex file to bin:
  14. fex2bin script.fex script.bin

  15. 8 - Reboot the system:
  16. sudo reboot
Copy the Code


Now, the system should boot even with SD inserted.

2

Threads

3

Posts

26

Credits

Novice

Rank: 1

Credits
26
 Author| Post time 2017-3-16 19:10:42 | Show all posts
Thank you!  All ok now
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-4-7 05:02 GMT+8 , Processed in 0.028700 second(s), 24 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list