login|Register
Forum > Gaming
Post|
看10204|回1|Favorite
Giantofstone 看全部
2017-4-23 10:07:44
Edited by Giantofstone at 2017-4-24 06:45

There is a newer version of armbian and i wanted to manually install retropie on it to see what happens but there are issues installing it on Orange Pi PC. I don't use the required packages from other devices to install emulationstation and retroarch. How do i go around that?

Edit1: Using the following command to run retropie setup i have managed to install everything without errors.

code:

  1. sudo MAKEFLAGS=-j1 __platform=generic-x11 ./retropie-setup.sh


Now i get this error when i start emulationstation:

libGL error: unable to load driver: mali_drm_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: mali_drm

Edit2: Here is the Fix
Get into root mode (sudo -i) instead of sudo to not get premission denied
and install this pakages too

code:

  1. apt-get install git build-essential xorg-dev xutils-dev x11proto-dri2-dev libltdl-dev libtool automake




charlly 看全部
2023-3-8 12:00:20
It seems that you have managed to successfully install Retropie on an Orange Pi PC, despite the issues you encountered. Congratulations on finding a workaround to the problem - it's great to see that you are determined to explore the possibilities of the newer version of Armbian. We  build a diamond ring   are looking forward to hearing more about the results of your installation.

OrangePi En

Powered by Discuz! X3.4

homepage|Simple edition|Touch edition|PC