Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: loboris

Linux Distributions for Orange PI H3 boards

  [Copy link]

10

Threads

448

Posts

4081

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4081
 Author| Post time 2015-6-25 00:48:31 | Show all posts
markwinger replied at 2015-6-25 00:19
Bluetooth usb audio will be nice addition but I have not been able to get it to work with jack audio ...

There is create_sdcard script in make_linux.tar.gz, but it has nothing to do with kernel building.
This is the scripts colection to build Debian or Ubuntu image using debootstrap. Kernel, libs, boot and u-boot are incleded as binaries.
For building the kernel you need Allwinner Linux SDK, and I can give you kernel config I use...

1

Threads

39

Posts

137

Credits

Registered member

Rank: 2

Credits
137
Post time 2015-6-25 01:09:58 | Show all posts
Thanks.  I will try it using you config as a starting point.

Marki

1

Threads

39

Posts

137

Credits

Registered member

Rank: 2

Credits
137
Post time 2015-6-25 01:26:42 | Show all posts
The only kernel I have successfull built is for the banana pi using igorpec script.  That downloaded everything automatically.  Can you point me to where do I get the allwinner sdk for orange pi plus and if there are instructions on how to build it?

2

Threads

53

Posts

1306

Credits

Gold member

Rank: 6Rank: 6

Credits
1306
Post time 2015-6-25 01:53:39 | Show all posts
matteobp replied at 2015-6-24 21:42
Ok. Thanks. I'll try and let you know.

This is the dmesg output with wireless driver removed
[    5.017530] generic-usb 0003:045E:0745.0005: input,hidraw4: USB HID v1.11 Keyboard [Microsoft Microsoft® Nano Transceiver v2.0] on usb-sunxi-ohci-1.2/input0
[    5.110893] generic-usb 0003:045E:0745.0006: input,hidraw5: USB HID v1.11 Mouse [Microsoft Microsoft® Nano Transceiver v2.0] on usb-sunxi-ohci-1.2/input1
[    5.155614] generic-usb 0003:045E:0745.0007: input,hiddev0,hidraw6: USB HID v1.11 Device [Microsoft Microsoft® Nano Transceiver v2.0] on usb-sunxi-ohci-1.2/input2
[    6.101876] vmouse_input_dev_open
[    6.170098] vmouse_input_dev_close
[    8.761756] systemd-logind[574]: New seat seat0.
[    8.982490] gmac0: probed
[    8.982662] gmac0 gmac0: eth0: eth0: PHY ID 001cc915 at 0 IRQ poll (gmac0-0:00)
[   10.317520] vmouse_input_dev_open
[   10.371852] init: plymouth-upstart-bridge main process ended, respawning
[   10.461253] systemd-logind[574]: Failed to start user service: Unknown unit: user@108.service
[   10.472962] systemd-logind[574]: New session c1 of user lightdm.
[   14.980339] PHY: gmac0-0:00 - Link is Up - 1000/Full
[   70.257482] CPU Budget:update CPU 0 cpufreq max to 1200000 min to 480000
[  129.396969] systemd-logind[574]: Failed to start user service: Unknown unit: user@0.service
[  129.410768] systemd-logind[574]: New session 1 of user root.
And this is the dmesg of Debian distribution

[    6.626250] RTL871X: module init start
[    6.638429] RTL871X: rtl8189es v4.3.0.4_11916.20140724_COB
[    6.652480] RTL871X: build time: Jun 20 2015 18:01:48
[    6.653525] systemd[1]: Started Set Up Additional Binary Formats.
[    6.653670] systemd[1]: Mounted Huge Pages File System.
[    6.653762] systemd[1]: Mounted POSIX Message Queue File System.
[    6.653828] systemd[1]: Starting LSB: Set keymap...
[    6.722754] [wifi_pm]: set wl_reg_on 0 !
[    6.783810] [mmc]: sdc1 set ios: clk 0Hz bm PP pm UP vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    6.801753] [mmc]: sdc1 power_supply is null
[    6.830030] [mmc]: sdc1 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    6.846572] systemd[1]: Starting Journal Service...
[    6.862378] [mmc]: *** sunxi_mci_dump_errinfo(L826): smc 1 err, cmd 52,  RTO !!
[    6.863232] [mmc]: *** sunxi_mci_dump_errinfo(L826): smc 1 err, cmd 52,  RTO !!
[    6.863280] [mmc]: sdc1 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    6.865820] [mmc]: sdc1 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    6.883795] [wifi_pm]: set wl_reg_on 1 !
[    6.883989] RTL871X: module init ret=0
[    6.924601] [mmc]: *** sunxi_mci_dump_errinfo(L826): smc 1 err, cmd 8,  RTO !!
[    6.924631] *******************Try sdio*******************
[    6.956363] [mmc]: sdc1 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing LEGACY(SDR12) dt B
[    6.992036] [mmc]: sdc1 set ios: clk 400000Hz bm PP pm ON vdd 3.3V width 1 timing SD-HS(SDR25) dt B
[    7.007507] [mmc]: sdc1 set ios: clk 50000000Hz bm PP pm ON vdd 3.3V width 1 timing SD-HS(SDR25) dt B
[    7.023158] [mmc]: sdc1 set ios: clk 50000000Hz bm PP pm ON vdd 3.3V width 4 timing SD-HS(SDR25) dt B
[    7.039337] mmc1: new high speed SDIO card at address 0001
[    7.056934] bFWReady == _FALSE call reset 8051...
[    7.088518] bFWReady == _FALSE call reset 8051...
[    7.116516] systemd[1]: Started Journal Service.
[    7.119992] bFWReady == _FALSE call reset 8051...
[    7.142974] RTL871X: rtw_ndev_init(wlan0)
[    7.143952] RTL871X: rtw_ndev_init(wlan1)
[    7.145210] *******************sdio init ok*******************
[    8.204104] systemd-udevd[114]: starting version 215
[   18.008298] systemd-journald[107]: Received request to flush runtime journal from PID 1
[   34.895479] gmac0: probed
[   34.903864] gmac0 gmac0: eth0: eth0: PHY ID 001cc915 at 0 IRQ poll (gmac0-0:00)
[   35.320203] ==> rtl8188e_iol_efuse_patch
[   35.550841] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   35.560094] RTL871X: nolinked power save enter
[   35.564668] ADDRCONF(NETDEV_UP): wlan1: link is not ready
[   35.636966] vmouse_input_dev_open
[   36.410217] ==> rtl8188e_iol_efuse_patch
[   36.608381] RTL871X: nolinked power save leave
[   37.920096] RTL871X: nolinked power save enter
[   40.900362] PHY: gmac0-0:00 - Link is Up - 1000/Full
[   59.340267] ==> rtl8188e_iol_efuse_patch
[   59.573461] RTL871X: nolinked power save leave
[   60.890147] RTL871X: nolinked power save enter
[   92.410428] ==> rtl8188e_iol_efuse_patch
[   92.633237] RTL871X: nolinked power save leave
[   93.950114] RTL871X: nolinked power save enter
[  135.430423] ==> rtl8188e_iol_efuse_patch
[  135.673938] RTL871X: nolinked power save leave
[  138.980146] RTL871X: nolinked power save enter
[  188.410427] ==> rtl8188e_iol_efuse_patch
[  188.653933] RTL871X: nolinked power save leave
[  189.970128] RTL871X: nolinked power save enter






1

Threads

39

Posts

137

Credits

Registered member

Rank: 2

Credits
137
Post time 2015-6-25 05:25:41 | Show all posts
Laboris,
I still see no create_sdcard script in the make_linux.tar.gz.
I unzipped it then grep the tar for it:
mark@orangepi:~/kernel-build$ tar -tvf make_linux.tar | grep create
-rwxrwxr-x boris/boris   12149 2015-06-23 18:00 make_linux/create_image

Not create_sdcard, only create_image.  Is that the actual file name of the script?

Thanks.
Mark

10

Threads

448

Posts

4081

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4081
 Author| Post time 2015-6-25 07:39:13 | Show all posts
markwinger replied at 2015-6-25 05:25
Laboris,
I still see no create_sdcard script in the make_linux.tar.gz.
I unzipped it then grep the t ...

You are right, the name of the main script is create_image.
Sorry.

1

Threads

6

Posts

29

Credits

Novice

Rank: 1

Credits
29
Post time 2015-6-25 11:48:02 | Show all posts
Good job!
   Please help me to change the resolution, @loboris, my display is older enough,so,I can't display with the 1080P resolution,I can't display the desktop of mate, If any ideas?

0

Threads

6

Posts

78

Credits

Registered member

Rank: 2

Credits
78
Post time 2015-6-25 16:15:39 | Show all posts

Problems with Debian

Edited by Petr at 2015-6-25 16:26

loboris, thank you very much for the debian image.

I found thre problems. I am linux newbie, so please be patient.

1) I can't mount SATA drive using /etc/fstab on boot. I think it could be this problem https://bbs.archlinux.org/viewtopic.php?id=161814. When I add "noauto" attribut, it boot normaly (just without mounting the drive). Is there any boot log?

  1. # OrangePI fstab
  2. tmpfs /tmp  tmpfs nodev,nosuid,mode=1777  0 0

  3. UUID=a4b59a60-ccbb-41e1-a7e7-b048bf57b482  /mnt  ext4 defaults,noatime,nodiratime,noauto 0 1
Copy the Code

2) Worse problem  - it stops working randomly. I can't ping it. I can only unplug and plug the power. Where I can find logs, that could help me to determine the problem?

3) Process "kswapd0" has 100% CPU sometimes. I foud this "solution":
  1. echo 3 > /proc/sys/vm/drop_caches
Copy the Code

But is there any other way?

Thank you very much.

Best regards,
Petr


10

Threads

448

Posts

4081

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4081
 Author| Post time 2015-6-25 17:29:12 | Show all posts
Petr replied at 2015-6-25 16:15
loboris, thank you very much for the debian image.

I found thre problems. I am linux newbie, so ple ...

Could you give me some more information:

Can you mount your sata drive manualy, is it formated as ext4, does it have thet UUID ?
Can you check and post the output of
  1. sudo blkid
Copy the Code
Have you changed anything about swap ?
Are you running something when it stops ?

10

Threads

448

Posts

4081

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4081
 Author| Post time 2015-6-25 17:31:41 | Show all posts
joole.sy replied at 2015-6-25 11:48
Good job!
   Please help me to change the resolution, @loboris, my display is older enough,so,I can' ...

I'll upload u-boot with 720p resolution soon.

You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-11-24 06:30 GMT+8 , Processed in 0.035770 second(s), 20 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list