Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
123
Return to list New
Author: gaara

why an HDMI -> DVI adapter doesn't work ?

[Copy link]

0

Threads

23

Posts

114

Credits

Registered member

Rank: 2

Credits
114
Post time 2015-11-8 06:00:54 | Show all posts
Edited by marekwolek at 2015-11-8 07:42
tokka replied at 2015-11-7 21:40
Hi guys, have you tried with an hdmi->dvi cable? (without adapter)
I'm using it with op a20 (not the ...

Hi

Allwinner A20 in not compatybile Allwinner H3 .
Different address space and timing core ,timing bus( AHB ,VBP) , numbr of core. Different prescaler setings.

I think that problem in not monitor resolution. My monitor should by display all resolution screen declare in script.bin.
frequency refresh must by 60hz.

Problem is bad signal  . too high or too low  frequency?  
Maybe bad frequency data frame or refresh ?

Maybe is defective data frame ? ( soft is work in orange pi and it is all ok . data frame should by ok). Audio signal be interlaced with signal of Video it Can here problem is ?

Cable HDMI-DVI is OK .
Monitor <--- cable HDMI-DVI  <----  PC                    : it work .   
Monitor <----cable HDMI-DVI <----- Orange Pi plus  : does not work .


16

Threads

105

Posts

989

Credits

Senior member

Rank: 4

Credits
989
Post time 2015-11-8 19:15:56 | Show all posts
Hi
ok sorry, i was thinking we were talking about Gpu, not Cpu, my mistake.
Good luck ;)
OrangePi A20, with Qbee-X_testing

Still waiting for refund/replacement of no working op+2e bought on 11/11 >_<...really serious company

0

Threads

23

Posts

114

Credits

Registered member

Rank: 2

Credits
114
Post time 2015-11-8 22:14:19 | Show all posts
Edited by marekwolek at 2015-11-9 02:29
tokka replied at 2015-11-8 19:15
Hi
ok sorry, i was thinking we were talking about Gpu, not Cpu, my mistake.
Good luck ;)

Allwinner A20  and Allwinner H3 have the same cpu core  ARM Cortex A7 .Allwinner A20  and Allwinner H3 have the same GPU core  Mali400 MP2 @ 600Mhz .

Orange PI (banaba pi ) have Allwinner A20 @ 1 Ghz     Dual  core  and GPU Mali400MP2  - Hdmi is work.
Orange Pi plus              have Allwinner H3   @ 1,6 Ghz Quad core  and GPU Mali400MP2  - Hdmi does not work.

GPU Mali 400MP2 driver is identical for A20 and H3.  in A20 it  work  well , but H3 does not work.
Driver mali is Good. Problem lies more deeply.
Maybe problem is hardware? And not will be give repair him of software?


I put  picture http://www.orangepi.org/orangepibbsen/data/attachment/forum/201511/01/020538saarzqoohayqmyqa.jpg. You see  this picture?
Resolution screen has be ok . but picture have green artefacts.
Digital transmision and artefacts ???
Error in digital broadcast depend from :
1 hardware demage     (Orange pi plus don't have ESD protection )
2 Synchronisation of data packets ( prescaler seting problem , hardware problem)
3 Software problem.  ( driver Mali 400MP2 is ok . driver it work A20 banana pi , Orangepi. No problem)
4 emi      ( Designer  wrongly disposed components  and wire .)

http://www.arm.com/products/processors/cortex-a/cortex-a7.php

0

Threads

23

Posts

114

Credits

Registered member

Rank: 2

Credits
114
Post time 2015-11-12 20:54:04 | Show all posts
tokka replied at 2015-11-8 12:15
Hi
ok sorry, i was thinking we were talking about Gpu, not Cpu, my mistake.
Good luck ;)

My bord is broken. HDMI is not work . I try conect to monitor using cable HDMI->DVI  and converter HDMI -> VGA  .  Android build in board not work. Screan is black .I try use  Ubuntu , Debian , Lubuntu , android ( in board)  .

3

Threads

44

Posts

962

Credits

Senior member

Rank: 4

Credits
962
Post time 2015-11-12 22:06:04 | Show all posts
I have HDMI to DVI working on my Orange Pi PC. I followed the tutorial from zipob in this post:

http://www.orangepi.org/orangepi ... wthread&tid=475

I am using an Acer X203H monitor, OP PC,  and Debian 8 from loboris post:

http://www.orangepi.org/orangepi ... wthread&tid=342

It looks perfect on the monitor. I also plugged in a $0.99 wifi dongle from ebay and I had WIFI. I do need to disable and re-enable networking on each boot to get it to connect though.

My OP PC seems to work right out of the box with this OS from loboris. I am in the process of loading WiringPi today to begin working with the GPIO.

I am very impressed in buying such an inexpensive computer and within an hour of unboxing have it running well. Seems like a very solid design so far. Special thanks to such smart forum members like loboris and zipob.

0

Threads

23

Posts

114

Credits

Registered member

Rank: 2

Credits
114
Post time 2015-11-13 02:15:33 | Show all posts
phreon replied at 2015-11-12 15:06
I have HDMI to DVI working on my Orange Pi PC. I followed the tutorial from zipob in this post:

htt ...

You are lucky because you got working orange pi
I had  unlucky  Orange Pi.


My board not work . I have Orange Pi plus.

3

Threads

44

Posts

962

Credits

Senior member

Rank: 4

Credits
962
Post time 2015-11-13 09:34:14 | Show all posts
marekwolek replied at 2015-11-13 02:15
You are lucky because you got working orange pi
I had  unlucky  Orange Pi.

Hi marekwolek,
can you ssh into your PI and see how healthy it is? It looks like you pic of the green screen you are getting has a login prompt or something. Do you have a HDMI TV you can test the board with?
P

0

Threads

8

Posts

127

Credits

Registered member

Rank: 2

Credits
127
Post time 2015-11-14 00:22:52 | Show all posts
here is my uImage and script bin for 4/3 monitors.
possible resolutions are 1280x1024 and 1024x768.
With the attached script.bin the resolution is 1280x1024. To change to 1024x768 you have to edit the script.fex

720p_50 -> 1024x768
720p_60 -> 1280x1024

  1. https://www.sendspace.com/file/ub5l39
Copy the Code

1

Threads

2

Posts

25

Credits

Novice

Rank: 1

Credits
25
Post time 2015-11-18 13:25:40 | Show all posts
I have the same problem . I have also seen it with the Banana Pi which uses the Allwinner A20  and the ODROID-C1 which uses the Amlogic S805.

The Banana Pi was fixed by changing a line in the u-boot uEnv.txt file. I tried to add the uEnv.txt file to the Orange Pi boot directory mainly because I wasn't
sure what to put in the fex file and I can't find any documentation on the HDMI section options there even after a couple of hours Googling. I didn't really
expect it to work and it didn't.

The ODROID-C1 is just very sensitive to the length of the cables/adapters. If I keep every thing as short as possible (and I mean very short) it works.

Never had any problems with any of the Raspberry Pi models or the CubieBoard 1 even after running them through HDMI switches which I believe do
attenuate the video signals slightly.

I only have one monitor with HDMI input and several with DVI input so I really need the Orange Pi to work with DVI monitors.

You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2019-10-20 02:57 GMT+8 , Processed in 0.036599 second(s), 20 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list