Built PHP on ARM, cannot load libphp7.so in apache2: unexpected reloc type 0x03 看全部

Hello,

I built PHP 7.2.5 on a armv7l single-board computer (Orange Pi PC) running Armbian Stretch (Linux 4.14.18-sunxi). I used this resource as a reference: http://yoestuve.es/blog/compile- ... pi-with-memcached/.
However, after compiling and installing successfully, the apache2 webserver cannot start due to the following error:
  1. Cannot load /usr/lib/apache2/modules/libphp7.so into server: /usr/lib/apache2/modules/libphp7.so: unexpected reloc type 0x03

Hence, I built PHP once again with the
  1. CFLAGS='\-fPIC'

attribute, but this lead to the same result.

Using the mentioned procedure above, I had successfully compiled and installed PHP 7.2.1 before on another SBC (Banana Pi) running Bananian Linux and apache2 2.4.25-3+deb9u3.
I already tried downgrading the apache2 server from 2.4.25\-3\+deb9u4 to 2.4.25\-3\+deb9u3 and building and installing PHP 7.2.1. Unfortunately, the error persists.

The system is up-to-date.
Perhaps some package is missing or is at the wrong version? Here is the output of dpkg --get-selections: https://pastebin.com/yNWuL2v5

Any help would be appreciated. Thank you in advance!


I learned a lot from your blog. If you want to have more fun, you can learn more about old video games. It's going to be fun to play with you again! trap the cat