Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 981|Reply: 4

Building Ubuntu with scripts

[Copy link]

2

Threads

4

Posts

16

Credits

Novice

Rank: 1

Credits
16
Post time 2018-8-31 20:08:58 | Show all posts |Read mode
Hello,


I'm trying to build Ubuntu Xenial with these scripts.
Everithing in params.sh file is set properly, but when I run create image script. I got the following error:

пт авг 31 14:42:59 EEST 2018
=======================================================
Creating Ubuntu/Debian SD Card instalation for OrangePI
=======================================================

Creating root filesistem in local directory linux-xenial...

DEBOOTSTRAP, FIRST STAGE
OK.                        
Creating "sources.list"
Error while loading /bin/bash: No such file or directory
================================================
ERROR on second-stage, instalation NOT FINISHED.


So, I found what cause this error. It was this line:

+ chroot linux-xenial /usr/bin/qemu-arm-static -cpu cortex-a9 /bin/bash /second-stage
Error while loading /bin/bash: No such file or directory


I'm using Ubuntu 16.04

Now, I'm stuck with this error.
Need your help!
Thank you!



8

Threads

617

Posts

4166

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4166
Post time 2018-9-1 00:00:55 | Show all posts

2

Threads

4

Posts

16

Credits

Novice

Rank: 1

Credits
16
 Author| Post time 2018-9-3 16:39:31 | Show all posts
Thank you very much, @igorpec. I was able to compile successfully armbian image. But, now I have another problem. I need to load vfe_v4l2. When I try sudo modprobe vfe_v4l2 I have the following message:

modprobe: FATAL: Module vfe_v4l2 not found in directory /lib/modules/4.14.67-sunxi

Modules are in /lib/modules/4.14.67-sunxi/kernel/drivers

I need to load also ov5647 module (my camera is with this sensor), but can't find that module in /lib/modules/4.14.67-sunxi/kernel/drivers/media/i2c. How to compile that module?
I need that modules to start motion

Thank you for your help!

8

Threads

617

Posts

4166

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4166
Post time 2018-9-3 21:02:12 | Show all posts
I need to load vfe_v4l2. When I try sudo modprobe vfe_v4l2


If you didn't enable it in kernel configuration as a module, it can't exist. I am not sure how is with camera support in the modern kernel. Perhaps you will need to stick to old 3.4.y kernel ...

2

Threads

4

Posts

16

Credits

Novice

Rank: 1

Credits
16
 Author| Post time 2018-9-3 21:09:04 | Show all posts
I understand. The problem with 3.4 kernel is that sunxi ov5647 module didn't work at all. However, thank you very much for your help!
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2019-11-19 13:01 GMT+8 , Processed in 0.031754 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list