please choosego to mobile | Continue to access the PC version
View: 7267|Reply: 2

[Solved - don't buy OPiZ] OPi Zero stuck in endless config loop

[Copy link]

10

threads

36

posts

154

credits

Registered member

Rank: 2

credits
154
Published in 2018-9-7 06:20:10 | Show all floors |Read mode
Edited by Bazmundi at 2018-9-8 11:35

A quite useless behaviour in my freshly installed Ubuntu CORE 16 enabled Orange Pi Zero has arisen.

  • I installed Ubuntu CORE 16 onto device.
  • I registered the device.
  • I left the device running to see the effect of an update on the device.
  • Update came through and device did not restart.
  • Device falls back into configuration loop and never gets out.
  • The terminal on the serial port was prompting me with the configuration prompts.
  • After answering yes to all prompts, the device just fell through into a new configuration prompt.  It just keeps looping through the intial configuration prompt - over and over and over.
  • The device cycled through each time grabbing new IP address.
  • The device is otherwise useless.
  • I cannot see why a refresh would want to start from config, it would mean any device would stop dead on update and would need manual reconfig?
  • The only way to recover the device is to take out SD and re-etch the Ubuntu Core 16 again.  That would be at least a daily occurance so why was this image released if it is broken?

I have tried this on two OPiZ.  Same problem on both.
I cannot recommend Orange Pi Zero or Ubuntu Core 16 on Orange Pi Zero.  

10

threads

36

posts

154

credits

Registered member

Rank: 2

credits
154
 Author| Published in 2018-9-8 09:39:44 | Show all floors
Edited by Bazmundi at 2018-9-8 11:37

  • The problem is with the Ubuntu update mechanism and delays on the internet. There is what I call the doldrums which is southern hemisphere is blocked out of access to northern hemisphere servers when northern hemisphere is awake and users are throttling servers.
  • Whenever I try connecting to ubuntu core device at night time southern hemisphere I will often get a snap does not exist message or connection timeout with some message about missing headers. This is just round trip problem over the internet over distances and server loading.
  • This morning (saturday morning southern hemisphere and northern hemisphere asleep) I reburnt the Ubuntu CORE 16 Orange Pi onto SD, loaded it, started device, let device go through it’s obligatory first update and it came back up! That is it did not lock into config loop after update came through.
  • This indicates that the update, also prone to having to travel across planet, is sensitive to timeouts and frags the device that is updating.
  • Therefore, snap technology, binding to commercial entity in northern hemisphere appears unfriendly to southern hemisphere.
  • The only solution, since you cannot avoid the updates, is to set the updates to quiet time in northern hemisphere.  That is not a useful approach either as there is still no guarantee the device will not be fragged at some point.

4

threads

96

posts

931

credits

Senior member

Rank: 4

credits
931
Published in 2018-9-8 17:05:10 | Show all floors
OPi zero working great on Armbian... has to be Ubuntu Cores' fault.
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list