Forum > Armbian
BryanFRitt 看全部
2019-5-2 08:18:19
Edited by BryanFRitt at 2019-5-28 01:17

I can't boot into my Orange Pi.

At first I noticed that the ethernet wasn't working(after an update?), but the wireless was. Trying to fix it I impulsively chose the install different kernel fom armbian-config. Now it's not booting.

I've now made a abackup of that image(I can go back to this if needed, wish I made a backup when it was working), and started playing around with that backup to see if I could fix the issue, but no luck so far.

Stuff I've tried:
I can do a `chroot` into the image and run commands
sudo apt-get update
sudo apt-get upgrade
sudo apt-get --reinstall install $(dpkg --get-selections | cut -f1 | tr '\n' ' ') # aka reinstalling everything

I`ve tried downloading a new orange pi image and it seamed to work fine with my brief test(didn't even log in), but I don't really want to have to redo everything.

Not sure what information you might need to help me, but here are some things I came across that might be something: (ideas?)

** File not found /boot/zImage **

-rw-rw-r-- 1 root root    3708 2018-01-27 13:28 boot.scr
-rwxr-xr-x 1 root root 7476688 2019-04-08 01:46 vmlinuz-4.19.25-sunxi
lrwxrwxrwx 1 root root      21 2019-05-01 17:18 zImage -> vmlinuz-4.19.25-sunxi

no partition table

* ERROR: `serverip` not set /000000 (repeats message with below, but with one less 0 until there are none.)

Retrieving file: prelinux.cfg

missing environment variable: bootfile

BOOTP broadcast 1 (goes up to 17 and then says a  message and repeats)

'RESEARCHING ISSUES UPDATE: I found https://github.com/armbian/build/issues/319 which looks simular to boot screens I have.

'CHROOT UPDATE': It seams that `chroot` isn't saving changes I make. When I unmount then remount the partition my CHANGES ARE GONE.
Now I've even tried to format the card with gparted and no changes were made! Tried it from a microSDtoSD card holder and a microsSDtoUSB reader, same results. Guessing either the card is bad or the host OS is messing up, guess I'll try from a Windows installation later. If I couldn't write to the drive anymore, why wasn't I getting any messages saying so?
NOTE: This was just the card that I was testing out fixes with, not the original card that was in the Orange Pi when all of this started.

SUDO=$(which sudo) # /usr/bin/sudo on this system
#$SUDO /bin/mkdir -p $CHROOT # only needed if directory doesn't exist
#$SUDO qemu-debootstrap --arch armel stretch $CHROOT http://deb.debian.org/debian/ # this needs to be done one time
SUDO=$(which sudo) # /usr/bin/sudo on this system
$SUDO /bin/mount /dev/mmcblk0 $CHROOT
$SUDO /bin/mount --bind /dev/ $CHROOT/dev
$SUDO /bin/mount --bind /dev/pts $CHROOT/dev/pts
$SUDO /bin/mount --bind /dev/shm $CHROOT/dev/shm
$SUDO /bin/mount -t sysfs sysfs $CHROOT/sys
$SUDO /bin/mount -t proc proc $CHROOT/proc
$SUDO cp -L /etc/resolv.conf $CHROOT/etc/resolv.conf
$SUDO chroot $CHROOT

/bin/echo "to uninstall this chroot :"
/bin/echo "for i in /tmp /run /proc /sys /dev/pts /dev/shm /dev \"\"; do $SUDO /bin/umount $CHROOT\$i ; done"
/bin/echo "do double checkk that $CHROOT got unmounted..."
/bin/echo "$SUDO /bin/umount $CHROOT"

'MONEY' UPDATE: I saw that I could give 'money' for answers to this, I didn't think it would take away any 'money' until someone answers. Thought these would be maximum amounts that I could change unused 'money' amounts, and it wouldn't affect my 'user group'. If I had know they weren't I might have changed the options.

It put me back at 'novice' with 'zero' money . 1st time trying out the 'money' feature. What are the odds that I'll get 112 replies from 12+ users to this post?
I don't see any ways to change the 'money' settings for this post
No way to get 'money' back even if no one answers?
Is there a forum moderator that could help me change this?


Looks like I had to 'earn' enough 'money' to go back to being in the 'Registered member' group to get my 'money' back. Leaving alone for now. I think there's something wrong with how some things are calculated, like it subtracts when it should add, or something is exclued/included when it should be included/excluded.

I redid my Orange Pi instead of trying to fix this problem. 1st redo attempt had the Pi taking up all available nnn.nnn.nnn.1..253 IPs according to the router.

igorpec 看全部
2019-5-4 20:35:19
When selecting another kernel, you had received a warning that board might not boot ...

I don't understand what you are trying to do ... start with a clean image.
basaltonerous 看全部
2022-6-22 17:00:26
This post was finally edited by basaltonerous at 2022-7-1 09:46

Seems like I had to re-join the "Registered member" group in order to reclaim my "money." For the time being, I'm going to leave you to your own devices. In my opinion, the way certain items are computed is incorrect; for example, it seems to be subtracting when it should be adding, or including when it should be excluding.


OrangePi En

Powered by Discuz! X3.4

homepage|Simple edition|Touch edition|PC