Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: gaara

Mali GPU driver

[Copy link]

18

Threads

303

Posts

7920

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
7920
Post time 2015-11-14 19:53:29 | Show all posts
Here is the U2B video playback test I did after successfully installed GPU driver. Freeze randomly.
http://pan.baidu.com/s/1ntnKGJZ

7

Threads

100

Posts

647

Credits

Senior member

Rank: 4

Credits
647
Post time 2015-11-15 00:27:42 | Show all posts

Has I understand this correct that with CedarX videos are normal and not very slow?

Is there somewhere a manual how to install CedarX on ubuntu.

THX


11

Threads

286

Posts

1874

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1874
Post time 2015-11-15 06:00:28 | Show all posts
On smplayer selecting sdl output driver on video options can play hd ready video no problem,vlc with opengl new embabed system 2 run better

11

Threads

286

Posts

1874

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1874
Post time 2015-11-15 09:28:30 From the mobile phone | Show all posts
Edited by melanrz at 2015-11-15 21:10

Im able to get score 95ptson windowed and score 62pts full screen,minimal x11 loaded, 720p,libuntu. I post screenshots .

18

Threads

303

Posts

7920

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
7920
Post time 2015-11-15 11:34:47 | Show all posts
melanrz replied at 2015-11-15 09:28
Im able to get 95fps on windowed and 62fps full screen,minimal x11 loaded, 720p,libuntu. I post scre ...

What is your score number of glmark2-es2 using 720P?

7

Threads

100

Posts

647

Credits

Senior member

Rank: 4

Credits
647
Post time 2015-11-15 17:43:33 | Show all posts
I got these results: are they ok?
root@OrangePI:~# glmark2-es2=======================================================
    glmark2 2014.03+git20150611.fa71af2d
=======================================================
    OpenGL Information
    GL_VENDOR:     ARM
    GL_RENDERER:   Mali-400 MP
    GL_VERSION:    OpenGL ES 2.0
=======================================================
[build] use-vbo=false: FPS: 34 FrameTime: 29.412 ms
[build] use-vbo=true: FPS: 44 FrameTime: 22.727 ms
[texture] texture-filter=nearest: FPS: 52 FrameTime: 19.231 ms
[texture] texture-filter=linear: FPS: 50 FrameTime: 20.000 ms
[texture] texture-filter=mipmap: FPS: 63 FrameTime: 15.873 ms
[shading] shading=gouraud: FPS: 37 FrameTime: 27.027 ms
[shading] shading=blinn-phong-inf: FPS: 43 FrameTime: 23.256 ms
[shading] shading=phong: FPS: 41 FrameTime: 24.390 ms
[shading] shading=cel: FPS: 36 FrameTime: 27.778 ms
[bump] bump-render=high-poly: FPS: 28 FrameTime: 35.714 ms
[bump] bump-render=normals: FPS: 48 FrameTime: 20.833 ms
[bump] bump-render=height: FPS: 67 FrameTime: 14.925 ms
[effect2d] kernel=0,1,0;1,-4,1;0,1,0;: FPS: 58 FrameTime: 17.241 ms
[effect2d] kernel=1,1,1,1,1;1,1,1,1,1;1,1,1,1,1;: FPS: 39 FrameTime: 25.641 ms
[pulsar] light=false:quads=5:texture=false: FPS: 83 FrameTime: 12.048 ms
[desktop] blur-radius=5:effect=blur:passes=1:separable=true:windows=4: FPS: 36 FrameTime: 27.778 ms
[desktop] effect=shadow:windows=4: FPS: 69 FrameTime: 14.493 ms
Error: Requested MapBuffer VBO update method but GL_OES_mapbuffer is not supported!
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=map: Unsupported
[buffer] columns=200:interleave=false:update-dispersion=0.9:update-fraction=0.5:update-method=subdata: FPS: 18 FrameTime: 55.556 ms
Error: Requested MapBuffer VBO update method but GL_OES_mapbuffer is not supported!
[buffer] columns=200:interleave=true:update-dispersion=0.9:update-fraction=0.5:update-method=map: Unsupported
[ideas] speed=duration: FPS: 55 FrameTime: 18.182 ms
[jellyfish] <default>: FPS: 65 FrameTime: 15.385 ms
Error: SceneTerrain requires Vertex Texture Fetch support, but GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS is 0
[terrain] <default>: Unsupported
[shadow] <default>: FPS: 74 FrameTime: 13.514 ms
[refract] <default>: FPS: 23 FrameTime: 43.478 ms
[conditionals] fragment-steps=0:vertex-steps=0: FPS: 78 FrameTime: 12.821 ms
[conditionals] fragment-steps=5:vertex-steps=0: FPS: 193 FrameTime: 5.181 ms
[conditionals] fragment-steps=0:vertex-steps=5: FPS: 291 FrameTime: 3.436 ms
[function] fragment-complexity=low:fragment-steps=5: FPS: 156 FrameTime: 6.410 ms
[function] fragment-complexity=medium:fragment-steps=5: FPS: 49 FrameTime: 20.408 ms
[loop] fragment-loop=false:fragment-steps=5:vertex-steps=5: FPS: 78 FrameTime: 12.821 ms
[loop] fragment-steps=5:fragment-uniform=false:vertex-steps=5: FPS: 69 FrameTime: 14.493 ms
[loop] fragment-steps=5:fragment-uniform=true:vertex-steps=5: FPS: 72 FrameTime: 13.889 ms
=======================================================
                                  glmark2 Score: 68
=======================================================

11

Threads

286

Posts

1874

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1874
Post time 2015-11-15 21:22:22 | Show all posts
jacer replied at 2015-11-15 11:34
What is your score number of glmark2-es2 using 720P?

i edit post,its scores.

18

Threads

303

Posts

7920

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
7920
Post time 2015-11-16 21:19:07 | Show all posts
melanrz replied at 2015-11-15 21:22
i edit post,its scores.

How to install glmark2-es2 on Debian? There is no reposite package.

11

Threads

286

Posts

1874

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1874
Post time 2015-11-18 04:01:47 | Show all posts
Quake 3 benchmark windowed
https://www.youtube.com/watch?v=RyIeQQ7tut8

2

Threads

21

Posts

86

Credits

Registered member

Rank: 2

Credits
86
Post time 2015-11-18 09:48:36 | Show all posts
Hi guys,
I have an OPI2 board with loboris's Lubuntu image (coming with mali r4p0 kernel modules).
Mali modules can be installed w/o any problem by:
modprobe ump
modprobe drm
modprobe mali
modprobe mali_drm

I uninstalled mesa stuff and I installed user-space r4p0 mali binary driver using this repo: github.com/WhiteWind/sunxi-mali
I installed xf86-video-fbturbo using github.com/ssvb/xf86-video-fbturbo/tree/master (Xorg.0.log confirms that the driver is loaded with success).

Unfortunately glmark2-es2 fails:
eglInitialize() failed with error 0x3003
eglInitialize() failed with error 0x3003
main: Could not inizialize canvas

Please help! thanks
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-6-6 03:31 GMT+8 , Processed in 0.031842 second(s), 20 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list