Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: gaara

Mali GPU driver

[Copy link]

2

Threads

21

Posts

86

Credits

Registered member

Rank: 2

Credits
86
Post time 2015-11-19 23:31:21 | Show all posts
And make sure that you use proper libUMP.so. I compiled it from sources.

compiled from sources too...

2

Threads

21

Posts

86

Credits

Registered member

Rank: 2

Credits
86
Post time 2015-11-21 07:40:21 | Show all posts
Edited by barban at 2015-11-21 07:47

Hi all,
just to let you know that I suceeded to let it work by disablig GLX/AIGLX in X11
In /etc/X11/xorg.conf
Section "Device"
        Identifier      "Allwinner A10/A13 FBDEV"
        Driver          "fbturbo"
        Option          "fbdev" "/dev/fb0"

        Option          "SwapbuffersWait" "true"
EndSection

Section "Screen"
         Identifier      "My Screen"
         Device          "fbturbo device"
         Monitor         "My Monitor"
EndSection

Section "DRI"
        Mode 0666
EndSection

Section "Serverflags"
        Option  "AIGLX" "false"
EndSection

Section "Module"
        Disable "glx"
EndSection

1

Threads

116

Posts

661

Credits

Senior member

Rank: 4

Credits
661
Post time 2015-11-21 15:17:05 | Show all posts
Edited by magicse at 2015-11-21 10:32
hojnikb replied at 2015-11-18 23:45
Is there a premade image, that has the gpu driver and fbturbo configured ?

Anyone ?

5

Threads

355

Posts

2131

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
2131
Post time 2015-11-21 16:22:17 | Show all posts
Yes
I will release Hamburger PI with full sources on Facebook in one month!
Sorry, was only a joke.

Build it yourself, at least you learn something!
Boards:
orangepi plus, olinuxino A20, cubieboard A10, mele A2000 .....

18

Threads

200

Posts

841

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
841
Post time 2015-11-21 16:31:59 | Show all posts
barban replied at 2015-11-19 17:29
Thanks for the suggestion but the lines are already in my script.hex...

This error is 100% due to the fact that the driver does not find [mali_param] in script.bin! So again, check and create the new script.bin
Orange PI 2
www.orangepi.pp.ua

18

Threads

200

Posts

841

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
841
Post time 2015-11-21 16:33:10 | Show all posts

GPU modules for Lubuntu 1404 0.9.0

Edited by magicse at 2015-11-21 11:14

I made one only for oficial  Lubuntu 1404 0.9.0/ And it worked well

GPU modules for Lubuntu 1404 0.9.0


Orange PI 2
www.orangepi.pp.ua

1

Threads

116

Posts

661

Credits

Senior member

Rank: 4

Credits
661
Post time 2015-11-21 20:29:53 | Show all posts
It would be great if someone actually build a whole Ubuntu or Lubuntu around those fixes. So novice users can enjoy this too.

Or maybe just a shell scrip, that installs everything.

4

Threads

52

Posts

284

Credits

Intermediate member

Rank: 3Rank: 3

Credits
284
Post time 2015-11-21 20:53:05 | Show all posts
In fact, this already exist!

If you install plain Loboris Vivid + desktop of your choice and then download the GPU tutorial pack from the instructions thread (click here) in this forum you will succeed. No compiling necessary, all the work is already done and you will find the step by step instructions in the gpupack file. If I can do it, you should be able to do it too!

It includes Mali400 acceleration and fbturbo driver.

18

Threads

303

Posts

7920

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
7920
Post time 2015-11-21 21:20:44 | Show all posts
Edited by jacer at 2015-11-21 21:21
magicse replied at 2015-11-21 16:33
I made one only for oficial  Lubuntu 1404 0.9.0/ And it worked well

GPU modules for Lubuntu 1404 0 ...

I get two errors like below. Any fix?
  1. Error: Requested MapBuffer VBO update method but GL_OES_mapbuffer is not supported!
  2. Error: SceneTerrain requires Vertex Texture Fetch support, but GL_MAX_VERTEX_TEXTURE_IMAGE_UNITS is 0
Copy the Code
Used this setting below.
  1. # This is a minimal sample config file, which can be copied to
  2. # /etc/X11/xorg.conf in order to make the Xorg server pick up
  3. # and load xf86-video-fbturbo driver installed in the system.
  4. #
  5. # When troubleshooting, check /var/log/Xorg.0.log for the debugging
  6. # output and error messages.
  7. #
  8. # Run "man fbturbo" to get additional information about the extra
  9. # configuration options for tuning the driver.

  10. Section "Device"
  11.         Identifier      "Allwinner H3 FBDEV"
  12.         Driver          "fbturbo"
  13.         Option          "fbdev" "/dev/fb0"
  14.         Option          "DRI2"            "true"
  15.         Option          "SwapbuffersWait" "true"
  16. EndSection

  17. Section "DRI"
  18.     Mode 0666
  19. EndSection
Copy the Code



18

Threads

200

Posts

841

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
841
Post time 2015-11-21 21:52:28 | Show all posts
Edited by magicse at 2015-11-21 15:57
jacer replied at 2015-11-21 15:20
I get two errors like below. Any fix?
Used this setting below.

The same error on another devices with testing glmark2, and may be this function (https://www.khronos.org/registry ... S/OES_mapbuffer.txt) not implemented in blob
http://linux-sunxi.org/Benchmarks
I think this question to mali arm.

Orange PI 2
www.orangepi.pp.ua
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-6-6 02:19 GMT+8 , Processed in 0.032303 second(s), 20 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list