Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
12Next
Return to list New
View: 23939|Reply: 13

Orange PI PC, No sound [RESOLVE]

[Copy link]

1

Threads

7

Posts

73

Credits

Registered member

Rank: 2

Credits
73
Post time 2015-10-25 06:21:51 | Show all posts |Read mode
Edited by marl at 2015-10-31 03:51

I tried OrangePI-PC_Ubuntu_Vivid_Mate and OrangePI_Jessie_Xfce images from here http://www.orangepi.org/orangepi ... d=342&extra=&page=1


All is working except no sound in AV port. I'm not using HDMI, I used HDMI to VGA converter coz my monitor don't have HDMI.

2

Threads

42

Posts

1167

Credits

Gold member

Rank: 6Rank: 6

Credits
1167
Post time 2015-11-7 00:00:04 | Show all posts
Edited by Fourdee at 2015-11-7 00:02

Did some work on this today:

Set HDMI output as default:
  1. cat << _EOF_ > /etc/asound.conf
  2. pcm.!default {
  3.    type hw
  4.    card 1
  5. }

  6. ctl.!default {
  7.    type hw
  8.    card 1
  9. }
  10. _EOF_
Copy the Code


Set 3.5mm as output:
  1. cat << _EOF_ > /etc/asound.conf
  2. pcm.!default {
  3.    type hw
  4.    card 0
  5. }

  6. ctl.!default {
  7.    type hw
  8.    card 0
  9. }
  10. _EOF_
Copy the Code


Test with:
  1. speaker-test
Copy the Code


You can mute/unmute the 3.5mm (lineout) channel with:
  1. amixer set -c 0 'Audio lineout' unmute
  2. amixer set -c 0 'Audio lineout' mute
Copy the Code



I get an error when using type plughw in asound.conf:
  1. ALSA lib dlmisc.c:252:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/arm-linux-gnueabihf/alsa-lib/libasound_module_pcm_plughw.so
Copy the Code

However, i can run speaker test using plughw on both devices.
  1. speaker-test -Dplughw:1
  2. speaker-test -Dplughw:0
Copy the Code


DietPi - Lightweight justice for your Orange Pi. http://dietpi.com

0

Threads

3

Posts

54

Credits

Registered member

Rank: 2

Credits
54
Post time 2015-12-8 19:43:55 | Show all posts
It is a permissions problem.

Your user must be in the audio group to access the audio filesystem object. Normally "orangepi" user is not member of such group, in fact if you run speaker-test from root you should get audio from analog. More than this, as normal user you aren't even able to run alsamixer, because you don't have permissions.

To gain normal user access to audio, just add orangepi user to audio group in /etc/group, then log out and log in.
Nonetheless in my setup audio is quite low in volume when I run audio applications as standard user. It is ok when I run it as root.




2

Threads

4

Posts

120

Credits

Registered member

Rank: 2

Credits
120
Post time 2015-10-25 08:28:20 | Show all posts
I'm facing the same problem. In my case I'm using HDMI video output without converters.

1

Threads

7

Posts

73

Credits

Registered member

Rank: 2

Credits
73
 Author| Post time 2015-10-25 09:22:57 | Show all posts
Doumekxkai replied at 2015-10-25 08:28
I'm facing the same problem. In my case I'm using HDMI video output without converters.

Fixed mine. I disabled HDMI audio output on settings.

9

Threads

29

Posts

329

Credits

Intermediate member

Rank: 3Rank: 3

Credits
329
Post time 2015-10-25 15:25:55 | Show all posts
Im working with OrangePI_Jessie.

I will play mp3 from AV port, I cant found seeting.  alsamixer is ready. I need help plase.

1

Threads

7

Posts

73

Credits

Registered member

Rank: 2

Credits
73
 Author| Post time 2015-10-26 16:31:52 | Show all posts
linux34 replied at 2015-10-25 15:25
Im working with OrangePI_Jessie.

I will play mp3 from AV port, I cant found seeting.  alsamixer is  ...

yes, i have same OS. i don't have the device right now, once i have it i will post a screenshot here. you can explore in the meantime. i think it was in the sound settings.

0

Threads

3

Posts

30

Credits

Novice

Rank: 1

Credits
30
Post time 2015-10-30 04:26:26 | Show all posts
Some channels are probably muted.
It helps https://www.youtube.com/watch?v=-FgMni9I374

1

Threads

7

Posts

73

Credits

Registered member

Rank: 2

Credits
73
 Author| Post time 2015-10-30 14:34:32 | Show all posts
Tafka replied at 2015-10-30 04:26
Some channels are probably muted.
It helps https://www.youtube.com/watch?v=-FgMni9I374

Not muted. Just needed to disable the hdmi output so the other channel work. If two are enabled there is no output. That is what I have observe. So I fix mine by doing that.

18

Threads

303

Posts

7754

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
7754
Post time 2015-10-30 23:13:59 From the mobile phone | Show all posts
Run alsamixer and set mm of lineout.

0

Threads

6

Posts

150

Credits

Registered member

Rank: 2

Credits
150
Post time 2015-11-5 23:59:18 | Show all posts
marl replied at 2015-10-30 14:34
Not muted. Just needed to disable the hdmi output so the other channel work. If two are enabled th ...

Hello!
What do you mean"disable HDMI output"? Should I mute it in alsamixer or make some changes in X settings?
12Next
Return to list New
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2019-12-16 21:29 GMT+8 , Processed in 0.036044 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list