Forum > Debian
sopifore 看全部
2015-10-30 01:12:17
Edited by sopifore at 2015-10-30 01:18

My goal is to get as up-to-date a version of Debian on the Orange Pi Plus (H3 model) as possible with as much of the on-board hardware working as possible.

This post is to document how I got Debian working on an Orange Pi Plus with the on-board wifi. It took much trial and error and I attempted this with many different images as my starting point.

  • I used Win32DiskImager to write the image to a micro SD card
  • Using the OrangePI_Jessie_Xfce.img from 31-August-2015 was a good start. (this thread)
  • I followed the related instructions to download scriptbin_kernel.tar.gz from Oct 17 (same link)
  • I expanded the gz and unpack the tar
  • I followed the instructions to replace script.bin and uImage on the BOOT partition of the SD card
  • For my setup, I used script.bin.OPI-PLUS_1080p60_hdmi and uImage_OPI-PLUS; renaming them to  script.bin and uImage respectively
  • For convenience, I also copied the lib/modules folder and everything in it to the BOOT partition
  • I place the micro SD card into the RPi+ and booted it up with an HDMI monitor, USB keyboard, USB mouse, and Ethernet connected
  • I logged in as user: root password: orangepi
  • The ethernet (eth0) was working; the XFCE interface was rendered on my HDMI monitor
  • I opened two File System windows
  • I navigated one window to /lib and the other to /media/boot
  • I renamed /lib/modules to /lib/modules.original
  • I copied /media/boot/modules to /lib which gave me a new /lib/modules
  • I rebooted the OPi+
  • The console showed that wlan0 was renamed to rename7
  • I logged in as user: root password: orangepi
  • I edited /etc/udev/rules.d/70-persistent-net.rules
  • and commented out any lines which were not already commented out
  • I rebooted the OPi+
  • I logged in as user: root password: orangepi
  • ifconfig showed eth0, lo, wlan0, and wlan1 (both wlan0 and wlan1 showed the same MAC address)
  • I connected to my local wireless router
  • I had an IP address but routing was not correct. I could not ping any address on my local or internet
  • I tried many things but did not make any changes permanent
  • I disconnected the ethernet and rebooted the OPi+
  • I logged in as user: root password: orangepi
  • This time I had a proper connection over wifi on wlan1 and I could ping both local and internet

Two problems remain
  • there is wlan0 and wlan1 but I know there is only one wireless network device. I can use "ifconfig wlan1 down" to get rid of it
  • in teh XFCE GUI, the network connection is always spinning (indicating it is connecting) even though the connection is already working - but clicking on it and then clicking on 'disconnect' for the ethernet which is not connected switches the indicator to the wifi signal icon so I'm not worried.

I will close the SD card and then see if apt-get update/upgrade is a good or bad thing to do. I will also disable XFCE since I don to need it.

If all of this works, I'll go back and repeat the process with the jessie_min image.

May thanks to loboris and others for all of their posts. My next task is to test GPIO and I2C.

forumme 看全部
2015-11-2 20:00:41
Thanks for reporting your steps.
I did the same with one additional comment and one question.

Comment to Point 13: Renaming to "modules original" and then installing the updated "module"-file was the only way, because it was not possible to delete the two internal files "build" and "source" concerning the original "module"-file (a little bit strange for me).

Question: The "lib"-update contains the updated "module"-file you have used, but also a "firmware"-file. Did you ignore that file, so I did?

In addition: You have used Win32DiscImager on a windows system. People can download a tool "paragon-ExtFS" for free that allows reading and writing linux-ext-files on a windows system.Perhaps nice to have.

Enjoy your orangePi, I am still waiting for HW-delivery. My prepared SD-card is waiting for verifikation.

PaulF8080 看全部
2015-12-16 04:46:28
Edited by PaulF8080 at 2015-12-15 12:51

Thanks. I got the wlan0 and wlan1 to appear in the gui, which is major progress. I click on my router and it does't ask for the unlock pass word and doesn't connect

Also my wired lan disappeared. The lights on the plug don't even blink.

I looked up the wifi chip and it is called MIMO(multi-in multi-out). I'm gussing you can connect to two routers at once using wlan0 and wlan1, but right now I can connect to nothing. My router appears twice HomeWLAN and HomeWLAN 1 so I am guessing I can have two connections on one router.
PaulF8080 看全部
2015-12-17 19:22:48
OK I guessed I must have done something wrong because I tried to use the exact file names with the same creation dates.

I tried again and re-read everything I typed a few times. It now works great. Thank you Thank you. @sopifore

The wifi is an MIMO. I connected to my wifi router on wlan0 and I connected to my neighbors open router on wlan1 at the same time. So I had three connections at once, eth0, wlan0 and wlan1.
eliafino 看全部
2015-12-18 19:13:07
try to connect with this command:
sudo nmcli -a d wifi connect

OrangePi En

Powered by Discuz! X3.4

homepage|Simple edition|Touch edition|PC