please choosego to mobile | Continue to access the PC version
Author: swordfish6975

Openelec Build for OPI PC and 2 now with HW decoding

  [Copy link]
 Author| Published in 2015-11-17 09:20:56 | Show all floors
@jernej I also made a system with a /etc/asound.conf last night but could not get it to play anything with aplay  

If I remember correctly i was getting a similar error.

4

threads

1119

posts

8457

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
8457
Published in 2015-11-18 04:06:21 | Show all floors
I finally managed to get ALSA working, thanks to this thread: http://www.orangepi.org/orangepi ... wthread&tid=266

aplay now works great, however sound quality in kodi is very poor, at least on analog output. Can someone test hdmi audio?
 Author| Published in 2015-11-19 08:47:22 | Show all floors
sounds fuzzy and very poor,  HDMI also  (my computer screen has HDMI and no speakers so it has headphone jack out)

4

threads

1119

posts

8457

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
8457
Published in 2015-11-19 14:35:24 | Show all floors
Ok, kind of expected. How does it sound if you run aplay from ssh?

aplay -Dhw:1,0 somefile.wav

should work flawlessly. If sound is still distorted, try to stop kodi with

systemctl stop kodi

4

threads

1119

posts

8457

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
8457
Published in 2015-11-21 01:51:35 | Show all floors
@swordfish6975,

can you test USB now? I enabled few options in kernel which should fix your issue.

I also found out that kswapd is the most hungry thread and not Kodi. It seems that this is common issue in linux. There are two possibilities - find which upstream patches fix this issue or to try to rebase kernel on 3.4.110 branch. Maybe second is easier....

Did anyone try to use CedarX OpenMax library? It seems that this is the easy way to reach HW decoding acceleration in Kodi.

Regards,
Jernej
Published in 2015-11-21 07:49:36 | Show all floors
@Jernej  supply your email address to me,please. I have new CedarX OpenMax library.

5

threads

355

posts

2407

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
2407
Published in 2015-11-21 15:24:03 | Show all floors
@zhao_steven
I'm wondering if you're really interested in that here the things improves?????
I dont't realy understand your behavior.
Boards:
orangepi plus, olinuxino A20, cubieboard A10, mele A2000 .....
Published in 2015-11-21 16:23:50 | Show all floors
@fritz  I need to think about Our competitors in China.  I've already sent tp a few people. I also send it to you.

0

threads

10

posts

54

credits

Registered member

Rank: 2

credits
54
Published in 2015-11-22 00:34:37 | Show all floors
http://openelec.tv/openelec-box
It looks like this device has a mali gpu too and openelec officially supports it.
but what kind of a driver does it run? I'm launching my investigation now

4

threads

1119

posts

8457

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
8457
Published in 2015-11-22 01:15:02 | Show all floors
@lyoko,

GPU don't usually do video acceleration. Please read this: http://www.cnx-software.com/2013 ... ation-the-vpu-does/

This WETEK box uses separate amcodec library to accelerate video decoding. Allwinner provides CedarX libraries, which helps with video decoding. There is also experimental open source VDPAU implementation, which you can use on X11 based graphic system.

@zhao_steven,
is implementation on allwinner github already obsolete or it never really worked?
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list