login|Register
Forum > Device drivers(GPU&VPU)
Post|
看77122|回71|Favorite
fritz 看全部
2015-11-22 17:01:50
@Rangarid
Pssssssssssssssssssssss!!!!
Don't tell it anyone!
It is a big secret!!!
We will publish it in three weeks on facebook and we will make a video tutorial on youtube.
Rangarid 看全部
2015-11-22 23:32:43
Sounds good. Cant wait. If you need testers let me know (with detailed instructions ).
barban 看全部
2015-11-23 02:58:35
Edited by barban at 2015-11-23 03:02

quote:

fritz replied at 2015-11-22 15:45
@barban
have you compiled from source?

Yes I did.
But from your answer I just realized to have considered the master branch
instead of the h3-dev branch...

I am going to rebuild and retry...  lolBR



Rangarid 看全部
2015-12-1 18:36:44
Edited by Rangarid at 2015-12-4 23:46

Just testet with Lubuntu Vivid and it seems to work. Follow these instructions:

code:

  1. sudo apt-get install libvdpau-dev build-essential pkg-config
  2. cd
  3. git clone https://github.com/linux-sunxi/libvdpau-sunxi.git
  4. cd libvdpau-sunxi
  5. git checkout h3-dev

As the newly added h265 decoding still does not work we need to remove it for now. If you use Lubuntu the standard textedit is leafpad, but you can as well use nano or any other texteditor...

code:

  1. leafpad Makefile

remove h265.c from SRC define and save

code:

  1. leafpad decoder.c

search for text VDP_DECODER_PROFILE_HEVC_MAIN

remove the part marked here:
https://github.com/linux-sunxi/l ... v/decoder.c#L73-L78
and marked here:
https://github.com/linux-sunxi/l ... decoder.c#L205-L211

Save and close.

After that run

code:

  1. make
  2. sudo make install


Now there should be a folder in /usr/lib/vdpau with 2 files. For lubuntu to recognize libvdpau correctly we need to create a symlink to the nvidia vdpau lib (which does not exist but mplayer keeps asking for it).

code:

  1. sudo ln -s /usr/lib/vdpau/libvdpau_sunxi.so.1 /usr/lib/libvdpau_nvidia.so


As it is mentioned in the libvdpau installation instructions i also added this line in /etc/profile

code:

  1. export VDPAU_DIVER=sunxi

Not sure if this makes a difference though...

Now we still need to set the correct udev rules in /etc/udev/rules.d/

create file 50-disp.rules (need root permission)

code:

  1. KERNEL=="disp", MODE="0660", GROUP="video"


create file 50-cedar.rules (need root permission)

code:

  1. KERNEL=="cedar_dev", MODE="0660", GROUP="video"


Reboot and then it should all work. You can test it like this:

code:

  1. wget https://github.com/raspberrypi/firmware/blob/master/opt/vc/src/hello_pi/hello_video/test.h264?raw=true
  2. mv test.h264?raw=true test.h264
  3. mplayer -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau, -fs test.h264


The -fs parameter means fullscreen. Scaling does not seem to work very well with that driver. If mplayer is not in fullscreen the video looks strange.
Rangarid 看全部
2015-12-1 19:51:27
Another note... disabling h265 just seems to apply to the libvdpau-dev version in the lubuntu apt repositories. That version is 0.9, but latest is 1.1.1, so it looks like the h265 related things were added in a later version. there it might not be necessary to remove the h265 things.

OrangePi En

Powered by Discuz! X3.4

homepage|Simple edition|Touch edition|PC