Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: xwalter

Enable the serial port in Debian Jessie

[Copy link]

17

Threads

83

Posts

382

Credits

Intermediate member

Rank: 3Rank: 3

Credits
382
 Author| Post time 2016-2-23 18:28:24 | Show all posts
Edited by xwalter at 2016-2-23 18:33

werecatf I found the script.bin into  /media/boot .....
  1. bin2fex
  2. fex2bin
  3. FOUND.000
  4. script.bin
  5. script.bin.default
Copy the Code


Ok now I read sunxi-tools to undertand how to open it ....

  1. Usage: ./sunxi-fexc [-vq] [-I <infmt>] [-O <outfmt>] [<input> [<output>]]

  2. infmt:  fex, bin  (default:fex)
  3. outfmt: fex, bin, uboot  (default:bin)
Copy the Code


17

Threads

83

Posts

382

Credits

Intermediate member

Rank: 3Rank: 3

Credits
382
 Author| Post time 2016-2-23 18:37:45 | Show all posts
  1. root@OrangePI:/media/boot# bin2fex script.bin > script.fex
  2. bash: bin2fex: command not found
Copy the Code

17

Threads

83

Posts

382

Credits

Intermediate member

Rank: 3Rank: 3

Credits
382
 Author| Post time 2016-2-23 18:45:15 | Show all posts
command not found but is there ....

  1. cd /media/boot
  2. ls
Copy the Code
  1. bin2fex
  2. fex2bin
  3. FOUND.000
  4. script.bin
  5. script.bin.default
  6. .......
Copy the Code

17

Threads

83

Posts

382

Credits

Intermediate member

Rank: 3Rank: 3

Credits
382
 Author| Post time 2016-2-23 20:17:19 | Show all posts
Edited by xwalter at 2016-2-23 20:32

ok guys
I follow this ....
sunxi-tools-master/bin2fex script.bin script.fex
Now I have my script.fex opened ....
What about uarts.....
  1. [uart0]
  2. uart_used = 1
  3. uart_port = 0
  4. uart_type = 2
  5. uart_tx = port:PA04<2><1><default><default>
  6. uart_rx = port:PA05<2><1><default><default>

  7. [uart1]
  8. uart_used = 0
  9. uart_port = 1
  10. uart_type = 2
  11. uart_tx = port:PG06<2><1><default><default>
  12. uart_rx = port:PG07<2><1><default><default>
  13. uart_rts = port:PG08<2><1><default><default>
  14. uart_cts = port:PG09<2><1><default><default>

  15. [uart2]
  16. uart_used = 1
  17. uart_port = 2
  18. uart_type = 4
  19. uart_tx = port:PA00<2><1><default><default>
  20. uart_rx = port:PA01<2><1><default><default>
  21. uart_rts = port:PA02<2><1><default><default>
  22. uart_cts = port:PA03<2><1><default><default>

  23. [uart3]
  24. uart_used = 1
  25. uart_port = 3
  26. uart_type = 2
  27. uart_tx = port:PA13<3><1><default><default>
  28. uart_rx = port:PA14<3><1><default><default>
  29. uart_rts = port:PA15<3><1><default><default>
  30. uart_cts = port:PA16<3><1><default><default>
Copy the Code

now ...?
[uart3]
uart_used=1  ---this is ok if I want to use it
uart_port=3   ...this ok  --> /dev/ttyS3
uart_type=2  ....this ok  I use only two pins , PA15 and PA16 don't exist
But not work ....

17

Threads

83

Posts

382

Credits

Intermediate member

Rank: 3Rank: 3

Credits
382
 Author| Post time 2016-2-23 21:15:55 | Show all posts
ok guys now it seems work .
I have also tested a java application echo with netbeans in orange side and putty in win7
Very good !!!

17

Threads

83

Posts

382

Credits

Intermediate member

Rank: 3Rank: 3

Credits
382
 Author| Post time 2016-2-24 08:18:40 | Show all posts
Edited by xwalter at 2016-2-24 08:48

There is a problem ....
I start the java application which use the /dev/ttyS3
In win7 I start putty and connect over my windows serial port 5 at 115200
The java application under netbeans is running and waiting for something over serial uart3 .
When I send something from putty I receive the orange pi login and password
It seems that the /dev/ttyS3 is connected with a console but isnt' true because gtkterm hasn't any port connected and minicom is connected to /dev/ttyS0
And then ....this happens if I use putty but also a simple windows under visual studio .
Pratically the /dev/ttyS3 responds as if I want to connect with terminal ....very hard to solve that ...But if I close tightvncserver everithing run well .

17

Threads

83

Posts

382

Credits

Intermediate member

Rank: 3Rank: 3

Credits
382
 Author| Post time 2016-2-24 11:12:09 | Show all posts

2

Threads

144

Posts

985

Credits

Senior member

Rank: 4

Credits
985
Post time 2016-2-24 11:29:42 | Show all posts
You have agetty or similar running on ttyS3.

17

Threads

83

Posts

382

Credits

Intermediate member

Rank: 3Rank: 3

Credits
382
 Author| Post time 2016-2-24 17:49:49 | Show all posts
Edited by xwalter at 2016-2-24 17:51

you are right because two day ago I wrote
  1. systemctl enable serial-getty@ttyS3.service
Copy the Code

And when I reboot or restart this remain permanent , maybe
I want to try to disable that ....by typing

  1. systemctl disable serial-getty@ttyS3.service
Copy the Code


17

Threads

83

Posts

382

Credits

Intermediate member

Rank: 3Rank: 3

Credits
382
 Author| Post time 2016-2-24 18:12:24 | Show all posts
Now is much more better .
I hope to solve in this way ....
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2022-5-19 09:50 GMT+8 , Processed in 0.033265 second(s), 19 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list