Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 2190|Reply: 2

Xorg video driver porting

[Copy link]

2

Threads

5

Posts

36

Credits

Novice

Rank: 1

Credits
36
Post time 2016-3-24 17:43:05 | Show all posts |Read mode
Hi,
   I am porting Tizen2.4 to Orangepi+, and now Tizen startup without GUI.
and the X window system failed like this:

X.Org X Server 1.16.0
Release Date: 2014-07-16
[   280.183] X Protocol Version 11, Revision 0
[   280.183] Build Operating System: Linux 3.7.10-1.11-default armv7l Tizen Platform
[   280.183] Current Operating System: Linux sun8i 3.4.39 #1 SMP PREEMPT Tue Mar 22 17:08:55 CST 2016 armv7l
[   280.183] Kernel command line: console=ttyS0,115200 root=/dev/mmcblk0p7 init=/init loglevel=8 partitions=bootloader@mmcblk0p2:env@mmcblk0p5:boot@mmcblk0p6:rootfs@mmcblk0p7:system-data@mmcblk0p8:user@mmcblk0p9:csa@mmcblk0p10:csc@mmcblk0p11:UDISK@mmcblk0p1 security=none
[   280.184] Build Date: 29 October 2015  05:16:04AM
[   280.184]  
[   280.184] Current version of pixman: 0.28.2
[   280.184]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   280.184] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   280.184] (++) Log file: "/var/log/Xorg.0.log", Time: Thu Jan  1 09:06:19 1970
[   280.185] (++) Using config file: "/etc/X11/xorg.conf"
[   280.185] (++) Using config directory: "/etc/X11/xorg.conf.d"
[   280.186] (==) No Layout section.  Using the first Screen section.
[   280.186] (**) |-->Screen "Mali-Screen" (0)
[   280.186] (**) |   |-->Monitor "Monitor0"
[   280.186] (**) |   |-->Device "Mali-Fbdev"
[   280.186] (**) Option "BlankTime" "0"
[   280.187] (**) Option "StandbyTime" "0"
[   280.187] (**) Option "SuspendTime" "0"
[   280.187] (**) Option "OffTime" "0"
[   280.187] (**) Option "IgnoreABI" "True"
[   280.187] (**) Ignoring ABI Version
[   280.187] (==) Automatically adding devices
[   280.187] (==) Automatically enabling devices
[   280.187] (==) Automatically adding GPU devices
[   280.187] (==) FontPath set to:
    built-ins
[   280.187] (==) ModulePath set to "/usr/lib/xorg/modules"
[   280.187] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[   280.187] (II) Loader magic: 0xb6febc08
[   280.187] (II) Module ABI versions:
[   280.187]     X.Org ANSI C Emulation: 0.4
[   280.187]     X.Org Video Driver: 18.0
[   280.187]     X.Org XInput driver : 21.0
[   280.187]     X.Org Server Extension : 8.0
[   280.188] (II) LoadModule: "extra"
[   280.189] (WW) Warning, couldn't open module extra
[   280.189] (II) UnloadModule: "extra"
[   280.189] (II) Unloading extra
[   280.189] (EE) Failed to load module "extra" (module does not exist, 0)
[   280.189] (II) LoadModule: "xdbg"
[   280.190] (II) Loading /usr/lib/xorg/modules/libxdbg.so
[   280.191] (II) Module xdbg: vendor="X.Org Foundation"
[   280.191]     compiled for 1.16.0, module version = 0.1.0
[   280.191] (**) Option "dlog" "true"
[   280.192] (**) Option "log_path" "/var/log/Xorg.0.log2"
[   280.192] (**) Option "log_level" "7"
[   280.192] [Jan 1 09:06:19:034] (II) [XDBG][xDbgModuleParseOptions] dlog: "on"
[   280.193] (II) LoadModule: "mali"
[   280.193] (II) Loading /usr/lib/xorg/modules/drivers/mali_drv.so
[   280.197] (II) Module mali: vendor="X.Org Foundation"
[   280.197]     compiled for 1.13.0, module version = 0.4.2
[   280.197]     ABI class: X.Org Video Driver, version 13.0
[   280.197] (WW) module ABI major version (13) doesn't match the server's version (18)
[   280.197] (II) MALI: driver for Mali Framebuffer: mali
[   280.197] (--) using VT number 2

[   280.213] (WW) Falling back to old probe method for mali
[   280.213] (II) MALI(0): using /dev/fb0.
[   280.213] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   280.213] (II) MALI(0): [MaliPreInit:1061]: Entering.
[   280.213] (II) MALI(0): [MaliGetRec:194]: Entering.
[   280.213] (II) MALI(0): [MaliHWInit:844]: Entering.
[   280.213] (II) MALI(0): [MaliHWGetDepth:876]: Entering.
[   280.213] (II) MALI(0): Creating default Display subsection in Screen section
    "Mali-Screen" for depth/fbbpp 24/32
[   280.213] (**) MALI(0): Depth 24, (--) framebuffer bpp 32
[   280.213] (==) MALI(0): RGB weight 888
[   280.213] (==) MALI(0): Default visual is TrueColor
[   280.214] (==) MALI(0): Using gamma correction (1.0, 1.0, 1.0)
[   280.214] (II) MALI(0): [MaliHWGetVidmem:894]: Entering.
[   280.214] (II) MALI(0): [MaliHWGetName:902]: Entering.
[   280.214] (II) MALI(0): hardware:  (video memory: 7200kB).
[   280.214] (**) MALI(0): Option "DRI2" "true"
[   280.214] (**) MALI(0): Option "DRI2_PAGE_FLIP" "true"
[   280.214] (**) MALI(0): Option "DRI2_WAIT_VSYNC" "false"
[   280.214] (**) MALI(0): Option "UMP_CACHED" "false"
[   280.214] (**) MALI(0): Option "UMP_LOCK" "true"
[   280.214] (**) MALI(0): Option "XVHWOverlay" "true"
[   280.214] (**) MALI(0): Option "MEASURE_FPS" "false"
[   280.214] (**) MALI(0): DRI Fullscreen page flip enabled.
[   280.214] (**) MALI(0): DRI Fullscreen page flip VSYNC disabled.
[   280.214] (**) MALI(0): Use uncached UMP memory.
[   280.214] (**) MALI(0): Use umplock across processes.
[   280.224] (EE) MALI(0): [mali_drm_open_master:1030] Error: mali_drm_open_master Unable to open DRM: No such file or directory
.
[   280.224] (EE) MALI(0): [MaliPreInit:1163] Error: Failed to be master of DRM!.
[   280.224] (II) UnloadModule: "mali"
[   280.224] (EE) Screen(s) found, but none have a usable configuration.
[   280.225] (EE)
Fatal server error:
[   280.225] (EE) no screens found(EE)
[   280.225] (EE)
Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
[   280.225] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   280.225] (EE)
[   280.293] (EE) Server terminated with error (1). Closing log file.

I use mali_drv.so as userspace video driver, and the problem is  there is no drm/mali_drm driver in kernel.
andthere is poor support of DRM driver.
Is anyone got the issue?   How to solve it?
waiting for your help !!!!

26

Threads

317

Posts

1968

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
1968
Post time 2016-9-24 15:00:10 | Show all posts
Hi friend, thanks for your work!

2

Threads

19

Posts

382

Credits

Intermediate member

Rank: 3Rank: 3

Credits
382
Post time 2017-3-3 23:40:48 | Show all posts
Please, inform us if there will be any solution
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2017-9-20 13:42 GMT+8 , Processed in 0.027912 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list