please choosego to mobile | Continue to access the PC version
View: 5317|Reply: 5

OWA aka SPDIF

[Copy link]

5

threads

354

posts

2605

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
2605
Published in 2015-3-26 18:07:26 | Show all floors |Read mode
I dont see it on the usermanual
are there pin-outs somewhere on the boards?
Boards:
orangepi plus, olinuxino A20, cubieboard A10, mele A2000 .....
Published in 2015-3-27 06:20:48 | Show all floors
Which model?

5

threads

354

posts

2605

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
2605
 Author| Published in 2015-3-27 12:49:08 | Show all floors
Sorry I forgot to mention it.
Pi plus or in generaly the H3 boards.
Thanks
Boards:
orangepi plus, olinuxino A20, cubieboard A10, mele A2000 .....

5

threads

354

posts

2605

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
2605
 Author| Published in 2015-4-1 02:37:43 | Show all floors
if it is not too late, make PA17 accessible or at least confirm that it is not possible.

Thanks
Boards:
orangepi plus, olinuxino A20, cubieboard A10, mele A2000 .....

3

threads

38

posts

1028

credits

Gold member

Rank: 6Rank: 6

credits
1028
Published in 2016-4-27 00:48:15 | Show all floors
i have OPC and i am also very interested in SPDIF output... would really appreciate any hints on this. Where is PA17? Is it posible to connect coaxial to that pin?
Thanks

1

threads

6

posts

31

credits

Novice

Rank: 1

credits
31
Published in 2023-11-1 01:31:50 | Show all floors
This post was finally edited by rohoog at 2023-11-6 21:17

I have an OP Zero 2W and I see in the H616 manual that it should have the OWA block (spdif output) on pin PH4. This pin is available on the gpio 40 pin connector on pin 18. I see that for the H5 based boards, there is the dt overlay available in github repo  orangepi-xunlong/linux-orangepi : sun50i-h5-spdif-out.dts.
I tried to modify the H5 overlay to suit the H616 base devicetree, but I get 'not found' errors. The error doesn't say _what_ it cannot find.
See the attached spdif.dts. Can anyone point what I did wrong?
Also I guess the ahubdam needs to arrange the 'connection' to the OWA, but I cannot see something obvious I should set in the alsamixer.

You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list