please choosego to mobile | Continue to access the PC version
Author: TheLinuxBug

H3Droid - Android image developed specifically to work on Allwinner H3 devices

  [Copy link]

0

threads

3

posts

23

credits

Novice

Rank: 1

credits
23
Published in 2018-7-29 23:37:48 | Show all floors
Guys, no news about GPIO access?

6

threads

22

posts

332

credits

Intermediate member

Rank: 3Rank: 3

credits
332
Published in 2018-8-5 07:52:16 | Show all floors

Raspbian passwords

I've installed successfully raspbian jessie-minimal in dual boot mode on my OPI-PC.

Btw i don't know any login account, do you know them?

0

threads

94

posts

2501

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
2501
Published in 2018-8-7 14:56:21 | Show all floors
i didnt know we had raspbian image? anyway, if its ARMBIAN, default login and password can be found here: https://docs.armbian.com/
dissatisfied with android on your H3 device? try again with https://h3droid.com/

6

threads

22

posts

332

credits

Intermediate member

Rank: 3Rank: 3

credits
332
Published in 2018-8-11 01:06:21 | Show all floors
I've figured out the default root:1234 password was correct, but for some reason my keyboard was not sending the digit keys correctly.
Turning on the NumLock and using the numpad solved the issue!

6

threads

22

posts

332

credits

Intermediate member

Rank: 3Rank: 3

credits
332
Published in 2018-8-16 11:12:48 | Show all floors

directional key stuck

Edited by eadmaster at 2018-8-16 12:16

I'd like to report an issue i am having with H3Droid (and even the official Android image for the OPI-PC): during gaming the directional keys randomly remains pressed/stuck.
I am pretty sure this is not an hardware issue, because with RetrOrangePi it never happens!

0

threads

94

posts

2501

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
2501
Published in 2018-8-16 13:40:09 | Show all floors
can you provide some logs from when it happens (logcat dump) ?
also, what are the exact steps to reproduce the issue, does it onlt happen in some specific app?
dissatisfied with android on your H3 device? try again with https://h3droid.com/

6

threads

22

posts

332

credits

Intermediate member

Rank: 3Rank: 3

credits
332
Published in 2018-8-17 08:16:01 | Show all floors
Edited by eadmaster at 2018-8-17 08:17
kotcza replied at 2018-8-16 13:40
can you provide some logs from when it happens (logcat dump) ?
also, what are the exact steps to rep ...

It always happens with the Retroarch app, both with USB keyboard and gamepads.
Try to play some platform games like Super Mario Bros (NES) and you should see a directional key becoming stuck after a few minutes of gameplay.

I cannot attach the logcat dump atm, i'll try later..

6

threads

22

posts

332

credits

Intermediate member

Rank: 3Rank: 3

credits
332
Published in 2018-8-21 11:46:08 | Show all floors
Edited by eadmaster at 2018-8-21 11:47

as alternative, can you add an option to install the RetrOrangePi slim distro in the Linux partition?
(as alternative to ubuntu and debian jessie)

0

threads

94

posts

2501

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
2501
Published in 2018-8-21 17:24:05 | Show all floors
i will look into it (they seem to base the distro on armbian so might be easy to integrate)
dissatisfied with android on your H3 device? try again with https://h3droid.com/

0

threads

5

posts

26

credits

Novice

Rank: 1

credits
26
Published in 2018-8-22 22:10:35 | Show all floors
Edited by Nyakoi at 2018-8-22 22:18

Hello to everyone! As owner of OPi Zero (Allwinner H2+) I tried installing H3Droid in both ways (with FEL Installer through USB and H3ii, manually writing the img file to the SD card).
The error I get every time with FEL Installer is this:
When writing the H3Droid installer img file with Etcher and powering up the OPi Zero board the green LED lights on constantly and there is no video out via composite TV output, even after 30 minutes. The power consumption at this state is 300mA and falls down to 180mA after short time.
My SD card is no-name class 4 8GB, but I think it is not the problem after testing it (writing speed 10.4Mb/s, reading 17.5Mb/s):

The question is: should I buy another SDHC (Sandisk class 10, ~10Mb/s writing at Youtube tests by other people) and try again or the problem is somewhere else?

Thank you in advance for your help!




This thread contains more resources

You need to Log in to download or view,No account?    Register

x
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list