Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 5881|Reply: 7

ppp demon is getting crashed in 2G-IoT orange-pi

[Copy link]

3

Threads

5

Posts

37

Credits

Novice

Rank: 1

Credits
37
Post time 2017-7-25 14:39:38 | Show all posts |Read mode
Edited by Amit1094 at 2017-7-25 14:42

Hi,

I am working on Orange-PI 2G-IoT and try to bring GSM connection up.
I am able to bring GSM connection up, but it;'s getting crashed[ppp demon] after 1-2 min.

Please find logs attached..

Disconnecting at Tue Jul 25 06:30:27 2017--> The PPP daemon has died: Lack of LCP echo responses (exit code = 15)--> man pppd explains pppd error codes in more detail.-->
I guess that's it for now, exiting--> Provider is overloaded(often the case) or line problem.-->
The PPP daemon has died. (exit code = 15)

Thanks
Amit Sharma

This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x

0

Threads

18

Posts

509

Credits

Senior member

Rank: 4

Credits
509
Post time 2017-7-25 22:27:27 | Show all posts
Edited by Reinhard at 2017-7-26 14:45
  1. root@OrangePi:~# nano /etc/ppp/peers/wvdial [ENTER]
Copy the Code

Set the # in the last row to disable the lcp-check

  1. # If this option is given, pppd will presume the peer to be dead if n
  2. # LCP echo-requests are sent without receiving a valid LCP echo-reply.
  3. # If this happens, pppd will terminate the connection. Use of this
  4. # option requires a non-zero value for the lcp-echo-interval parameter.
  5. # This option can be used to enable pppd to terminate after the physical
  6. # connection has been broken (e.g., the modem has hung up) in
  7. # situations where no hardware modem control lines are available.

  8. # lcp-echo-failure 4
Copy the Code



███ Greatings from Germany ███
███             Reinhard              ███
███                                       ███

3

Threads

5

Posts

37

Credits

Novice

Rank: 1

Credits
37
 Author| Post time 2017-7-28 15:02:47 | Show all posts
Reinhard replied at 2017-7-25 22:27
Set the # in the last row to disable the lcp-check

Hi Reinhard,

After doing the code changes according to your comment. But Problem still persisting.
is there any other configuration needs to be done the same?

Thanks
Amit Shrama

3

Threads

19

Posts

87

Credits

Registered member

Rank: 2

Credits
87
Post time 2017-9-17 23:00:19 | Show all posts
I have the same problem. Did you guys solve the issue?

3

Threads

79

Posts

1091

Credits

Gold member

Rank: 6Rank: 6

Credits
1091
Post time 2017-9-18 01:32:35 From the mobile phone | Show all posts
Maybe not enough current from power supply...Are you just powering with PC USB 2.0 (It is limited to 500mA)

3

Threads

19

Posts

87

Credits

Registered member

Rank: 2

Credits
87
Post time 2017-9-21 18:00:59 From the mobile phone | Show all posts
JRios replied at 2017-9-18 01:32
Maybe not enough current from power supply...Are you just powering with PC USB 2.0 (It is limited to ...

Did it work for you?

3

Threads

79

Posts

1091

Credits

Gold member

Rank: 6Rank: 6

Credits
1091
Post time 2017-9-21 19:00:06 From the mobile phone | Show all posts
Does not have an OPi 2G-IoT yet, but it could be the problem... just an idea, but I hear for someone else that this was his problem and using an external power supply fixed it. Ofcourse, it could be necessary do what Reinhard said too.

0

Threads

1

Posts

28

Credits

Novice

Rank: 1

Credits
28
Post time 2018-5-30 18:25:04 | Show all posts
Hi,
I am also trying to connect orangepi-2G board over GPRS. It successfully connected to GPRS but after 2 min it get automatically disconnected.
here is the log.

--> pppd: àkô¶Xq[01]àq[01][01]
--> pppd: àkô¶Xq[01]àq[01][01]
--> Connect time 1207786.0 minutes.
--> pppd: àkô¶Xq[01]àq[01][01]
--> pppd: àkô¶Xq[01]àq[01][01]
--> pppd: àkô¶Xq[01]àq[01][01]
--> Disconnecting at Wed May 30 10:20:10 2018
--> The PPP daemon has died: Lack of LCP echo responses (exit code = 15)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> Provider is overloaded(often the case) or line problem.
--> The PPP daemon has died. (exit code = 15)
root@OrangePi:~#

I also tried with multiple adaptor but result is same.
I check with file /etc/wvdial.conf
I am not finding any thing, why this connection break down.
Regards,
Rahul K.
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2021-3-9 15:14 GMT+8 , Processed in 0.031905 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list