please choosego to mobile | Continue to access the PC version
Author: loboris

Linux Distributions for Orange PI H3 boards

  [Copy link]

2

threads

8

posts

24

credits

Novice

Rank: 1

credits
24
Published in 2016-9-9 17:57:45 | Show all floors
Hi Loboris ,
Sorry for the trouble. I had install OrangePI-PC_Ubuntu_Vivid_Mate.img in mu new pc plus. But after installing it when I'm running install_to_emmc it shows an error of emmc not found. And with Lubuntu my network is not working. Can you please help me to solve this. Thanks.

0

threads

5

posts

40

credits

Novice

Rank: 1

credits
40
Published in 2016-11-9 18:46:08 | Show all floors
Edited by pakikje at 2016-11-10 21:44

Hello all,

I just purchased an Orange pi plus. (could be a couple of weeks before i receive it). I already have a raspberry pi2 (which runs libreelec). I am not sure what i will be doing with this OPI :-) Perhaps try to (android) get a Amazon echo/Mycroft kinda system going (using tasker/autovoice). Perhaps it will replace my RPi2 as mediaplayer (libreelec). (i read somewhere that android and kodi work fine thanks to HW accelaration)

What OS/image (img) would you recomend for me to start with? Does copying a working sd-card/boot os to the emmc work good (sudo install_to_emmc)? (fast, no problems?)
Do i really need a 5v/3a power-supply or will 5v/2a also do? (i am not planing to use the sata or attach usb-drives). Do i need a fan/cooling?

(i still need to do a lot of reading on this forum)

2

threads

4

posts

56

credits

Registered member

Rank: 2

credits
56
Published in 2016-11-23 21:31:01 | Show all floors
Hi,
For me the image installs fine and i2c folders appear under /dev/. Also get following using i2cdetect -l and lsmod
root@OrangePI:/home/orangepi# i2cdetect -l
i2c-0   i2c             twi0                                    I2C adapter
i2c-1   i2c             twi1                                    I2C adapter


root@OrangePI:/home/orangepi# lsmod
Module                  Size  Used by
snd_usb_audio          79205  0
snd_usbmidi_lib        17391  1 snd_usb_audio
snd_hwdep               5337  1 snd_usb_audio
uvcvideo               59634  0



However, have tried various sensors on the i2c interface but nothing gets detected, following is the output for both 1 and 0

root@OrangePI:/home/orangepi# i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --


However, the dmesg error is different
bus 1 :  sunxi_i2c_do_xfer()980 - [i2c1] incomplete xfer
bus 0 : sunxi_i2c_do_xfer()973 - [i2c0] xfer timeout

please suggest way forward to get i2c to work ...


0

threads

5

posts

40

credits

Novice

Rank: 1

credits
40
Published in 2016-12-1 19:34:13 | Show all floors
Right, so i have tried all (or almost all) known builds/images for the OPI+.

Still not satisfied...

The best seems to be: Armbian and Android 4.2.2 (Orange OS). But both have problems. (hw accelaration, wlan or lan not working, hdmi/display issues, etc.)

1

threads

4

posts

251

credits

Intermediate member

Rank: 3Rank: 3

credits
251
Published in 2016-12-1 20:28:51 | Show all floors
Edited by caracolo at 2016-12-1 20:36

helloo, what about wifi dondle RTL 8191SU , lsusb reconize it but does not install the firmware, and dont see 'wlan1' anywhere, I cant see drivers anywhre , i dont know how install thems
I hace a belkin f6d4050 USB WIFI wifi too, lsusb appears , the wlan! appears too , but show a message tha firmware is missing . I use Ubuntu mate vivid 15

Thanks

1

threads

5

posts

25

credits

Novice

Rank: 1

credits
25
Published in 2016-12-10 15:47:03 | Show all floors
Ethernet not working (not even lights flickering) on Debian Jessie.
I'm doubting if i'm using the right script.bin & uImage.
I used the OPI-PLUS while using an Orange Pi Plus 2.

I really need a fix for this, I'm building a NAS, but i'm certainly not going to connect it on Wi-Fi!

4

threads

10

posts

84

credits

Registered member

Rank: 2

credits
84
Published in 2016-12-12 13:04:47 | Show all floors
How do these images manage the voltage regulator on the Opi One?

Thanks for all your efforts :-)

0

threads

2

posts

34

credits

Novice

Rank: 1

credits
34
Published in 2016-12-22 20:02:50 | Show all floors
Hi there !

I'm working on OPI Plus 2 for a little project

I did not succeed compiling my own kernel, due to my no poweful computer, in order to integrate alsa Loopback and Dummy module. I would like to integrate it in an OPI Plus 2. Is it possible forsomeone to help me ?

Thank you !

62

threads

666

posts

4661

credits

Administrator

Rank: 9Rank: 9Rank: 9

credits
4661
Published in 2016-12-24 10:26:06 | Show all floors
sampath92 replied at 2016-9-9 17:57
Hi Loboris ,
Sorry for the trouble. I had install OrangePI-PC_Ubuntu_Vivid_Mate.img in mu new pc plu ...

Hi friend,OrangePI-PC_Ubuntu_Vivid_Mate.img cannot use for pc plus. You should use image of pc plus corresponding.

62

threads

666

posts

4661

credits

Administrator

Rank: 9Rank: 9Rank: 9

credits
4661
Published in 2016-12-24 10:27:04 | Show all floors
Mikail replied at 2016-12-10 15:47
Ethernet not working (not even lights flickering) on Debian Jessie.
I'm doubting if i'm using the ri ...

Hi friend, have you check the image you burn and power supply you use?
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list