please choosego to mobile | Continue to access the PC version
Author: loboris

Linux Distributions for Orange PI H3 boards

  [Copy link]

1

threads

47

posts

189

credits

Registered member

Rank: 2

credits
189
Published in 2015-7-29 17:34:36 | Show all floors
goldenfenix replied at 2015-7-29 16:35
Good day.
I have a problem when i trying to compile kernel with script  build_linux_kernel.sh from  ...

@goldenfenix This is because you are building with a standard gcc.
You may try the patches I've put in http://moinejf.free.fr/opi2/, but some modules would not compile with loboris's .config (I don't remember which).
Otherwise, you may start with my config.

0

threads

18

posts

292

credits

Intermediate member

Rank: 3Rank: 3

credits
292
Published in 2015-7-29 20:05:39 | Show all floors
Edited by goldenfenix at 2015-7-29 20:54

Please small instruction how to apply this patches and how to deal with a standard gcc.
Published in 2015-7-30 02:16:57 | Show all floors
Edited by bronco at 2015-7-30 02:22
goldenfenix replied at 2015-7-29 16:35
Good day.
I have a problem when i trying to compile kernel with script  build_linux_kernel.sh from  ...

Have you tried to set up a working standalone cross-compiler toolchain (eg. from Linaro) to avoid problems?

Get http://releases.linaro.org/14.11 ... ux-gnueabihf.tar.xz and unpack it below /usr/local.

Then prior to starting the script do a
  1. export PATH="/usr/local/gcc-linaro-4.9-2014.11-x86_64_arm-linux-gnueabihf/bin/:$PATH"
Copy code
and then as usual. Report back please.
Published in 2015-7-30 02:21:29 | Show all floors
GreyWolf replied at 2015-7-28 22:51
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
1536000

And what about /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq ?

0

threads

18

posts

292

credits

Intermediate member

Rank: 3Rank: 3

credits
292
Published in 2015-7-30 12:30:59 | Show all floors
Edited by goldenfenix at 2015-7-30 12:32
bronco replied at 2015-7-30 02:16
Have you tried to set up a working standalone cross-compiler toolchain (eg. from Linaro) to avoid p ...

Done how in the instruction, but the  same error.

unrecognized command line option ‘--min_array_alignment=4’
unrecognized command line option ‘--no_unaligned_access’


5

threads

354

posts

2621

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
2621
Published in 2015-7-30 14:00:52 | Show all floors
@goldenfenix
You need to patch source before you compile!
http://www.cyberciti.biz/faq/appy-patch-file-using-patch-command/
http://jungels.net/articles/diff-patch-ten-minutes.html

Without patch you can only compile this kernel source with included SDK binary toolchain (4.6) or for example (maybe simpler) with ubuntu 12.04and installing toolchain (4.6.4) with apt-get install.
Boards:
orangepi plus, olinuxino A20, cubieboard A10, mele A2000 .....

0

threads

18

posts

292

credits

Intermediate member

Rank: 3Rank: 3

credits
292
Published in 2015-7-30 14:03:18 | Show all floors
fritz replied at 2015-7-30 14:00
@goldenfenix
You need to patch source before you compile!
http://www.cyberciti.biz/faq/appy-patch-fi ...

Thanks it was good help.

0

threads

6

posts

764

credits

Senior member

Rank: 4

credits
764
Published in 2015-7-30 21:36:18 | Show all floors
bronco replied at 2015-7-29 21:21
And what about /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq ?

CPU0:
scaling_max_freq 1536000
scaling_cur_freq 480000
CPU1:
scaling_max_freq 1536000
scaling_cur_freq 480000
CPU2:
scaling_max_freq 1536000
scaling_cur_freq 480000
CPU3:
scaling_max_freq 1536000
scaling_cur_freq 480000

10

threads

448

posts

5035

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
5035
 Author| Published in 2015-7-30 22:50:23 | Show all floors
GreyWolf replied at 2015-7-30 14:36
CPU0:
scaling_max_freq 1536000
scaling_cur_freq 480000

scaling_cur_freq changes constantly...
try to run some cpu intensive program and at the same check scaling_cur_freq, it will go to scaling_max_freq.
Or install CPU frequency applet...
480000 (480MHz) is the minimal CPU freq.

0

threads

6

posts

764

credits

Senior member

Rank: 4

credits
764
Published in 2015-7-30 23:34:16 | Show all floors
loboris replied at 2015-7-30 17:50
scaling_cur_freq changes constantly...
try to run some cpu intensive program and at the same check ...

Why do this ?
For different tasks will be different loading cores.
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list