Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 463|Reply: 0

How to disable MSI on PCI bus.

[Copy link]

2

Threads

4

Posts

34

Credits

Novice

Rank: 1

Credits
34
Post time 2019-8-23 06:46:21 From the mobile phone | Show all posts |Read mode
Hi guys,

I am using a 802.11n atheros WiFi card. I need to disable MSI interrupts and enable legacy interrupt on PCI bus in order to use the card properly with ath9k driver. I had tried following methods:
- added quirks in kernel for the pci device.
- manually echoed the 0 in msi_bus file.
- cleared use_msi parameter in ath9k driver.

All of the method disable the msi. I could verify it in kernel message. After I disable MSI a dummy interrupt is assigned to the bus rather than a legacy interrupt. That is the problem.

I was not able to disable pci_msi bit in kernel configuration because it has unmet dependencies on rockchip_pci and gvicv3 interrupt controller.

I am using orangepi-rk3399 board. If anyone knows or faced similar issue please help me.
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2019-10-20 00:55 GMT+8 , Processed in 0.028013 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list