Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 63|Reply: 2

OrangePi Zero, default GPIO signal level

[Copy link]

1

Threads

4

Posts

21

Credits

Novice

Rank: 1

Credits
21
Post time 4 day(s) ago | Show all posts |Read mode
Hi

I'm trying to use OpiZero with a relais module. I noticed, during the boot the pins I tried (12 and 11, physical 3 resp 5) go high, which makes impossible

to manage the relais module.

Is it a HW/SW bug or limitation or something what can be configured somehow.

I would expect the level to be "nothing" ;-)


Thanks

Chris

23

Threads

174

Posts

787

Credits

Senior member

Rank: 4

Credits
787
Post time 4 day(s) ago | Show all posts
It sure sounds like an initial file testing the componants.  Maybe the boot loader is doing it?  Which OS?  
Test it without the SD card in and see if it does it.  
Thanks  [url=http://www.orangepi.org/orangepibbsen/static/image/smiley/default/biggrin.gif]http://ww

1

Threads

4

Posts

21

Credits

Novice

Rank: 1

Credits
21
 Author| Post time 3 day(s) ago | Show all posts
I found the reason for the high level here: http://linux-sunxi.org/images/4/ ... _Datasheet_V1.2.pdf
There are four pins pulled-up at startup, I obviously must have choosen one of them. With GPIO6 pin it works as I expected it to.
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-5-25 19:22 GMT+8 , Processed in 0.027439 second(s), 22 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list