Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 1057|Reply: 0

OrangePi zero cannot SSH into when on a different WI-FI frequency

[Copy link]

1

Threads

1

Posts

41

Credits

Novice

Rank: 1

Credits
41
Post time 2020-11-3 02:20:10 | Show all posts |Read mode
Edited by Just-s at 2020-11-3 02:22

Hello everyone, I've ran into some issues trying to SSH into my orange pi zero running Debian.


- The oPI is connected to my network and I can see it on my routers management panel. However when I try to SSH into it from my main machine, the connection times out.
- I can connect to the oPI, by first SSH'ing into another linux machine on my network so I know that the SSH server/config is fine.
- Both the oPI and the third device I use as an intermediary are connected to the 2.4GHz AP, where as my main machine is connected to the 5GHz one. If I switch it to 2.4, connection is successful. The router configuration should be fine, because I can SSH into the intermediary device(which is also on the 2.4 AP).


- If I connect to the oPI through the intermediary, and use tshark(frontend for wireshark), while trying to SSH from my main machine, here is the partial output:

The oPI is the IP address ending with 250, and my main machine is ending with 213.
  1. 1 0.000000000 xx.xx.xx.213 ? xx.xx.xx.250 TCP 74 49370 ? 22 [SYN] Seq=0 Win=64240 Len=0 MSS=1460 SACK_PERM=1 TSval=2016675449 TSecr=0 WS=128
  2.     2 0.000214171 xx:xx:xx:xx:xx:9f ? Broadcast    ARP 42 Who has xx.xx.xx.213? Tell xx.xx.xx.250
  3.     3 1.024041867 xx.xx.xx.213 ? xx.xx.xx.250 TCP 74 [TCP Retransmission] 49370 ? 22 [SYN] Seq=0 Win=64240 Len=0 MSS=1460 SACK_PERM=1 TSval=2016676471 TSecr=0 WS=128
  4.     4 1.055667918 xx:xx:xx:xx:xx:9f ? Broadcast    ARP 42 Who has xx.xx.xx.213? Tell xx.xx.xx.250
  5.     5 2.079659835 xx:xx:xx:xx:xx:9f ? Broadcast    ARP 42 Who has xx.xx.xx.213? Tell xx.xx.xx.250
Copy the Code
-There are some TCP packets on port 22 which I assume to be the SSH packets.
- The ARP packets never get answered
-There is no TCP packets going from 250(oPI) to 213.

The next test, was trying to ARP ping the main machine, from the oPI. Sent 5 packets, 0 responses. Checking the ARP table(using arp -n), shows the HWAddres as "(incomplete)"



I am not sure where to go from here. Given that other devices in the same network are fine, I suspect to somehow be the oPI zeros fault. Any ideas/suggestions/comments?


You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2021-4-22 01:41 GMT+8 , Processed in 0.027839 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list