please choosego to mobile | Continue to access the PC version
12
Return to list Post new posts
Author: marl

Orange PI PC, No sound [RESOLVE]

[Copy link]

18

threads

303

posts

8823

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
8823
Published in 2015-11-10 22:15:13 | Show all floors
Fourdee replied at 2015-11-7 00:00
Did some work on this today:

Set HDMI output as default:

You can try this trick below.
http://www.orangepi.org/orangepi ... 1&fromuid=37174

0

threads

6

posts

150

credits

Registered member

Rank: 2

credits
150
Published in 2015-11-11 01:41:46 | Show all floors
Fourdee replied at 2015-11-7 00:00
Did some work on this today:

Set HDMI output as default:

Yep, that works but only for situation when X is running, but i'd prefer to use orangepi in headless mode accessing by ssh.
When i try to speaker-test or launch cmus (terminal music player) from SSH there's no sound. When i plug HDMI and X starts i can hear some slick in speakers. After that sound plays from speakers whether i play it from X virtual terminal or via same ssh. But when i kill X (because i dont need it) i don't hear any sound from speaker-test or music player.
How can it be resolved?

0

threads

3

posts

54

credits

Registered member

Rank: 2

credits
54
Published in 2015-12-8 19:43:55 | Show all floors
It is a permissions problem.

Your user must be in the audio group to access the audio filesystem object. Normally "orangepi" user is not member of such group, in fact if you run speaker-test from root you should get audio from analog. More than this, as normal user you aren't even able to run alsamixer, because you don't have permissions.

To gain normal user access to audio, just add orangepi user to audio group in /etc/group, then log out and log in.
Nonetheless in my setup audio is quite low in volume when I run audio applications as standard user. It is ok when I run it as root.




1

threads

9

posts

105

credits

Registered member

Rank: 2

credits
105
Published in 2016-4-15 09:44:59 | Show all floors
jock replied at 2015-12-8 19:43
It is a permissions problem.

Your user must be in the audio group to access the audio filesystem ob ...

Sorry, I'm nob and don't understand this
I think I have already orangepi in my group, but still no sound
Maybe I have Hardware issue?
Below is /etc/group

root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4rangepi
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20rangepi
fax:x:21:
voice:x:22:
cdrom:x:24rangepi
floppy:x:25:
tape:x:26:
sudo:x:27rangepi
audio:x:29:pulse
dip:x:30rangepi
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44rangepi

sasl:x:45:
plugdev:x:46rangepi
staff:x:50:
games:x:60:
users:x:100:
nogroup:x:65534:
input:x:101:
systemd-journal:x:102:
systemd-journal-remote:x:103:
systemd-timesync:x:104:
systemd-network:x:105:
systemd-resolve:x:106:
systemd-bus-proxy:x:107:
ntp:x:108:
netdev:x:109rangepi
ssh:x:110:
messagebus:x:111:
i2c:x:112:
orangepi:x:1000:
utempter:x:113:
lightdm:x:114:
nopasswdlogin:x:115:
pulse:x:116:
pulse-access:x:117:
fuse:x:118rangepi
crontab:x:119:
ssl-cert:x:120:
lpadmin:x:121:
avahi:x:122:
scanner:x:123:
sambashare:x:124:
colord:x:125:


12
Return to list Post new posts
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list