Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 694|Reply: 5

orangepi zero2 apache ssl problem

[Copy link]

2

Threads

6

Posts

32

Credits

Novice

Rank: 1

Credits
32
Post time 2021-1-16 15:01:18 | Show all posts |Read mode
Hi,
i installed orangepi focal server
apache php mariadb server all ok

i try to install ssl :
sudo a2enmod ssl
sudo a2ensite default-ssl
sudo systemctl restart apache2


i have this error :
Jan 16 07:49:30 orangepizero2 apachectl[4642]: [Sat Jan 16 07:49:30.459936 2021] [core:emerg] [pid 4645] (38)Function not implemented: AH00023: Couldn't create the mpm-accept-mutex
Jan 16 07:49:30 orangepizero2 apachectl[4642]: (38)Function not implemented: could not create accept mutex
Jan 16 07:49:30 orangepizero2 apachectl[4642]: AH00015: Unable to open logs
Jan 16 07:49:30 orangepizero2 apachectl[4642]: Action 'start' failed.
Jan 16 07:49:30 orangepizero2 apachectl[4642]: The Apache error log may have more information.
Jan 16 07:49:30 orangepizero2 systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
-- Subject: Unit process exited
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- An ExecStart= process belonging to unit apache2.service has exited.


thanks for any help


1

Threads

20

Posts

87

Credits

Registered member

Rank: 2

Credits
87
Post time 2021-1-16 23:33:44 | Show all posts
Have a look in  /var/log/apache for any clues.

What do you get if you execute:
  1. sudo a2ensite default-ssl
Copy the Code


in the terminal,
Do you see a message:
"Eanabling site default-ssl" ?

2

Threads

6

Posts

32

Credits

Novice

Rank: 1

Credits
32
 Author| Post time 2021-1-17 01:54:01 | Show all posts
yes :
  1. Enabling site default-ssl.
  2. To activate the new configuration, you need to run:
  3.   systemctl reload apache2
Copy the Code

2

Threads

6

Posts

32

Credits

Novice

Rank: 1

Credits
32
 Author| Post time 2021-1-17 01:56:56 | Show all posts
in /var/log/apache2/error.log :
  1. [Sat Jan 16 07:47:57.392444 2021] [core:emerg] [pid 2405] (38)Function not implemented: AH00023: Couldn't create the mpm-accept mutex
  2. [Sat Jan 16 07:47:57.392504 2021] [mpm_prefork:crit] [pid 2405] (38)Function not implemented: could not create accept mutex
  3. [Sat Jan 16 07:47:57.392517 2021] [:emerg] [pid 2405] AH00019: Unable to open logs, exiting

Copy the Code

1

Threads

20

Posts

87

Credits

Registered member

Rank: 2

Credits
87
Post time 2021-1-17 20:32:12 | Show all posts
This looks like a mutex permission. You may have to add yourself to group www
Run this command and see if your output is different:

  1. cat /etc/group | grep www
Copy the Code


My output:
www-data:x:33:

If you have an output of www  then apache has created this group.
From your user ID type

  1. groups
Copy the Code


This will show you  what groups you are a member of. If apache needs
to be a member of group www then run

  1. sudo  usermod -a -G www pi
Copy the Code


This will add user "pi" to group "www" change pi to your username but
will only work if apache requires group www.

2

Threads

6

Posts

32

Credits

Novice

Rank: 1

Credits
32
 Author| Post time 2021-1-20 16:31:48 | Show all posts
i put Mutex posixsem in apache conf and it's now OK

www-data:x:33:
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2021-4-17 22:14 GMT+8 , Processed in 0.028927 second(s), 24 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list