Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: snowbody

fb-tft OK

[Copy link]

11

Threads

286

Posts

1864

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1864
Post time 2016-2-20 23:52:44 | Show all posts
ok,i get it but white screen after init

11

Threads

286

Posts

1864

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1864
Post time 2016-2-21 09:26:51 | Show all posts
somebody help spi connection with lcd spotpear 3,5
[    1.939420] sunxi_spi_chan_cfg()1355 - [spi-0] has no spi_regulator.
[    1.948838] sunxi_spi_chan_cfg()1355 - [spi-1] has no spi_regulator.
[    1.958669] spi spi0: master is unqueued, this is deprecated
[   61.591951] fbtft_device:      spidev spi0.0 33000kHz 8 bits mode=0x00
[   61.592054] fbtft_device: Deleting spi0.0
[   61.592948] flexfb spi0.0: fbtft_request_gpios: gpio_request_one('reset'=25) failed with -22
[   61.592962] flexfb spi0.0: fbtft_free_gpios()
[   61.592973] flexfb spi0.0: fbtft_free_gpios(): gpio_free('reset'=25)
[   61.593342] [<bf1cbc14>] (flexfb_probe_common+0x720/0x81c [flexfb]) from [<bf1cbd50>] (flexfb_probe_spi+0x1c/0x20 [flexfb])
[   61.593369] [<bf1cbd50>] (flexfb_probe_spi+0x1c/0x20 [flexfb]) from [<c043627c>] (spi_drv_probe+0x28/0x2c)
[   61.593394] [<c043627c>] (spi_drv_probe+0x28/0x2c) from [<c040a2c0>] (driver_probe_device+0xd8/0x1fc)
[   61.593521] [<c0407cd8>] (device_add+0x3ec/0x574) from [<c0437048>] (spi_add_device+0xdc/0x12c)
[   61.593542] [<c0437048>] (spi_add_device+0xdc/0x12c) from [<c0437128>] (spi_new_device+0x90/0xb0)
[   61.593576] [<c0437128>] (spi_new_device+0x90/0xb0) from [<bf1db420>] (fbtft_device_init+0x420/0x5dc [fbtft_device])
[   61.593697] flexfb spi0.0: fbtft_free_gpios(): gpio_free('dc'=24)
[   61.594004] [<bf1cbc14>] (flexfb_probe_common+0x720/0x81c [flexfb]) from [<bf1cbd50>] (flexfb_probe_spi+0x1c/0x20 [flexfb])
[   61.594030] [<bf1cbd50>] (flexfb_probe_spi+0x1c/0x20 [flexfb]) from [<c043627c>] (spi_drv_probe+0x28/0x2c)
[   61.594053] [<c043627c>] (spi_drv_probe+0x28/0x2c) from [<c040a2c0>] (driver_probe_device+0xd8/0x1fc)
[   61.594177] [<c0407cd8>] (device_add+0x3ec/0x574) from [<c0437048>] (spi_add_device+0xdc/0x12c)
[   61.594199] [<c0437048>] (spi_add_device+0xdc/0x12c) from [<c0437128>] (spi_new_device+0x90/0xb0)
[   61.594231] [<c0437128>] (spi_new_device+0x90/0xb0) from [<bf1db420>] (fbtft_device_init+0x420/0x5dc [fbtft_device])
[   61.594447] flexfb: probe of spi0.0 failed with error -22
[   61.594514] fbtft_device:      flexfb spi0.0 16000kHz 8 bits mode=0x00

1

Threads

11

Posts

56

Credits

Registered member

Rank: 2

Credits
56
Post time 2016-2-29 04:46:46 | Show all posts
melanrz replied at 2016-2-21 09:26
somebody help spi connection with lcd spotpear 3,5
[    1.939420] sunxi_spi_chan_cfg()1355 - [spi-0] ...

I have the same errors.
All time I'm trying to modprobe I've get an error with gpio_request: gpio-25 (fb_ili9341) status -22
fb_ili9341 spi0.0: fbtft_request_gpios: gpio_request_one('reset'=25) failed with -22


I've compiled my own kernel with SPI and FBTFT support from this thread instructions

11

Threads

286

Posts

1864

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1864
Post time 2016-3-1 02:58:08 | Show all posts
try reset on 20 and dc on 18

0

Threads

10

Posts

88

Credits

Registered member

Rank: 2

Credits
88
Post time 2016-3-24 05:34:04 | Show all posts
SPI is set in script.bin?
sunxi-gpio module is unloaded?

1

Threads

13

Posts

199

Credits

Registered member

Rank: 2

Credits
199
Post time 2016-3-24 18:52:51 | Show all posts

11

Threads

286

Posts

1864

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1864
Post time 2016-4-9 04:54:12 | Show all posts
beee replied at 2016-3-24 05:34
SPI is set in script.bin?
sunxi-gpio module is unloaded?

i have same lcd as yours,tested with arduino,connected as described but stil white screen,i used loboris img with compiled fbtft,an armbian with fbtft support ready to go,module load but still white screen.Please share your script.bin

0

Threads

10

Posts

88

Credits

Registered member

Rank: 2

Credits
88
Post time 2016-4-25 02:38:52 | Show all posts
According to your post above you try SPI display. My parallel is. Script.bin not have modified. Just as root: rmmod gpio_sunxi. You was created new FB device? If yes, you tried something on it show? What he says dmesg?

11

Threads

286

Posts

1864

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
1864
Post time 2016-5-2 17:47:34 | Show all posts

4

Threads

37

Posts

333

Credits

Intermediate member

Rank: 3Rank: 3

Credits
333
Post time 2017-5-30 23:43:27 | Show all posts
Hi,
I'm trying to show something in a 2.2" tft display (ILI9340) but I can't.
I tried with instructions written by snowbody and plugging reset and dc in PA7 and PA6 respectively.
I tried with fbview.py that is located in the attached file by beee (goo.gl/rokH6M) but it does not work either. This message returns
Using extension png for identity.
Detected type: PNG
sh: 1: ppmtofb: not found
Scaling /tmp/fbview.1496157891.10503.ppm (from 1280 x 1024)
Displaying image
Traceback (most recent call last):
  File "fbview.py", line 331, in <module>
    sys.exit(main())
  File "fbview.py", line 317, in main
    show_file(x, fp, grayscale, width, height, maxcolors)
  File "fbview.py", line 187, in show_file
    fp.write(txt)
IOError: [Errno 32] Broken pipe


Definitely, Can anyone write a brief guide? If someone made a video tutorial would be great!
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2019-11-18 14:23 GMT+8 , Processed in 0.034510 second(s), 20 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list