please choosego to mobile | Continue to access the PC version
Author: snowbody

fb-tft OK

[Copy link]

0

threads

4

posts

42

credits

Novice

Rank: 1

credits
42
Published in 2016-1-13 00:08:58 from mobile | Show all floors
When I try to compile fbtft, encountered some problems

0

threads

4

posts

42

credits

Novice

Rank: 1

credits
42
Published in 2016-1-13 00:11:01 | Show all floors
CC [M] drivers/video/fbtft/fbtft-core.o
drivers/video/fbtft/fbtft-core.c: In function ‘fbtft_request_gpios’:
drivers/video/fbtft/fbtft-core.c:144:5: error: implicit declaration of function ‘devm_gpio_request_one’ [-Werror=implicit-function-declaration]
cc1: some warnings being treated as error

0

threads

4

posts

42

credits

Novice

Rank: 1

credits
42
Published in 2016-1-13 00:26:57 | Show all floors
Now, 3.4 kernel source is missing the function I do not know what to do, can you help me?
Thank.

0

threads

10

posts

88

credits

Registered member

Rank: 2

credits
88
Published in 2016-1-13 20:12:25 | Show all floors
please read the first post. snowbody writes:
(rollback to version that is compatible with 3.4 kernel (instead of 3.5)
git checkout 6da654310724c31622afa8c7d12211a6e33ec18d

or use my compiled archive. ;-)

0

threads

4

posts

42

credits

Novice

Rank: 1

credits
42
Published in 2016-1-14 21:40:01 | Show all floors
beee replied at 2016-1-13 20:12
please read the first post. snowbody writes:
(rollback to version that is compatible with 3.4 kernel ...

Compiled perfectly,Because there is no checkout before, resulting in warehouses of clones are not compatible Linux 3.4.
Thank you very much

11

threads

286

posts

1924

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
1924
Published in 2016-2-17 03:45:53 | Show all floors
why i have invalid argument after modprobe?

11

threads

286

posts

1924

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
1924
Published in 2016-2-17 06:33:00 | Show all floors
copied modules, depmod

11

threads

286

posts

1924

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
1924
Published in 2016-2-17 06:53:08 | Show all floors
can you post how to compile with loboris kernel? i have many errors,kernel in home directory extracted,i must bulid??

11

threads

286

posts

1924

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
1924
Published in 2016-2-17 06:53:48 | Show all floors
beee replied at 2016-1-13 20:12
please read the first post. snowbody writes:
(rollback to version that is compatible with 3.4 kernel ...

your compile archive working only on your image,please post copy of your image,thanks.

11

threads

286

posts

1924

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
1924
Published in 2016-2-19 06:09:07 | Show all floors
modprobe: ERROR: could not insert 'fbtft_device': Invalid argument
modprobe: ERROR: could not insert 'flexfb': Invalid argument

The problem mayby is not corect connectio on lcd or module must load to without lcd atached?? i use compiled driver,still cant compile kernel with build error
please help
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list