please choosego to mobile | Continue to access the PC version
View: 19254|Reply: 10

How conect ili9488 Raspberry display ?

[Copy link]

1

threads

13

posts

201

credits

Intermediate member

Rank: 3Rank: 3

credits
201
Published in 2016-2-12 20:16:56 | Show all floors |Read mode
Hi, cant show linux on opi pc using an display ili9488 conectes on gpio port.

https://www.dropbox.com/s/vufxmm ... 212_130324.jpg?dl=0


I need help,thx.

PD: im using for example scipt.bin wt 480p gpio 30pin

GPIO pins used for TFT LCD Display:

  • pin1 3V3 ------------------------------------ TFT 3V3 / TS 3V3
  • pin18 GPIO24 ----------------------------- TFT RS
  • pin19 GPIO10/MOSI --------------------- TFT MOSI / TS DIN
  • pin24 GPIO8/CE0 ------------------------ TFT CS
  • pin23 GPIO11/CLK ----------------------- TFT SCLK / TS DCLK
  • pin22 GPIO25 ----------------------------- TFT RST
  • pin12 GPIO18/PWM --------------------- TFT BL
  • pin6 GND ----------------------------------- TFT GND
  • pin21 GPIO9/MISO ----------------------- TS DOUT
  • pin5 GPIO3/SCL -------------------------- TS PENIRQ
  • pin26 GPIO7/CE1 ------------------------ TS CS

Medecine moderne www.viagrasansordonnancefr.com en vente libre

2

threads

144

posts

1076

credits

Gold member

Rank: 6Rank: 6

credits
1076
Published in 2016-2-12 22:58:07 | Show all floors
You need to compile your own kernel and include https://github.com/notro/fbtft in it if you want to use the display as a regular framebuffer-device. Or you can write your own app to drive it using WiringOp.

0

threads

2

posts

36

credits

Novice

Rank: 1

credits
36
Published in 2016-2-13 19:35:14 from mobile | Show all floors
I think "0x9341" works with these.  

1

threads

13

posts

201

credits

Intermediate member

Rank: 3Rank: 3

credits
201
 Author| Published in 2016-2-14 07:22:27 | Show all floors
fatal error ->#include <linux/module.h>
i cant compile fb_ili9341.c
Medecine moderne www.viagrasansordonnancefr.com en vente libre

2

threads

144

posts

1076

credits

Gold member

Rank: 6Rank: 6

credits
1076
Published in 2016-2-15 16:31:42 | Show all floors
redo replied at 2016-2-14 07:22
fatal error ->#include
i cant compile fb_ili9341.c

You obviously need kernel-sources or headers installed.

9

threads

634

posts

4404

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4404
Published in 2016-2-15 19:06:30 | Show all floors
@redo

... and you need SPI drivers. No idea if there are done/working for sun8i (Allwinner H3). I know it's working on A20 - I am using one such display.

But you can try to build your own kernel with our tools. It's possible since yesterday. Kernel is 3.4.110, headers and drivers for those LCD displays are already included.

12

threads

30

posts

150

credits

Registered member

Rank: 2

credits
150
Published in 2016-2-22 17:32:33 | Show all floors
I can confirm SPI lcd screens work on H3 based orange pi PC -- it is very important that you define the spi-speed

fbtft_device custom name=fb_ili9341 gpios=reset:25,dc:24,led:18 speed=16000000 rotate=90 bgr=1

1

threads

13

posts

201

credits

Intermediate member

Rank: 3Rank: 3

credits
201
 Author| Published in 2016-2-28 05:28:23 | Show all floors
Medecine moderne www.viagrasansordonnancefr.com en vente libre

1

threads

11

posts

56

credits

Registered member

Rank: 2

credits
56
Published in 2016-2-29 04:42:04 | Show all floors
Edited by komw at 2016-2-29 04:43
snowbody replied at 2016-2-22 17:32
I can confirm SPI lcd screens work on H3 based orange pi PC -- it is very important that you define  ...

Could you explain how you make to work your TFT?
I have a 3.5 KEDEI version4 LCD tft ( pinout like this http://imageshack.com/i/p77p1oydj but I have a version4)I compiled kernel with SPI, and FBTFT support, next I configured my SPI at script.bin:

  1. [spi0]
  2. spi_used = 1
  3. spi_cs_bitmap = 1
  4. spi_mosi = port:PC00<3><default><default><default>
  5. spi_miso = port:PC01<3><default><default><default>
  6. spi_sclk = port:PC02<3><default><default><default>
  7. spi_cs0 = port:PC03<3><1><default><default>

  8. [spi1]
  9. spi_used = 0
  10. spi_cs_bitmap = 1
  11. spi_cs0 = port:PA13<2><1><default><default>
  12. spi_sclk = port:PA14<2><default><default><default>
  13. spi_mosi = port:PA15<2><default><default><default>
  14. spi_miso = port:PA16<2><default><default><default>
  15.                               
  16. [spi_devices]
  17. spi_dev_num = 1

  18. [spi_board0]
  19. modalias = "spidev"
  20. max_speed_hz = 16000000
  21. bus_num = 0
  22. chip_select = 0
  23. mode = 0
  24. full_duplex = 1
  25. manual_cs = 0
  26. irq_gpio = 1
Copy code


and I tried to enable kernel modules:
modprobe fbtft_device custom name=fb_ili9341 gpios=reset:25,dc:24,led:18 speed=16000000 rotate=90 bgr=1
But always I get the error at dmesg:
Some stacktrace and errors:

[  265.655190] fbtft_device:  SPI devices registered:
[  265.655213] fbtft_device:      spidev spi0.0 16000kHz 8 bits mode=0x00
[  265.655224] fbtft_device:  'fb' Platform devices registered:
[  265.655294] fbtft_device: Deleting spi0.0
[  265.655736] fbtft_device:  GPIOS used by 'fb_ili9341':
[  265.655750] fbtft_device:    'reset' = GPIO25
[  265.655759] fbtft_device:    'dc' = GPIO24
[  265.655767] fbtft_device:    'led' = GPIO18
[  265.655775] fbtft_device:  SPI devices registered:
[  265.655787] fbtft_device:      fb_ili9341 spi0.0 16000kHz 8 bits mode=0x00
[  265.670563] gpio_request: CHIP->REQUEST error
[  265.670582] gpio_request: gpio-25 (fb_ili9341) status -22
[  265.670602] fb_ili9341 spi0.0: fbtft_request_gpios: gpio_request_one('reset'=25) failed with -22

  265.670649] WARNING: at drivers/gpio/gpiolib.c:103 gpio_ensure_requested+0x54/0xb4()
[  265.670660] autorequest GPIO-25
[  265.670668] Modules linked in: fb_ili9341(+) fbtft_device fbtft fb_sys_fops

[  265.671340] WARNING: at drivers/gpio/gpiolib.c:103 gpio_ensure_requested+0x54/0xb4()
[  265.671351] autorequest GPIO-24
[  265.671358] Modules linked in: fb_ili9341(+) fbtft_device fbtft fb_sys_fops

[  265.671945] WARNING: at drivers/gpio/gpiolib.c:103 gpio_ensure_requested+0x54/0xb4()
[  265.671956] autorequest GPIO-18
[  265.671962] Modules linked in: fb_ili9341(+) fbtft_device fbtft fb_sys_fops
[  265.672610] fb_ili9341: probe of spi0.0 failed with error -22
So I always get the errors with gpio
gpio_request: gpio-25 (fb_ili9341) status -22
fb_ili9341 spi0.0: fbtft_request_gpios: gpio_request_one('reset'=25) failed with -22
It seems that there is some problems with setup a gpio 25.

12

threads

30

posts

150

credits

Registered member

Rank: 2

credits
150
Published in 2016-3-9 18:05:09 | Show all floors
in script.bin you'll have to check if your pin is not used for something else (eg serial port 2)
Guess you should be able to blink a led on that port ....
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list