please choosego to mobile | Continue to access the PC version
View: 3793|Reply: 0

Modules install failure after rebuild @ Linux OrangePi+ Kali 3.4.39 loboris

[Copy link]

15

threads

105

posts

387

credits

Intermediate member

Rank: 3Rank: 3

credits
387
Published in 2016-2-15 01:14:43 | Show all floors |Read mode
I have an USB dongle:
[ 5287.340332] usb 2-1.2: new high-speed USB device number 3 using sunxi-ehci
Bus 002 Device 003: ID 0846:4260 NetGear, Inc. WG111v3 54 Mbps Wireless [realtek RTL8187B]
which is not working with Kali 2.0 lororis build.

I tried to rebuild the modules from the sources and include the RTL8187 in the build as follows:
root@OrangePi_kali:/usr/src/trunk/linux-3.4# uname -a
Linux OrangePi_kali 3.4.39 #2 SMP PREEMPT Mon Oct 12 12:03:03 CEST 2015 armv7l GNU/Linux

root@OrangePi_kali:/usr/src# svn export https://github.com/loboris/OrangePI-Kernel/trunk/
followed by:
root@OrangePi_kali:~# apt-get update
root@OrangePi_kali:~# apt-get dist-upgrade
root@OrangePi_kali:~# apt-get install gcc build-essential
root@OrangePi_kali:~# cd /usr/src/trunk/linux-3.4/
root@OrangePi_kali:/usr/src/trunk/linux-3.4# cp ../build/config.good/sun8iw7p1smp_lobo_defconfig.opiplus .config
root@OrangePi_kali:/usr/src/trunk/linux-3.4# make oldconfig

# configuration written to .config :
# CONFIG_RTL8187 is not set
CONFIG_RTL8187=m

root@OrangePi_kali:/usr/src/trunk/linux-3.4# make modules_prepare
root@OrangePi_kali:/usr/src/trunk/linux-3.4# make modules
logs showed:
  LD [M]  drivers/net/wireless/rtl818x/rtl8187/rtl8187.o

Everything went OK till then.
The trouble came from the next stage:
root@OrangePi_kali:/usr/src/trunk/linux-3.4# make install

root@OrangePi_kali:/usr/src/trunk/linux-3.4# make install
  CHK     include/linux/version.h
  CHK     include/generated/utsrelease.h
make[1]: 'include/generated/mach-types.h' is up to date.
  CALL    scripts/checksyscalls.sh
grep: scripts/../arch/x86/syscalls/syscall_32.tbl: No such file or directory
  CC      init/main.o
  CHK     include/generated/compile.h
  UPD     include/generated/compile.h
  CC      init/version.o
  CC      init/do_mounts.o
  CC      init/do_mounts_initrd.o
  LD      init/mounts.o
  CC      init/initramfs.o
  CC      init/calibrate.o
  LD      init/built-in.o
  HOSTCC  usr/gen_init_cpio
  /usr/src/trunk/linux-3.4/scripts/gen_initramfs_list.sh: Cannot open 'output/rootfs.cpio.gz'
/usr/src/trunk/linux-3.4/usr/Makefile:67: recipe for target 'usr/initramfs_data.cpio' failed
make[1]: *** [usr/initramfs_data.cpio] Error 1
Makefile:945: recipe for target 'usr' failed
make: *** [usr] Error 2
make: *** [usr] Error 2


Additionally, I tried next
root@OrangePi_kali:/usr/src/trunk/linux-3.4# make headers_install ARCH=arm INSTALL_HDR_PATH=/usr
followed by:
root@OrangePi_kali:/usr/src/trunk/linux-3.4# make install
  CHK     include/linux/version.h
  CHK     include/generated/utsrelease.h
  HOSTCC  scripts/basic/fixdep
In file included from scripts/basic/fixdep.c:106:0:
/usr/include/arm-linux-gnueabihf/sys/types.h:25:22: fatal error: features.h: No such file or directory
#include <features.h>
                      ^
compilation terminated.
scripts/Makefile.host:118: recipe for target 'scripts/basic/fixdep' failed
make[1]: *** [scripts/basic/fixdep] Error 1
Makefile:412: recipe for target 'scripts_basic' failed
make: *** [scripts_basic] Error 2
root@OrangePi_kali:/usr/src/trunk/linux-3.4#

There are several instances of the features.h, but none is in the ARM tree:
root@OrangePi_kali:/usr/src/trunk/linux-3.4# find / -name features.h
/usr/src/trunk/linux-3.4/kernel/sched/features.h
/usr/src/trunk/linux-3.4/include/xen/features.h
/usr/src/trunk/linux-3.4/include/xen/interface/features.h
/usr/src/trunk/brandy/gcc-linaro/arm-linux-gnueabi/libc/usr/include/features.h
/usr/include/c++/4.9/parallel/features.h

What is the right procedure rebuilding and installing the modules so that system customisation could be done?


You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list