Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 15042|Reply: 7

Getting standard USB webcams to work?

[Copy link]

1

Threads

3

Posts

21

Credits

Novice

Rank: 1

Credits
21
Post time 2016-4-16 07:53:04 | Show all posts |Read mode
Hello everyone,

i am trying to create a simple online webcam with one of the many cheap webcams i have laying around but i dont get them to work with my Orange PI2. They just dont get recognized as an USB device.

Can somone maybe help me with this? Maybe its an driver problem or so.

Post time 2016-4-19 00:11:07 | Show all posts
Edited by MaqcBreaker at 2016-4-19 21:49

Hi,

i can only speak about orange pi pc but i think it will run also on opi2.

Load a image from armbian.com and install it. (http://www.armbian.com/orange-pi-2/)

(root)

  1. apt-get update
  2. apt-get upgrade

  3. apt-get install subversion-tools libcairo2-dev libjpeg62-turbo-dev libpango1.0-dev libgif-dev build-essential g++ imagemagick
Copy the Code

Now you will (hopefully) find your device under "lsusb".

After this install mjpg-streamer:

  1. svn co https://svn.code.sf.net/p/mjpg-streamer/code/mjpg-streamer mjpg-streamer

  2. cd mjpg-streamer
  3.         
  4. make
  5. make install
Copy the Code
Test ->

  1. mjpg_streamer -i "/usr/local/lib/input_uvc.so -d /dev/video0 -n -y -r 640x480 -f 15" -o "/usr/local/lib/output_http.so -n -w /usr/local/www -p 8080"
Copy the Code
On my side it worked with a Logitech C170 Cam without any problems.

Bus 002 Device 002: ID 046d:082b Logitech, Inc.

Good luck!!!



1

Threads

90

Posts

719

Credits

Senior member

Rank: 4

Credits
719
Post time 2016-4-17 12:50:57 | Show all posts
what is the output of lsusb ?

1

Threads

3

Posts

21

Credits

Novice

Rank: 1

Credits
21
 Author| Post time 2016-4-18 07:57:44 | Show all posts
lymon replied at 2016-4-17 12:50
what is the output of lsusb ?

There is no new entry.

  1. orangepi@OrangePI:~$ lsusb
  2. Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  3. Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  4. Bus 002 Device 002: ID 152d:2329 JMicron Technology Corp. / JMicron USA Technology Corp. JM20329 SATA Bridge
  5. Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  6. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Copy the Code


1

Threads

90

Posts

719

Credits

Senior member

Rank: 4

Credits
719
Post time 2016-4-18 13:28:32 | Show all posts
Maybe a power-supply problem and it's not registering because of that.
what kind of webcam is it ?

Have you tried connecting it through an external USB hub with a separate power supply ?

does it work on any other linux machines ?

1

Threads

90

Posts

719

Credits

Senior member

Rank: 4

Credits
719
Post time 2016-4-18 13:28:56 | Show all posts
Maybe a power-supply problem and it's not registering because of that.
what kind of webcam is it ?

Have you tried connecting it through an external USB hub with a separate power supply ?

does it work on any other linux machines ?

1

Threads

3

Posts

21

Credits

Novice

Rank: 1

Credits
21
 Author| Post time 2016-4-20 05:01:26 | Show all posts
@lymon
Two of the cams can be used without any driver under windows but i the third needs a driver.
Yes i tested them all under my LinuxMint installation (main pc) and they all work out of the box.

No i dont tested them with an active USB hub but the cams draw between 40-80mAh so i dont think thats too much for the PI2.

But here i have some of the IDs i could get while i did the tests on my big linux machine:
Bus 002 Device 005: ID 18ec:3399 Arkmicro Technologies Inc.
Bus 002 Device 006: ID 058f:5608 Alcor Micro Corp.
Bus 002 Device 007: ID 05a9:4519 OmniVision Technologies, Inc. Webcam Classic


@MaqcBreaker
I tried Armbian before but i just had problems with it (i last tested it 3 months ago), i am now using Debian from this thread http://www.orangepi.org/orangepi ... &extra=page%3D1
I also could find and install all of the packages you suggested but it dont seem to help, the cams still dont show up :/
Post time 2016-4-20 20:41:46 | Show all posts
TomTheDragon replied at 2016-4-20 05:01
@lymon
Two of the cams can be used without any driver under windows but i the third needs a driver.
...

@TomTheDragon


..that`s why i suggest to use the armbian (5.05) image.

eg.



There was a lot of progress in the last 3 month by armbian. ;-)

You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2021-4-12 08:52 GMT+8 , Processed in 0.033196 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list