please choosego to mobile | Continue to access the PC version
View: 2801|Reply: 3

OPiOne Not Bootting

[Copy link]

2

threads

6

posts

208

credits

Intermediate member

Rank: 3Rank: 3

credits
208
Published in 2016-12-13 20:10:31 | Show all floors |Read mode
I have been trying to get various images to work on my OPI One in thisthread.I think one of my bards has developed an issue.
I am using a 5V 8Amp SMPS.
When I start up with the Serial debug I get the following result
  1. U-Boot SPL 2016.09-armbian (Sep 15 2016 - 07:19:14)
  2. DRAM: 512 MiB
  3. Trying to boot from MMC1


  4. U-Boot 2016.09-armbian (Sep 15 2016 - 07:19:14 +0200) Allwinner Technology

  5. CPU:   Allwinner H3 (SUN8I 1680)
  6. Model: Xunlong Orange Pi One
  7. DRAM:  512 MiB
  8. MMC:   SUNXI SD/MMC: 0
  9. *** Warning - bad CRC, using default environment

  10. In:    serial
  11. Out:   serial
  12. Err:   serial
  13. Net:   phy interface0
  14. eth0: ethernet@1c30000
  15. Hit any key to stop autoboot:  0
  16. switch to partitions #0, OK
  17. mmc0 is current device
  18. Scanning mmc 0:1...
  19. Found U-Boot script /boot/boot.scr
  20. 2886 bytes read in 143 ms (19.5 KiB/s)
  21. ## Executing script at 43100000
  22. gpio: pin PL10 (gpio 298) value is 1
  23.    Warning: value of pin is still 0
  24. gpio: pin PG11 (gpio 203) value is 1
  25. ** File not found /boot/.verbose **
  26. ** File not found /boot/.next **
  27. ** Unrecognized filesystem type **
  28. ** File not found .next **
  29. 35908 bytes read in 405 ms (85.9 KiB/s)
  30. 3114523 bytes read in 307 ms (9.7 MiB/s)
  31. 5025168 bytes read in 451 ms (10.6 MiB/s)
  32. ## Loading init Ramdisk from Legacy Image at 43300000 ...
  33.    Image Name:   uInitrd
  34.    Image Type:   ARM Linux RAMDisk Image (gzip compressed)
  35.    Data Size:    3114459 Bytes = 3 MiB
  36.    Load Address: 00000000
  37.    Entry Point:  00000000
  38.    Verifying Checksum ... OK
  39. Using machid 0x1029 from environment

  40. Starting kernel ...

Copy code

If I power cycle the board,  the follow line repeat a lot after Starting Kernel
  1. U-Boot SPL 2016.09-armbian (Sep 15 2016 - 07:19:14)
  2. DRAM: 512 MiB
  3. Trying to boot from FEL
Copy code


Any ideas if I can fault find this board?  
( I am a Linux newby but will investigate as much as I can).


1

threads

65

posts

240

credits

Intermediate member

Rank: 3Rank: 3

credits
240
Published in 2016-12-13 21:58:51 | Show all floors
Have  you used a correct script.bin and uImage for your OPI ONE?

2

threads

6

posts

208

credits

Intermediate member

Rank: 3Rank: 3

credits
208
 Author| Published in 2016-12-14 02:58:04 | Show all floors
Yes.  I have two OPI One boards.  I use the same image on both. One boards works exactly as expected.  I have tried the same new 16G SD card in both boards.

1

threads

65

posts

240

credits

Intermediate member

Rank: 3Rank: 3

credits
240
Published in 2016-12-15 17:32:55 | Show all floors
Can you compare the u-boot output from two boards?
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list