please choosego to mobile | Continue to access the PC version
View: 3403|Reply: 0

Orange Pi Plus 2 RTSP Stream issues (IP Cameras)

[Copy link]








Rank: 1

Published in 2016-12-15 22:37:52 | Show all floors |Read mode
Edited by ClickIt1221 at 2016-12-15 22:39

I have purchased an Orange Pi Plus 2 system and used thefollowing image "Ubuntu 15.04 with Mate Desktop, updated:2015-09-19"from Iused Win32DiskImager to image the SD card with the Ubuntu 15.04 image. Afterimaging i chaged uImage_OPI_Plus file to uImage and copied to boot directory. Iwas able to successfully boot into the OS and update/upgrade numerous items.From that point I was able to perform a "sudo do-release-upgrade",made sure "pre-released updates" under software & updates ischecked and performed a "sudo apt-get -f install" to upgrade the OSto a newer version.  I installed some other software likemono-complete, ffmpeg, and my sql server/my sql workbench.

Currently the OS is Ubuntu 16.04.1 LTS (Xenial Xerus) 32bit. kernel version is3.4.39. I am trying to pull live video from an IP camera (tried multiplebrands, Axis, American dynamics, ClickIt IP cameras, etc.). I am able to pullthe MJPEG streams successfully, able to receive a live image and record thelive video when the cameras are set to MJPEG. However when i switch the camerasto the H.264 stream and try to pull the RTSP stream from the cameras, I am nolonger able to see a live image for any of the cameras, unable to record videoeither. I even tried to use VLC and pull the RTSP streams from the camera directlybut that is also failing. I am able to pull the RTSP streams for the samecameras using VLC on the Raspberry Pi3 and ODROID-C2 systems, issue is onlywithin the Orange Pi Plus 2 system with the RTSP stream.

If anyone knows how to get the RTSP stream working on the Orange Pi Plus 2system, please let me know or if you can point me in the right direction. Ihave been working on this for a while and tried researching this issue but havenot been able to resolve this.
Note: I have also confirmed the firewall is not active and is disabled, sothere should not be anything blocking me from using the RTSP port (554)
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list