please choosego to mobile | Continue to access the PC version
View: 8096|Reply: 13

[solved]OPI pc+ with emmc+wifi+gpio+serial

[Copy link]

6

threads

22

posts

109

credits

Registered member

Rank: 2

credits
109
Published in 2017-2-20 19:21:57 | Show all floors |Read mode
Edited by wwwlu at 2017-2-24 17:53

I can't find a linux distrib with following functions for my orange pi pc plus:
-can be installed on EMMC
-support of the integrated wifi card
-GPIO management (gpio_pyH3)
-Serial ports management (python-serial)

I tried Lubuntu_1404 but I did not succeed to install on EMMC
With Armbian I can't manage GPIO and serial port
With loboris distribs the integrated wifi card is not managed

Can you help please ?

9

threads

634

posts

4400

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4400
Published in 2017-2-20 21:54:10 | Show all floors
With Armbian I can't manage GPIO and serial port


Well, you stick to most supported, which is clearly Armbian, and continue from there. Everything is doable - but you might need to find some how-to.

I don't work with GPIO under python ... am sure you can make it work.  

6

threads

22

posts

109

credits

Registered member

Rank: 2

credits
109
 Author| Published in 2017-2-21 16:54:26 | Show all floors
Thank you Igorpec, I'll search that way

6

threads

22

posts

109

credits

Registered member

Rank: 2

credits
109
 Author| Published in 2017-2-21 22:26:20 | Show all floors
I tested the following images:
Armbian_5.25_Orangepipcplus_Ubuntu_xenial_default_3.4.113_desktop.img
Armbian_5.25_Orangepipcplus_Ubuntu_xenial_default_3.4.113.img
Armbian_5.25_Orangepipcplus_Debian_jessie_default_3.4.113.img
and the result is the same for all of them:
Impossible to boot... Black screen after "starting kernel..."

I finaly succeed to boot with a dev image:
Armbian_5.26.170222_Orangepipcplus_Ubuntu_xenial_dev_4.10.0_desktop.img
But I cannot activate the wifi. In network connections all the fields are in light grey and cannot be edited

6

threads

22

posts

109

credits

Registered member

Rank: 2

credits
109
 Author| Published in 2017-2-21 23:36:31 | Show all floors
The integrated wifi card is recognised with older version:
Armbian_5.14_Orangepipcplus_Debian_jessie_3.4.112_desktop

9

threads

634

posts

4400

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4400
Published in 2017-2-21 23:57:17 | Show all floors
Edited by igorpec at 2017-2-21 17:00
I tested the following images:
Armbian_5.25_Orangepipcplus_Ubuntu_xenial_default_3.4.113_desktop.img
Armbian_5.25_Orangepipcplus_Ubuntu_xenial_default_3.4.113.img
Armbian_5.25_Orangepipcplus_Debian_jessie_default_3.4.113.img
and the result is the same for all of them:
Impossible to boot... Black screen after "starting kernel..."

I finaly succeed to boot with a dev image:
Armbian_5.26.170222_Orangepipcplus_Ubuntu_xenial_dev_4.10.0_desktop.img
But I cannot activate the wifi. In network connections all the fields are in light grey and cannot be edited

All images are working - I just test first one from the list which proves, that you are doing something wrong. From starting kernel to login prompt it takes 5-10 seconds  (with nothing on the screen), little longer without a network cable, but mostly depending from your SD card.

Read some documentation before waisting time. Yours and mine.
https://docs.armbian.com/User-Guide_Getting-Started/

If you have a monitor with some odd screen size, that is not capable of at least 720p, which is default screen resolution for first boot, than ... look into docs again.

Wifi works out of the box. Tested again and BTW we fix most of problems and test most of our images, that you don't need to waste your time: https://www.armbian.com/donate/


Are you sure you have Orange Pi PC+ board?

9

threads

634

posts

4400

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4400
Published in 2017-2-22 00:30:52 | Show all floors
One thing to mention. Our first batch of 5.25 had some problems (missing desktop acceleration) ... in case you have 5.25. with build date 2.2., than download images again. They were corrected 4.2.

6

threads

22

posts

109

credits

Registered member

Rank: 2

credits
109
 Author| Published in 2017-2-22 01:01:55 | Show all floors
Yes I have a Orange Pi PC+ board (I have actually 12 )
I use a LG Flatron w2246 monitor (resolution 1920 x 1080) with a RGB/hdmi adapter
I waited 4 minutes with the black screen and nothing else happened
But I finally succeded to boot and have wifi using this version : Armbian_5.14_Orangepipcplus_Debian_jessie_3.4.112_desktop
Now my problem is about python serial. I think I should create a new thread

9

threads

634

posts

4400

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4400
Published in 2017-2-22 02:53:28 | Show all floors
OK. Anyway, I would like to know why latest image is not working for you. Just check build date inside .7z package - no need to install ... since it must work and it worked for me out of the box + I used a slightly non standard monitor with 1280x1024.

If you are using some scrapped SD card, 4 minutes might not be enough Another idea is also, that your power supply is on the edge. In case of shortage, HDMI is powered off first.

1

threads

3

posts

21

credits

Novice

Rank: 1

credits
21
Published in 2017-2-22 06:52:19 | Show all floors
I couldn't get the wifi to even be recognized on 5.14 but It works for me just great on 5.25.
It installed to the emmc no problem - it just took the better part of 2 hours.  Boots like lightning
now, wifi is up, and recognizes a C-media usb audio card.
For reference I'm using a 37" Viewsonic TV (720P)
Having fun, Dave
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list