Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: FransM

WiFi module

[Copy link]

5

Threads

37

Posts

136

Credits

Registered member

Rank: 2

Credits
136
Post time 2015-1-25 16:24:16 | Show all posts
I have compiled the kernel with 8188eu with success:
  1. [    1.594893] sw_usb_enable_hcd: usbc_num = 1
  2. [    1.599783] usbcore: registered new interface driver rtl8188eu
  3. [    1.611352] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
  4. [    1.623091] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
Copy the Code

But now I have to activate the USB wifi in fex.txt but it's a bit difficult...
I think I have to wait for a working script.bin !!

7

Threads

100

Posts

647

Credits

Senior member

Rank: 4

Credits
647
Post time 2015-1-25 17:20:50 | Show all posts
Tankafaire replied at 2015-1-25 16:24
I have compiled the kernel with 8188eu with success:

But now I have to activate the USB wifi in fex ...

Hi

Can you post a step by step list What is to do to compile.
I come from windows and have no experience in linux.

Thank you

5

Threads

37

Posts

136

Credits

Registered member

Rank: 2

Credits
136
Post time 2015-1-25 17:33:08 | Show all posts
Edited by Tankafaire at 2015-1-25 11:02

@john0815: I have created a new thread:  http://www.orangepi.org/orangepibbsen/forum.php?mod=viewthread&tid=43&extra=page%3D1

1

Threads

25

Posts

212

Credits

Intermediate member

Rank: 3Rank: 3

Credits
212
Post time 2015-1-25 18:14:01 | Show all posts
Edited by ryba84 at 2015-1-25 18:21

@Tankafaire I've this same result with bananian kernel (without modify). I've tried changing usbc_num in script.bin to 0,1,2 and wifi isn't showing in lsusb output nor in dmesg. Only info about loading driver.

EDIT:
Ok. After studying schematics I've finally found! Wifi is default disabled (power supply for wifi module is switched off). To use onboard module You must pull up PH22 CPU pin.
GUIDE TO MANUAL RUN WIFI ON UNMODIFIED BANANIAN:
1. Download script.bin https://drive.google.com/file/d/ ... 3c/view?usp=sharing
2. Replace original /boot/script.bin with downloaded
3. Reboot OrangePi
4. Do as root:
  1. echo 89 > /sys/class/gpio/export
  2. echo out > /sys/class/gpio/gpio89/direction
  3. echo 1 > /sys/class/gpio/gpio89/value
Copy the Code
From now You should have onboard wifi working. You should see in dmesg output something like this:

  1. [  178.771388] ehci_irq: port change detect
  2. [  179.053845] usb 3-1: new high-speed USB device number 2 using sw-ehci
  3. [  179.215579] usb 3-1: New USB device found, idVendor=0bda, idProduct=8179
  4. [  179.228405] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
  5. [  179.238975] usb 3-1: Product: 802.11n WLAN NIC
  6. [  179.246584] usb 3-1: Manufacturer: Realtek
  7. [  180.430715] sw_usb_enable_hcd: usbc_num = 1
  8. [  180.587295] usbcore: registered new interface driver rtl8188eu
  9. [  181.336079] ADDRCONF(NETDEV_UP): wlan0: link is not ready
  10. [  181.364041] ADDRCONF(NETDEV_UP): wlan0: link is not ready
  11. [  183.292849] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
  12. [  183.317768] UpdateHalRAMask8188EUsb => mac_id:0, networkType:0x0b, mask:0x000fffff
  13. [  183.317781]   ==> rssi_level:0, rate_bitmap:0x000ff005
  14. [  183.385911] UpdateHalRAMask8188EUsb => mac_id:0, networkType:0x0b, mask:0x000fffff
  15. [  183.385938]   ==> rssi_level:2, rate_bitmap:0x000ff000
Copy the Code


5

Threads

37

Posts

136

Credits

Registered member

Rank: 2

Credits
136
Post time 2015-1-25 18:28:16 | Show all posts
Edited by Tankafaire at 2015-1-25 11:44

Ok, I never found the solution alone ! Thanks for sharing, I will try this.

1

Threads

25

Posts

212

Credits

Intermediate member

Rank: 3Rank: 3

Credits
212
Post time 2015-1-25 18:52:08 | Show all posts
If You want to automatically enable onboard wifi during boot add commands from guide to Your /etc/rc.local. We must prepare proper script bin for our board.

5

Threads

37

Posts

136

Credits

Registered member

Rank: 2

Credits
136
Post time 2015-1-25 19:14:34 | Show all posts
Yeah it work !
I have done this:
  1. echo "89" | sudo tee /sys/class/gpio/export
  2. echo "out" | sudo tee /sys/class/gpio/gpio89/direction
  3. echo "1" | sudo tee /sys/class/gpio/gpio89/value
Copy the Code

and
  1. $ lsusb
  2. Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB
  3. Bus 003 Device 002: ID 0bda:8179 Realtek Semiconductor Corp.
  4. ...
Copy the Code

Thanks

5

Threads

37

Posts

136

Credits

Registered member

Rank: 2

Credits
136
Post time 2015-1-25 19:39:04 | Show all posts
It's ok too, with the lines inside /etc/rc.local, but wifi is available after ~1min:

  1. [   26.490307] disp clks: lcd 106500000 pre_scale 1 hdmi 106500000 pll 213000000 2x 0
  2. [   88.905716] EXT4-fs (sda1): re-mounted. Opts: data=ordered
  3. [   89.123112] ehci_irq: port change detect
  4. [   89.127482] ehci_irq: port change detect
  5. [   89.131312] ehci_irq: port change detect
  6. [   89.448132] usb 3-1: new high-speed USB device number 2 using sw-ehci
  7. [   89.609800] usb 3-1: New USB device found, idVendor=0bda, idProduct=8179
  8. [   89.622690] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
  9. [   89.633295] usb 3-1: Product: 802.11n WLAN NIC
  10. [   89.640942] usb 3-1: Manufacturer: Realtek
  11. [   89.908450] udevd[303]: renamed network interface wlan0 to wlan1
Copy the Code

You can see between 26s and 89s there's nothing (dmesg after 5 min)
Also, wlan0 is renamed to wlan1, but it's not very important I suppose.
I havn't configured wifi yet.

1

Threads

25

Posts

212

Credits

Intermediate member

Rank: 3Rank: 3

Credits
212
Post time 2015-1-25 20:03:56 | Show all posts
Edited by ryba84 at 2015-1-25 22:54

You using original bananian image? I've using only bananian kernel (my kernels don't work and I have no clue why) on my Debian Jessy image, and wifi is showing up on 36s. I wonder if we could default enable wifi in script.bin. This should speed up things.

5

Threads

37

Posts

136

Credits

Registered member

Rank: 2

Credits
136
Post time 2015-1-25 21:50:59 | Show all posts
Edited by Tankafaire at 2015-1-25 15:26

Yes, it's a compiled kernel, 3.4.105+
I will try to modify script.bin to see if something change.
Edit:
wifi works!
  1. orangepi@orangepi:~$ sudo service networking restart
  2. [warn] Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
  3. [....] Reconfiguring network interfaces...ioctl[SIOCSIWAP]: Operation not permitted
  4. ioctl[SIOCSIWENCODEEXT]: Invalid argument
  5. ioctl[SIOCSIWENCODEEXT]: Invalid argument
  6. Internet Systems Consortium DHCP Client 4.2.2
  7. Copyright 2004-2011 Internet Systems Consortium.
  8. All rights reserved.
  9. For info, please visit https://www.isc.org/software/dhcp/

  10. Listening on LPF/wlan1/ac:a2:13:5a:f7:c5
  11. Sending on   LPF/wlan1/ac:a2:13:5a:f7:c5
  12. Sending on   Socket/fallback
  13. DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 8
  14. DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 8
  15. DHCPREQUEST on wlan1 to 255.255.255.255 port 67
  16. DHCPOFFER from 192.168.2.1
  17. DHCPACK from 192.168.2.1
  18. bound to 192.168.2.7 -- renewal in 725288140 seconds.
  19. ifup: interface wlan1 already configured
  20. done.
Copy the Code
But I must to wait about 80s to make the sudo service networking restart command


You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-7-9 06:58 GMT+8 , Processed in 0.030027 second(s), 19 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list