please choosego to mobile | Continue to access the PC version
View: 13072|Reply: 8

Lubuntu HDMI sound

[Copy link]

1

threads

3

posts

23

credits

Novice

Rank: 1

credits
23
Published in 2015-5-20 20:41:32 | Show all floors |Read mode
Hi all,

Firefox youtube's video, mplayer and aplay cant output sound to HDMI or the audio jack. Have been googling around but still did not find a solution. Anyone got any tips?

Thanks and best regards,
Hew

6

threads

116

posts

401

credits

Intermediate member

Rank: 3Rank: 3

credits
401
Published in 2015-5-21 04:43:39 | Show all floors
WEll, looks like Lubuntu is at Beta Stage and needs some polishing before it will have everything working.
But the most important is that something done in order to have it up and running.
I am sure that very soon it will be more finished.

As far as i understand--boards with H3 CPU are quite new and it will take some time until everything developed properly.

So as far as I understand--Linux cant read yet EDID info from HDMI chip in monitor or tv--thats why  only 720p by default. Also sound needs to be fixed and Mali driver needs to be integrated and CPU Freq.

1

threads

39

posts

137

credits

Registered member

Rank: 2

credits
137
Published in 2015-5-25 22:27:54 | Show all floors
I just started with the orange pi plus.  I see that the audio does not even appear to be enabled.  So even if I chose to use a usb audio device, I cannot get it to work.  It seems like usb audio should work and should be enabled by default.  I ran across this when building a kernel for a banana pro.  It's audio was not working, and I had to build a kernel to allow me to use usb audio while waiting for internal audio drivers to work.  
Wiki page on sunx named "Xunlong Orange Pi Plus" says:

Manual build
    As yet there is no support for the orange pi 2 in uboot.
Mainline kernel
As yet there is no support for the orange pi 2 in the mainline kernel

Can I do this or can someone working on it enable audio so I can use this board?

Mark

2

threads

53

posts

1502

credits

Gold member

Rank: 6Rank: 6

credits
1502
Published in 2015-6-17 20:00:00 | Show all floors
I have the same problem. No audio on HDMI with Lubuntu, but also no audio on HDMI using the Android on EMMC, booting without any sd.

1

threads

3

posts

23

credits

Novice

Rank: 1

credits
23
 Author| Published in 2015-6-19 21:47:50 | Show all floors
Looks the kernel HDMI audio driver is working if you recompile it with option
SND_SUNXI_SOC_SUPPORT_AUDIO_RAW turned off.

When SND_SUNXI_SOC_SUPPORT_AUDIO_RAW is turned on, it modifies the snd_pcm_hw_params structure in asound.h and cause ioctl functions to fail in sound\core\pcm_native.c.

10

threads

448

posts

4367

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4367
Published in 2015-6-20 00:49:27 | Show all floors
hhc replied at 2015-6-19 21:47
Looks the kernel HDMI audio driver is working if you recompile it with option
SND_SUNXI_SOC_SUPPORT ...

Thank you for sharing that information. Now I've got sound working in my images on OPI-2.

3

threads

96

posts

535

credits

Senior member

Rank: 4

credits
535
Published in 2015-6-20 11:57:12 | Show all floors
So how do you  recompile? (sent from my OPiPlus)
Orange Pi Plus

5

threads

15

posts

58

credits

Registered member

Rank: 2

credits
58
Published in 2016-7-31 04:26:47 | Show all floors
Any update for Lubuntu 16.04 which can run with all of its drivers on OPI Plus 2....

9

threads

641

posts

4379

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4379
Published in 2016-7-31 13:08:27 | Show all floors
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list