Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 7832|Reply: 5

serial

[Copy link]

6

Threads

43

Posts

222

Credits

Intermediate member

Rank: 3Rank: 3

Credits
222
Post time 2015-5-26 23:22:59 From the mobile phone | Show all posts |Read mode
HELLO i need to use the serial (rx tx) on gpio of the orange pi (i need to connect it to a esp8266 module).
What are the serial Pin? I need to modify something in boot params like Raspberry?
Thx

10

Threads

448

Posts

3877

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
3877
Post time 2015-8-20 17:07:18 | Show all posts
Edited by loboris at 2015-8-20 10:20
alexparadise replied at 2015-8-19 20:05
Did you made any progress?? Until now I didn't manage to use /dev/ttyS0, never seen /dev/ttyAMA0 and ...

You must enable UART(s) in fex to use UART1-UART3.
To use /dev/ttyS0 (UART0) you must first disable it as kernel console (in sun8iw7p1.h) and rebuild u-boot.
For USBtoUART the kernel must have USBtoSerial modules built. You can try one of my images, I think it should work.

0

Threads

19

Posts

111

Credits

Registered member

Rank: 2

Credits
111
Post time 2015-8-20 03:05:04 | Show all posts
Did you made any progress?? Until now I didn't manage to use /dev/ttyS0, never seen /dev/ttyAMA0 and I can't connect my arduino board to orange pi by the usb serial :-/

0

Threads

1

Posts

10

Credits

Novice

Rank: 1

Credits
10
Post time 2015-11-14 23:06:08 | Show all posts
loboris, can you ON all 4 UART in next kernel imige from you? Now in sys_config.fex
ttyS0=enable
ttyS1=enable
ttyS2=disable
ttyS3=disable

with raspberry Pi 2 identifical ttyS3 (OFF) => My orange PI PC not working an Boards creating for Raspberry Pi,
not compatible.

0

Threads

1

Posts

54

Credits

Registered member

Rank: 2

Credits
54
Post time 2015-12-11 06:32:33 | Show all posts
pentagon128 replied at 2015-11-14 23:06
loboris, can you ON all 4 UART in next kernel imige from you? Now in sys_config.fex
ttyS0=enable
tty ...

Thank you

3

Threads

13

Posts

81

Credits

Registered member

Rank: 2

Credits
81
Post time 2016-2-5 19:19:05 | Show all posts
loboris replied at 2015-8-20 17:07
You must enable UART(s) in fex to use UART1-UART3.
To use /dev/ttyS0 (UART0) you must first disable ...

Can you help.  I have a version of Jessie which was made from yours - everything works except the UARTS - so that in Node-Red it sees uart 0-3 but cannot open them. I'm afraid I did not understand that comment about FEX...

In my BOOT directory I have..
boot0_OPI.fex
u-boot_OPI.fex
u-boot_OPI-emmc.fex

This is on an Orange Pi PC.

Is there anything I can do inside Jessie to enable the UARTs?

chrome-extension://bigefpfhnfcobdlfbedofhhaibnlghod/mega/secure.html#fm/transfers

That is the file download...  I simply loaded it up - removed NGINX and put the likes of Apache, Node-Red etc on... and the only thing I'm hitting a brick wall with is the UARTs.

Pete.

You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2019-11-13 05:09 GMT+8 , Processed in 0.032309 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list