please choosego to mobile | Continue to access the PC version
Author: loboris

Linux Distributions for Orange PI H3 boards

  [Copy link]

0

threads

3

posts

76

credits

Registered member

Rank: 2

credits
76
Published in 2015-11-18 22:47:53 | Show all floors
Yeah. thanks @Loboris!
All compiles & works fine!
Tested:
Nginx 1.9.6@latest
php5.6.7
phpMyAdmin@latest
MariaDB 10 with jemalloc
redis@latest
Nodejs@latest
owfs@latest  w all sup modules
GPIOlib@latest




  1. root@jessika:~# (cd /mnt/1wire/ && ls)
  2. 01.67C6697351FF  22.F2FBE3467CC2  alarm  settings      statistics  system
  3. 10.4AEC29CDBAAB  29.54F81BE8E78D  bus.0  simultaneous  structure   uncached
  4. root@jessika:~# owfs --version
  5. /usr/lib/owfs/owfs version:
  6.         3.1p0
  7. libow version:
  8.         3.1p0
  9. root@jessika:~# php -v
  10. PHP 5.6.7-1 (cli)
  11. Copyright (c) 1997-2015 The PHP Group
  12. Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
  13.     with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2015, by Zend Technolog                                                                                 ies
  14. root@jessika:~# gpio readall
  15. +-----+-----+----------+------+---+--OrangePiPC--+---+------+---------+----                                                                                 -+--+
  16. | BCM | wPi |   Name   | Mode | V | Physical | V | Mode | Name     | wPi |                                                                                  BCM |
  17. +-----+-----+----------+------+---+----++----+---+------+----------+-----+-                                                                                 ----+
  18. |     |     |     3.3v |      |   |  1 || 2  |   |      | 5v       |     |                                                                                      |
  19. |   2 |  -1 |    SDA.0 |      |   |  3 || 4  |   |      | 5V       |     |                                                                                      |
  20. |   3 |  -1 |    SCL.0 |      |   |  5 || 6  |   |      | 0v       |     |                                                                                      |
  21. |   4 |   6 | IO6 PA06 |  OUT | 0 |  7 || 8  |   |      | TxD3     |     |                                                                                      |
  22. |     |     |       0v |      |   |  9 || 10 |   |      | RxD3     |     |                                                                                      |
  23. |  17 |  -1 |     RxD2 |      |   | 11 || 12 | 0 | OUT  | IO1 PD14 | 1   |                                                                                  18  |
  24. |  27 |  -1 |     TxD2 |      |   | 13 || 14 |   |      | 0v       |     |                                                                                      |
  25. |  22 |  -1 |     CTS2 |      |   | 15 || 16 | 0 | OUT  | IO4 PC04 | 4   |                                                                                  23  |
  26. |     |     |     3.3v |      |   | 17 || 18 | 0 | OUT  | IO5 PC07 | 5   |                                                                                  24  |
  27. |  10 |  -1 |     MOSI |      |   | 19 || 20 |   |      | 0v       |     |                                                                                      |
  28. |   9 |  -1 |     MISO |      |   | 21 || 22 |   |      | RTS2     |     |                                                                                      |
  29. |  11 |  -1 |     SCLK |      |   | 23 || 24 |   |      | SPI-CE0  |     |                                                                                      |
  30. |     |     |       0v |      |   | 25 || 26 |   |      | CE1      |     |                                                                                      |
  31. |   0 |  -1 |    SDA.1 |      |   | 27 || 28 |   |      | SCL.1    |     |                                                                                      |
  32. |   5 |   7 |  IO7 PA7 |  OUT | 0 | 29 || 30 |   |      | 0v       |     |                                                                                      |
  33. |   6 |   8 |  IO8 PA8 |  OUT | 0 | 31 || 32 | 0 | OUT  | IO9 PG08 | 9   |                                                                                  12  |
  34. |  13 |  10 | IO10 PA9 |  OUT | 0 | 33 || 34 |   |      | 0v       |     |                                                                                      |
  35. |  19 |  12 | IO12PA10 |  OUT | 0 | 35 || 36 | 0 | OUT  | IO13PG09 | 13  |                                                                                  16  |
  36. |  26 |  14 | IO14PA20 | ALT3 | 0 | 37 || 38 | 0 | OUT  | IO15PG06 | 15  |                                                                                  20  |
  37. |     |     |       0v |      |   | 39 || 40 | 0 | OUT  | IO16PG07 | 16  |                                                                                  21  |
  38. +-----+-----+----------+------+---+----++----+---+------+----------+-----+-                                                                                 ----+
  39. | BCM | wPi |   Name   | Mode | V | Physical | V | Mode | Name     | wPi |                                                                                  BCM |
  40. +-----+-----+----------+------+---+--OrangePIPC--+------+----------+-----+-                                                                                 ----+

Copy code

0

threads

3

posts

36

credits

Novice

Rank: 1

credits
36
Published in 2015-11-21 00:37:06 | Show all floors
Any help 4 kernel headers package?

18

threads

303

posts

9729

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
9729
Published in 2015-11-21 21:09:43 | Show all floors
lymon replied at 2015-11-17 14:04
sounds like a problem with the wpa-supplicant package

is it installed ?

It is working now. I added the WIFI manually in the network connections. But start-up log shows kernel modules loading error, also LSB overides error with Debian Jessie.

1

threads

4

posts

21

credits

Novice

Rank: 1

credits
21
Published in 2015-11-22 05:00:05 | Show all floors
Edited by wizard2015 at 2015-11-22 05:25

Does anyone know how to solve HDMI ovescan issue on the orange pi? Is there something like /boot/config.txt for the Orange Pi, similar to Raspberry Pi? Taken from here : http://www.webtechgadgetry.com/m ... resolution-monitor/
I am using Ubuntu 14.04.

18

threads

303

posts

9729

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
9729
Published in 2015-11-22 11:40:31 | Show all floors
Edited by jacer at 2015-11-22 11:43

Got some warnings during start-up using Debian 8. Any fix available?

root@OrangePI:/home/orangepi# systemctl status systemd-modules-load.service -l
systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
   Active: failed (Result: exit-code) since Thu 1970-01-01 08:10:24 CST; 2min 14s ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 265 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 265 (code=exited, status=1/FAILURE)

Jan 01 08:10:24 OrangePI systemd-modules-load[265]: Module 'fuse' is builtin
Jan 01 08:10:24 OrangePI systemd[1]: systemd-modules-load.service: main process exited, code=exited, status=1/FAILURE
Jan 01 08:10:24 OrangePI systemd[1]: Failed to start Load Kernel Modules.
Jan 01 08:10:24 OrangePI systemd[1]: Unit systemd-modules-load.service entered failed state.


0

threads

1

posts

26

credits

Novice

Rank: 1

credits
26
Published in 2015-11-22 21:58:24 | Show all floors
why no device g2c for allwinner h3. not compatible ?

0

threads

2

posts

32

credits

Novice

Rank: 1

credits
32
Published in 2015-11-23 10:31:15 | Show all floors
Hi there!
It's possibile to get Orange Pi Plus work with a custom resolution of 2560x1080px? I have an LG UltraWide monitor and was wondering if it's possibile to use full resolution!
What i have to do? There is some tutorial?

Thank you!

1

threads

2

posts

21

credits

Novice

Rank: 1

credits
21
Published in 2015-11-25 01:32:24 | Show all floors
How do I install these images on the Orangpi mini 2? It has an H3 processor, but it isn't listed in the supported boards...

Please help me, I've been stuck on this for days!

5

threads

31

posts

1161

credits

Gold member

Rank: 6Rank: 6

credits
1161
Published in 2015-11-25 05:05:11 | Show all floors
Hello, already seen in the forum how to view and modify both the CPU speed as the speed of DDR RAM.
Is it possible to do the same with the speed of mali400?

1

threads

3

posts

23

credits

Novice

Rank: 1

credits
23
Published in 2015-11-27 00:57:50 | Show all floors
Hello, Loboris. Thanks for your good work.
I bought an Orange PI PC and tried to follow your suggestions on your post.
I downloaded OrangePI-PC_Ubuntu_Vivid_Mate.img prepared for OrangePI users, just copy to SDCard, no configuration needed !
I  copied to SD card with win32 disk imager , then I linked an USB to TTL cable to rx/tx and I put the SDCard in the
Orange PI PC.
The boot messages were as follow, but noting on HDMI. What is wrong ?

HELLO! BOOT0 is starting!
boot0 version : 4.0.0
fel_flag = 0x00000000
rtc[0] value = 0x00000000
rtc[1] value = 0x00000000
rtc[2] value = 0x00000000
rtc[3] value = 0x00000000
rtc[4] value = 0x00000000
rtc[5] value = 0x00000000
rtc[6] value = 0x00000000
rtc[7] value = 0x00000000
DRAM DRIVE INFO: V0.8
DRAM Type = 3 (2DR2,3DR3,6PDDR2,7PDDR3)
DRAM CLK = 672 MHz
DRAM zq value: 003b3bfb
READ DQS LCDL = 001d1c1e
DRAM SIZE =1024 M
odt delay
dram size =1024
card boot number = 0
card no is 0
sdcard 0 line count 4
[mmc]: mmc driver ver 2014-12-10 21:20:39
[mmc]: ***Try SD card 0***
[mmc]: SD/MMC Card: 4bit, capacity: 15193MB
[mmc]: vendor: Man 00035344 Snr 000e8443
[mmc]: product: SS16G
[mmc]: revision: 8.0
[mmc]: ***SD/MMC 0 init OK!!!***
sdcard 0 init ok
The size of uboot is 000dc000.
sum=ede66ee7
src_sum=ede66ee7
Succeed in loading uboot from sdmmc flash.
Ready to disable icache.
Jump to secend Boot.
SUNXI_NORMAL_MODE   
already secure mode

[      0.376]

U-Boot 2011.09-rc1 (Jun 21 2015 - 19:33:17) Allwinner Technology

[      0.383]version: 1.1.0
normal mode
[      0.391]pmbus:   ready
not set main pmu id
axp_probe error
[      0.406]PMU: pll1 1200 Mhz,PLL6=600 Mhz
AXI=400 Mhz,AHB=200 Mhz, APB1=100 Mhz
sid read already
fel key new mode
run key detect
no key found
no key input
dram_para_set start
dram_para_set end
normal mode
[      0.437]DRAM:  1 GiB
relocation Offset is: 35af9000
[box standby] read rtc = 0x0
[box_start_os] mag be start_type no use
user_gpio config
user_gpio ok
gic: normal or no secure os mode
workmode = 0
MMC:     0
[      0.511][mmc]: mmc driver ver 2014-12-10 9:23:00
[      0.516][mmc]: get sdc_phy_wipe fail.
[      0.520][mmc]: get sdc0 sdc_erase fail.
[      0.524][mmc]: get sdc_f_max fail,use default 50000000Hz
[      0.529][mmc]: get sdc_ex_dly_used fail,use default dly
[      0.535][mmc]: SUNXI SD/MMC: 0
[      0.548][mmc]: *Try SD card 0*
[      0.599][mmc]: CID 0x3534453 0x53313647 0x80000e84 0x4300f4d1
[      0.604][mmc]: mmc clk 50000000
[      0.608][mmc]: SD/MMC Card: 4bit, capacity: 15193MB
[      0.613][mmc]: boot0 capacity: 0KB,boot1 capacity: 0KB
[      0.618][mmc]: ***SD/MMC 0 init OK!!!***
[      0.622][mmc]: erase_grp_size:0x1WrBlk * 0x200 = 0x200 Byte
[      0.628][mmc]: secure_feature 0x0
[      0.631][mmc]: secure_removal_type  0x0
[      0.635]sunxi flash init ok
script config pll_de to 864 Mhz
Not Found clk pll_video1 in script
script config pll_video to 297 Mhz
[boot]disp_init_tv
[DISP_TV] disp_init_tv enter g_tv_used
screen 0 do not support TV TYPE!
[BOOOT_DISP_TV] disp tv device_registered
unable to find regulator vcc-hdmi-18 from [pmu1_regu] or [pmu2_regu]
enable power vcc-hdmi-18, ret=-1
DRV_DISP_Init end
boot_disp.auto_hpd=1
auto hpd check has 50 times!
[disk_read_fs] no the partition
error: open disp_rsl.fex, maybe it is not exist
attched ok, mgr1<-->device1, type=2, mode=11----
ready to set mode
disp_tv_enable
[      1.476]finally, output_type=0x2, output_mode=0xb, screen_id=0x1, disp_para=0x20b0000
fail to find part named env
Using default environment

In:    serial
Out:   serial
Err:   serial
--------fastboot partitions--------
mbr not exist
base bootcmd=run setargs_mmc boot_normal
bootcmd set setargs_mmc
key 0
cant find rcvy value
cant find fstbt value
no misc partition is found
to be run cmd=run setargs_mmc boot_normal
[      1.513][mmc]: MMC Device 2 not found
[      1.517][mmc]: Can not find mmc dev
[      1.521][mmc]: read first backup failed in fun sdmmc_secure_storage_read line 1849
sunxi_secstorage_read fail
get secure storage map err
the private part isn't exist
WORK_MODE_BOOT
adver not need show
sunxi_bmp_logo_display
[disk_read_fs] no the partition
error: open bootlogo.bmp, maybe it is not exist
sunxi bmp info error : unable to open logo file bootlogo.bmp
[      1.554]Hit any key to stop autoboot:  3  2  1  0
[      4.813][mmc]: blkcnt should not be 0
[      5.286][mmc]: blkcnt should not be 0
## Booting kernel from Legacy Image at 40007800 ...
   Image Name:   Linux-3.4.39
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    10915552 Bytes = 10.4 MiB
   Load Address: 40008000
   Entry Point:  40008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK
[      5.477][mmc]: MMC Device 2 not found
[      5.481][mmc]:  mmc  not find,so not exit
[      5.485]
Starting kernel ...


You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list