please choosego to mobile | Continue to access the PC version
Author: loboris

Linux Distributions for Orange PI H3 boards

  [Copy link]

10

threads

448

posts

4564

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4564
 Author| Published in 2015-8-18 15:14:23 | Show all floors
fritz replied at 2015-8-17 22:49
@loboris
You still build your kernels with the lichee SDK from the Download section?

Could you suggest any other ?

5

threads

355

posts

2449

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
2449
Published in 2015-8-19 15:36:22 | Show all floors
Well, I think for now better stay with "old".
With "newer" I can build .defconfig and it's booting but when I try with your .config I have a nice crash:
[    1.807282] kernel BUG at mm/percpu.c:578!
[    1.811814] sunxi oops: enable sdcard JTAG interface
[    1.812143] sunxi oops: cpu frequency: 1536 MHz
[    1.812143] sunxi oops: ddr frequency: 672 MHz
[    1.812143] sunxi oops: gpu frequency: 105 MHz
[    1.812143] sunxi oops: cpu temperature: 217
[    1.812143] Internal error: Oops - BUG: 0 [#1] PREEMPT SMP ARM
[    1.812143] Modules linked in:
[    1.812143] CPU: 2    Not tainted  (3.4.39+ #5)
[    1.812143] PC is at pcpu_free_area+0x64/0x170
[    1.812143] LR is at pcpu_chunk_slot+0x50/0x60

I hope that someday Allwinner decide to release proper H3 kernelsources.
Boards:
orangepi plus, olinuxino A20, cubieboard A10, mele A2000 .....

1

threads

47

posts

189

credits

Registered member

Rank: 2

credits
189
Published in 2015-8-19 15:45:35 | Show all floors
fritz replied at 2015-8-18 05:49
@loboris
You still build your kernels with the lichee SDK from the Download section?


It seems that Tronsmart's sdk is older than Steven's.
I am testing the kernel 4.2-rc7 with Jens Kuske's patch series, but it is far from working!
(Jens told me he does not work actively on the H3)
The machine boots, UART and MMC work. Only 1 CPU can be activated with a clock frequency about 250MHz.
With Lubuntu (upstart), the mountall program does not see that the root device is already mounted.
With Debian (upgraded to sid), systemd does not want to give me a serial console (and same with the lichee kernel).
So, actually, I am trying to put the SDIO stuff of the 8189es in the staging driver rtl8188eu (I don't need ethernet).

0

threads

4

posts

20

credits

Novice

Rank: 1

credits
20
Published in 2015-8-19 20:14:11 | Show all floors
Hello Loboris,

I'm Thuc, I bought an Orange PI plus and I'm interesting with it. I tried with your debian image and it's great in SD card. I tried it with eMMC, it works well without script.bin, when I try create script.bin from your fex file and put it to /boot/, debian can't load. It's seam that the partition can't load. Could you help us check it.

1. The root what I find is "run debian Image in eMMC with resolution 720p". Could you give us any solution to edit fex file or anything to do it ?
2. Second question is about rotate. In Sunxi's site (http://linux-sunxi.org/Display#Rotation), they talk we can rotate by "echo <n>"
/sys/class/graphics/fbcon/rotate

I tried but the screen can't rotate. Do you know any information about it ? and have any other solution for it ?
3. Could we use uEnv.txt or boot.scr with your debian device and uImage ? if it's can, where I can place it to ?

Thanks in advance,
Thuc Le.

5

threads

355

posts

2449

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
2449
Published in 2015-8-19 23:15:31 | Show all floors
moinejf replied at 2015-8-19 08:45
It seems that Tronsmart's sdk is older than Steven's.
I am testing the kernel 4.2-rc7 with Jens K ...

its newer:
[mmc]: mmc driver ver 2015-04-13 16:07:39
[mmc]: ***Try SD card 0***
[mmc]: SD/MMC Card: 4bit, capacity: 7580MB
[mmc]: vendor: Man 00035344 Snr 002c7d5b
[mmc]: product: SU08G
[mmc]: revision: 8.0
[mmc]: ***SD/MMC 0 init OK!!!***
sdcard 0 init ok
[    0.060479] [ARISC] :sunxi-arisc driver v1.04
[    0.074726] [ARISC] :arisc version: [v0.1.52]
But newer does not mean that it's better than older.


Yeah, for mainline support there is a lot of work to do.


Boards:
orangepi plus, olinuxino A20, cubieboard A10, mele A2000 .....

2

threads

10

posts

308

credits

Intermediate member

Rank: 3Rank: 3

credits
308
Published in 2015-8-20 01:53:03 | Show all floors
loboris replied at 2015-7-26 05:30
Just curious about your questions.
how did you do it?  (did what ?)
it gives me an error .... ( wha ...

I continued running tests and I have reached a point that I can not solve . With the system Ubuntu_base in my orangepiplus. Connect to the wifi and run the script "sudo update_boot.sh " downloaded the files from your server and select option 2 " orangepiplus " . When you start the system again got errors saying :

[  613.826087] gmac0 gmac0: eth0: eth0: PHY ID 00000000 at 0 IRQ poll (gmac0-0:00)
[  613.836276] gmac0 gmac0: eth0: Initialize hardware error


And Eth0 not up

Any ideas?
I have any error in the process?

Thanks!!








10

threads

448

posts

4564

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4564
 Author| Published in 2015-8-20 02:20:08 | Show all floors
@ledongthuc, @rupertgti I hope I'll receive OPI-plus soon, than I'll be able to test it properly and solve the problems related to it.

0

threads

4

posts

20

credits

Novice

Rank: 1

credits
20
Published in 2015-8-20 05:24:29 | Show all floors
ok, thank Loboris, I hope you got it soon
Published in 2015-8-20 11:51:11 | Show all floors
@loboris  DHL tracking number 5292220916

0

threads

4

posts

20

credits

Novice

Rank: 1

credits
20
Published in 2015-8-20 20:37:24 | Show all floors
hi @loboris, I have an other question. Could you give us some comment how to build uImage for your image. I tried with this guide: http://www.orangepi.org/Docs/Building.html

I tried with default parameters from:
  1. make ARCH=arm CROSS_COMPILE=arm-linux-gnueabihf- menuconfig
Copy code


and the code show black screen. Sorry if it's question duplicate.

Thanks.
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list