Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 2264|Reply: 5

HDMI problems on boot from SD with PC Plus

[Copy link]

1

Threads

3

Posts

21

Credits

Novice

Rank: 1

Credits
21
Post time 2018-4-8 21:02:28 | Show all posts |Read mode
Edited by ZhuTou at 2018-4-8 21:20

Dear experts,

For me, booting from SD does not work. I don't have an HDMI capable monitor, so I attached my full HD LCD via an HDMI to VGA (analog) converter. When booting without SD card, the H3 CPU logo appears. When booting with SD card (Ubuntu lxde image), the red LED stays on, the screen stays black with the backlight turned on, but the monitor tells me I should set the graphics to full HD. When I boot without the HDMI converter connected, the red LED turns off after after few seconds and the green one lights up. The same HDMI to VGA adapter is working fine with my notebook.

My conclusion is that there is a problem with monitor detection.

Do you think my assumption is right (or what else might be the cause) and how could I solve this problem? Is there any way to define a screen resolution and to skip the monitor detection?

Thanks for your help and suggestions!

60

Threads

665

Posts

3970

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
3970
Post time 2018-4-9 10:50:04 | Show all posts
When you do not insert SD card, it stays at H3 CPU logo only or enter into system finally?

1

Threads

3

Posts

21

Credits

Novice

Rank: 1

Credits
21
 Author| Post time 2018-4-9 22:31:35 | Show all posts
Edited by ZhuTou at 2018-4-9 22:35

When powering on without SD card, only the H3 logo is shown (I powered off after a few minutes). It's a new board. Supposedly the flash is still empty. I see it rather as a sign that the board itself is not faulty.
Today, I attached a HDMI to DVI adapter and tried to start the system from the SD card. The screen was still black, but the red LED went off after about 5sec and the green LED went on. Later, I changed to a HDMI to VGA adapter while the system was still powered on and there were messages from the linux boot on the screen.

9

Threads

639

Posts

4326

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4326
Post time 2018-4-10 13:19:42 | Show all posts

60

Threads

665

Posts

3970

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
3970
Post time 2018-4-10 13:52:11 | Show all posts
ZhuTou replied at 2018-4-9 22:31
When powering on without SD card, only the H3 logo is shown (I powered off after a few minutes). It' ...

when you test without SD card, maybe you should wait some more time to check whether it could enter into system or not. If it entered into system, that means the hardware is ok and your screen is fine. While you use SD card cannot enter into system, maybe you could try to flash the image again.

1

Threads

3

Posts

21

Credits

Novice

Rank: 1

Credits
21
 Author| Post time 2018-4-10 23:23:05 | Show all posts
Edited by ZhuTou at 2018-4-11 11:52
admin replied at 2018-4-10 13:52
when you test without SD card, maybe you should wait some more time to check whether it could ente ...

Without SD card, also after ~15min nothing happened (black screen with HDMI adapter, H3 logo with HDMI to VGA adapter). Tried re-flashig the SD several times. Had no effect. Will try the images from the armbian site now, referring to igorpec's post.

Edit (20180411): Flashed the desktop legacy kernel image from the armbian site (https://www.armbian.com/orange-pi-pc-plus/). Now the board starts with a green LED. With the DVI converter, the screen is purple, with the analog VGA converter, the screen is horizontally divided into a black and a white part which vary in size between boots. No changes within about 15mins. Seems it's really a problem concerning monitor/adapter/HDMI/board communication and possibly driver availability. I'm now waiting for a small screen with SPI communication using the GPIO to arrive and trying to borrow a monitor with a direct HDMI input.


You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-9-23 17:33 GMT+8 , Processed in 0.031208 second(s), 22 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list