Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 4821|Reply: 8

linux-headres-4.18-rc7-sunxi for dkms

[Copy link]

7

Threads

19

Posts

228

Credits

Intermediate member

Rank: 3Rank: 3

Credits
228
Post time 2018-11-24 19:29:15 | Show all posts |Read mode
I set up Ubuntu Bionic on OrangePi One Plus ( H6 based )
The next step - setting up MALI drivers. (mali-midgard-dkms)


Bionic supports dkms technology.
However, it requires linux headers.

Bionic apt offers headers of linux kernel 4.15
I don't know where to get exact headers for my bionic
linux-headres-4.18-rc7-sunxi
I found some kernel headers here
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.18-rc7/
But not sure they are exact
It is possible, that
linux-headres-4.18-rc7-sunxi
is not the same as
  linux-headers-4.18.0-041800rc7_4.18.0-041800rc7.201807292230_all.deb
  linux-headers-4.18.0-041800rc7-generic_4.18.0-041800rc7.201807292230_amd64.deb
  linux-headers-4.18.0-041800rc7-lowlatency_4.18.0-041800rc7.201807292230_amd64.deb


Where to get sunxi version of headers?


4

Threads

96

Posts

931

Credits

Senior member

Rank: 4

Credits
931
Post time 2018-11-25 21:29:50 | Show all posts
Ubuntu themselves do neither create images especially for sunxi64 nor do they have matching linux headers. Go for ARM64.
Or use Armbian as base.

7

Threads

19

Posts

228

Credits

Intermediate member

Rank: 3Rank: 3

Credits
228
 Author| Post time 2018-11-25 21:55:00 | Show all posts
I didn't find armbian kernel build for H6 based platforms.
are you familiar with this build system internals?

7

Threads

19

Posts

228

Credits

Intermediate member

Rank: 3Rank: 3

Credits
228
 Author| Post time 2018-11-26 07:04:35 | Show all posts
I found it yet.
It requires EXPERT=yes variable, and while boar selection choosing WIP mode option

9

Threads

641

Posts

4349

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4349
Post time 2018-11-27 13:52:00 | Show all posts
You can easily stop here. DRM video driver is n/a / buggy which means there is no HDMI out at the moment. The rest somehow works, headers are included at the build time.

7

Threads

19

Posts

228

Credits

Intermediate member

Rank: 3Rank: 3

Credits
228
 Author| Post time 2018-11-27 19:49:03 | Show all posts
Edited by jslav at 2018-11-27 19:54

Igor. I want to use mali without display driver. Only for computing.
First, I need to test is mali driver able to work without display and X11.
Probably, I will find some bugs and log them to ARM.

Previously, I used Platform OrangePi PC with MALI 400.
On this platform I use libMali.so driver which implements OpenGL ES interface.

Do you know does mali-t76x-...-driver provide OpenGL functionality correctly?

9

Threads

641

Posts

4349

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4349
Post time 2018-11-27 20:28:13 | Show all posts
I am not an expert in this particular field but I think OpenGL is probably not supported. GLES only.

7

Threads

19

Posts

228

Credits

Intermediate member

Rank: 3Rank: 3

Credits
228
 Author| Post time 2018-11-27 20:46:56 | Show all posts
Edited by jslav at 2018-11-27 20:48

Are you aware about dkms.

While building dkms driver
  1. DKMS make.log for mali-midgard-16.0 for kernel 4.19.4-sunxi64 (aarch64)
  2. Tue Nov 27 11:11:46 UTC 2018
  3. make -C /lib/modules/4.19.4-sunxi64/build M=/var/lib/dkms/mali-midgard/16.0/build EXTRA_CFLAGS="-I/var/lib/dkms/mali-midgard/16.0/build/../../../../include -I/var/lib/dkms/mali-midgard/16.0/build/../../../../tests/include -DCONFIG_MALI_MIDGARD=m -DCONFIG_MALI_DEVFREQ=y -DCONFIG_MALI_EXPERT=y -DCONFIG_MALI_BACKEND=gpu -DCONFIG_MALI_PLATFORM_DEVICETREE=y"  KBUILD_EXTRA_SYMBOLS="/var/lib/dkms/mali-midgard/16.0/build/../../../base/ump/src/Module.symvers /var/lib/dkms/mali-midgard/16.0/build/../../../../drivers/base/kds/Module.symvers" modules
  4. make[1]: Entering directory '/usr/src/linux-headers-4.19.4-sunxi64'
  5. Makefile:619: arch//Makefile: No such file or directory
  6. make[1]: *** No rule to make target 'arch//Makefile'.  Stop.
  7. make[1]: Leaving directory '/usr/src/linux-headers-4.19.4-sunxi64'
  8. Makefile:39: recipe for target 'all' failed
  9. make: *** [all] Error 2
Copy the Code

Missing Makefile at /usr/src/linux-headers-4.19.4-sunxi64/arch
As I see, ther is an issue with headers itself
Is there any dkms compliant linux-headers-* package?

7

Threads

19

Posts

228

Credits

Intermediate member

Rank: 3Rank: 3

Credits
228
 Author| Post time 2018-11-27 21:34:31 | Show all posts
got it. The ARCH environment variable was not recognized
explicit ARCH setting moved me further
sudo dkms build -m mali-midgard -v 16.0 -a arm64
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2021-3-9 15:45 GMT+8 , Processed in 0.034306 second(s), 22 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list