please choosego to mobile | Continue to access the PC version
View: 8029|Reply: 6

Network problem RK3399

[Copy link]

1

threads

4

posts

19

credits

Novice

Rank: 1

credits
19
Published in 2018-11-29 21:08:53 | Show all floors |Read mode
Hi all

I have a problem with Gigabit Ethernet interface on my Orange Pi RK3399 with your version of Debian 9 OS (OrangePi-RK3399_Linux4.4_V1.0_2018_0110) onboard.

Basic issues:
1) Pings to all network nodes from RK3399 leads to at least 3% packet losts (results are independed from network environment and Ethernet cable, direct connection from PC shows same losts)
2) Pings to RK3399 from any another network node (or from PC in case of direct connection) leads to 3% packet losts too.

Effects:
1) SSH sessions are unstable and frequently interrupts
2) Any massive network load (RTSP video translation, for example) leads to network interface shutdown, after that only ifdown/ifup combination allow to bring it back

Switching eth0 to 100 Mbit/sec speed mode allows to remove packet losts, in that case ping packets sents succesfully. However, Effect 2 is still active, any network load leads to crashing eth0 anyway.
In all cases, there are no any errors in system logs, ethtool shows correct work of network interface.

Nota bene, that i powered up the device from 12V 2A, as required in User Manual. I should say also there is mSATA SSD onboard, so there is some additional power consumption maybe.  

Solution of that problem is very important for me, because network speed is needed for multichannell video translation, sphere of my proffessional interests.

So, i'll be very grateful to developers for any help

1

threads

4

posts

19

credits

Novice

Rank: 1

credits
19
 Author| Published in 2019-3-29 17:15:15 | Show all floors
The problem is still actual

However, not long time ago Armbian beta for RK3399 was released. Maybe, i will try it. There is no hope for OrangePi vendor, it's support is terrible, as i understood.

2

threads

13

posts

127

credits

Registered member

Rank: 2

credits
127
Published in 2018-12-10 16:05:35 | Show all floors
I have the same issues. However, I have "fixed it" (not really) by running one of two shell-scripts which changes network settings depending in which direction I need to transfer most of the data.

- If I want my OrangePi RK3399 to act as a fileserver I run one of them (this is the most common setup).
- If I want to do administrative work on the RK3399, maybe update some large packages using "sudo apt-get upgrade" or something, I run the other. When I'm done, I run the first script again to change back to "fileserver mode".

It kinda works but it is annoying as hell, really...

If anyone else has gotten their network running flawlessly on the RK3399 / Debian, please tell us. :-)
DataDataData

1

threads

4

posts

19

credits

Novice

Rank: 1

credits
19
 Author| Published in 2019-3-29 17:17:35 | Show all floors

13

threads

93

posts

686

credits

Senior member

Rank: 4

credits
686
Published in 2019-3-31 18:07:39 | Show all floors
I will give a try soon with the HDMI-IN image, but would love to switch to Armbian asap.

1

threads

4

posts

19

credits

Novice

Rank: 1

credits
19
 Author| Published in 2019-5-15 23:32:37 | Show all floors
The problem is still actual

13

threads

93

posts

686

credits

Senior member

Rank: 4

credits
686
Published in 2019-7-26 03:45:17 | Show all floors
I am still using the HDMI-IN image, and my SSH sessions are unstable...
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list