please choosego to mobile | Continue to access the PC version
View: 18432|Reply: 19

[SOLVED] Dual Head Display (expanded desktop and mirror desktop (VGA and HDMI)

[Copy link]

7

threads

100

posts

647

credits

Senior member

Rank: 4

credits
647
Published in 2015-1-25 00:25:13 | Show all floors |Read mode
Edited by john0815 at 2015-2-8 06:14

The following lines give you the information how to configigure orangepi for a Dual-Monitor-System.

Most of this settings had been figured out by Gaara
.


There are 2 different modes:
1. Dual Head with monitor Mirror
2. Dual Head with a desktop over 2 Monitors

All values are for Monitors with full HD (1920*1080) if you have other resolutions you can change the values (refer to: http://linux-sunxi.org/Fex_Guide

You can use the following lines for both modes:

a) uEnv.txt

bootargs=console=ttyS0,115200 console=tty0 sunxi_fb_mem_reserve=64 disp.screen0_output_mode=EDID:1280x1024 hdmi.audio=EDID:0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
aload_script=fatload mmc 0 0x43000000 script.bin;
aload_kernel=fatload mmc 0 0x48000000 uImage; bootm 0x48000000;
uenvcmd=run aload_script aload_kernel

b) script.fex

[disp_init]
disp_init_enable = 1
disp_mode = 2                           (2= Dual Head - Expand Desktop, 4= Clone Screen or Mirror) !!! --> remove the pink letters from the file
screen0_output_type = 4        
screen0_output_mode = 10

screen1_output_type = 3
screen1_output_mode = 10

fb0_framebuffer_num = 2
fb0_format = 10
fb0_pixel_sequence = 0
fb0_scaler_mode_enable = 1

fb1_framebuffer_num = 2
fb1_format = 10
fb1_pixel_sequence = 0
fb1_scaler_mode_enable = 1


c) etc\x11\xorg.conf:

Note: If you dont have installed the Mali binary driver (http://linux-sunxi.org/Mali_binary_driver) use fbdev instead of fbturbo

The following ist for expanded Desktop:

Section "Device"
            Identifier      "fbturbo"
            Driver          "fbturbo"
            Option          "fbdev" "/dev/fb0"

            Option          "SwapbuffersWait" "true"
    EndSection

    Section "Device"
            Identifier      "FBDEV 0"
            Driver          "fbturbo"
            Option          "fbdev" "/dev/fb0"
    EndSection

    Section "Device"
            Identifier      "FBDEV 1"
            Driver          "fbturbo"
            Option          "fbdev" "/dev/fb1"
    EndSection

    Section "Screen"
            Identifier      "_VGA_"
            Device          "FBDEV 0"
            Monitor         "VGA"
            DefaultDepth    24
            SubSection "Display"
                    Depth           24
                    Modes           "1920x1080"
            EndSubSection
    EndSection

    Section "Screen"
            Identifier      "_HDMI_"
            Device          "FBDEV 1"
            Monitor         "HDMI"
            DefaultDepth    24
            SubSection "Display"
                    Depth           24
                    Modes           "1920x1080"
            EndSubSection
    EndSection

    Section "Monitor"
            Identifier      "VGA"
            Option "PreferredMode" "1920x1080_60.00"
            Option          "DPMS" "true"
    EndSection

    Section "Monitor"
            Identifier      "HDMI"
            Option "PreferredMode" "11920x1080_60.00"
            Option "RightOf" "VGA"
            Option          "DPMS" "true"
    EndSection

    Section "ServerLayout"
            Identifier      "Xinerama"
            Screen          0 "_VGA_"
            Screen          1 "_HDMI_" Leftof "_VGA_" write Rightof instead of Leftof if your HDMI Monitor is right of the VGA Monitor
            Option                "Xinerama" "on"            commend with # this line for clone or mirror display

            Option         "Clone" "off"                        
commend with # this line for clone or mirror display
    EndSection

    Section "Extensions"
            Option "RANDR" "Enable"
    EndSection

________________________________________

If someone have a suggestion to change this lines please post a message and I will put it in.


7

threads

100

posts

647

credits

Senior member

Rank: 4

credits
647
 Author| Published in 2015-1-31 00:51:56 | Show all floors
Edited by john0815 at 2015-1-31 01:37

Hallo again!

I tried several things to get a Dual Screen (DualHead) System with an expanded desktop.

The result is, that the VGA Monitor works OK with Full HD
The HDMI Monitor shows only a bad picture with coloured points and strips.

But: and this is interesting:

I see the mouse pointer, when I go from the VGA to the HDMI Side.
So I am sure that this could work.
The problem might be, that the Monitor do not can display the Signal from the HDMI Port correctly.

xrandr do not recognize the moniors, but in the xorg.log I see them.

Please refer to the attached Zip.
It contains the script.fex, xorg.conf and xorg.0.log


To find a solution would be very great because this wonderful board an be uses als THIN Client for less money.
It runs perfectly for me (with one Monitor) but I need the solution with the expanded Desktop to get a great system.

Thank you for your helping.






This thread contains more resources

You need to Log in to download or view,No account?    Register

x
Published in 2015-1-31 05:56:36 | Show all floors
Thank you. We need test it.

17

threads

212

posts

1319

credits

Gold member

Rank: 6Rank: 6

credits
1319
Published in 2015-2-7 04:13:36 | Show all floors
Edited by gaara at 2015-2-6 21:33

@john0815:
I have successfully set the dual display using  your xorg.conf, modified like that:
  1. Section "Device"
  2.         Identifier      "fbturbo"
  3.         Driver          "fbturbo"
  4.         Option          "fbdev" "/dev/fb0"

  5.         Option          "SwapbuffersWait" "true"
  6. EndSection

  7. Section "Device"
  8.         Identifier      "FBDEV 0"
  9.         Driver          "fbturbo"
  10.         Option          "fbdev" "/dev/fb0"
  11. EndSection

  12. Section "Device"
  13.         Identifier      "FBDEV 1"
  14.         Driver          "fbturbo"
  15.         Option          "fbdev" "/dev/fb1"
  16. EndSection

  17. Section "Screen"
  18.         Identifier      "_VGA_"
  19.         Device          "FBDEV 0"
  20.         Monitor         "VGA"
  21.         DefaultDepth    24
  22.         SubSection "Display"
  23.                 Depth           24
  24.                 Modes           "1280x1024"
  25.         EndSubSection
  26. EndSection

  27. Section "Screen"
  28.         Identifier      "_HDMI_"
  29.         Device          "FBDEV 1"
  30.         Monitor         "HDMI"
  31.         DefaultDepth    24
  32.         SubSection "Display"
  33.                 Depth           24
  34.                 Modes           "1440x900"
  35.         EndSubSection
  36. EndSection

  37. Section "Monitor"
  38.         Identifier      "VGA"
  39.         Option "PreferredMode" "1280x1024_60.00"
  40.         Option          "DPMS" "true"
  41. EndSection

  42. Section "Monitor"
  43.         Identifier      "HDMI"
  44.         Option "PreferredMode" "1440x900_60.00"
  45.         Option "RightOf" "VGA"
  46.         Option          "DPMS" "true"
  47. EndSection

  48. Section "ServerLayout"
  49.         Identifier      "Xinerama"
  50.         Screen          0 "_VGA_"
  51.         Screen          1 "_HDMI_" Rightof "_VGA_"
  52.         Option                "Xinerama" "off"
  53.         Option         "Clone" "off"
  54. EndSection

  55. Section "Extensions"
  56.         Option "RANDR" "Enable"
  57. EndSection
Copy code

It can certainly be optimized, but I have two differents screens with the good resolution, and the mouse pointer works good.

7

threads

100

posts

647

credits

Senior member

Rank: 4

credits
647
 Author| Published in 2015-2-7 15:43:19 | Show all floors
hi

You are a guru.

I will try it
thx

17

threads

212

posts

1319

credits

Gold member

Rank: 6Rank: 6

credits
1319
Published in 2015-2-7 17:18:05 | Show all floors
The only thing I can't do for the moment, is to move windows from screen 1 to screen 2. (or 2 to 1)
Windows must be opened in his own screen

7

threads

100

posts

647

credits

Senior member

Rank: 4

credits
647
 Author| Published in 2015-2-7 17:47:14 | Show all floors
HI

I have tried yor xorg.conf and it is the sam matter as before. VGA shows a good picture, HDMI is BAD but I see the Cursor.
do you have made an changes zu script.fex or on an other place?

17

threads

212

posts

1319

credits

Gold member

Rank: 6Rank: 6

credits
1319
Published in 2015-2-7 18:22:48 | Show all floors
I have used my own file.fex, here is the disp_init I use:
  1. [disp_init]
  2. disp_init_enable = 1
  3. disp_mode = 2
  4. screen0_output_type = 4
  5. screen0_output_mode = 3

  6. screen1_output_type = 3
  7. screen1_output_mode = 4

  8. fb0_framebuffer_num = 2
  9. fb0_format = 10
  10. fb0_pixel_sequence = 0
  11. fb0_scaler_mode_enable = 1

  12. fb1_framebuffer_num = 2
  13. fb1_format = 10
  14. fb1_pixel_sequence = 0
  15. fb1_scaler_mode_enable = 1

  16. lcd0_backlight = 197
  17. lcd1_backlight = 197
  18. lcd0_bright = 50
  19. lcd0_contrast = 50
  20. lcd0_saturation = 57
  21. lcd0_hue = 50

  22. lcd1_bright = 50
  23. lcd1_contrast = 50
  24. lcd1_saturation = 57
  25. lcd1_hue = 50
Copy code

7

threads

100

posts

647

credits

Senior member

Rank: 4

credits
647
 Author| Published in 2015-2-7 18:53:14 | Show all floors
HI

It doesnt work - I think I am too stupid for this.

Has anybody else sucess with this duál-head config

17

threads

212

posts

1319

credits

Gold member

Rank: 6Rank: 6

credits
1319
Published in 2015-2-7 19:14:40 | Show all floors
That's weird.. What is your Xorg.0.log ? I will compare with mine
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list