Please select To the mobile version | Continue to access the desktop computer version


Hot search: orangepi
View: 1963|Reply: 1

Orangepi 3 (H6) + EMMC Arcade

[Copy link]








Rank: 1

Post time 2019-3-21 18:41:23 | Show all posts |Read mode
Edited by jurjur at 2019-3-21 18:57

I am a mere user and I do not have much idea of ​​linux, I write this post to do my bit for those who might be interested.

Finally I bought an Orangepi 3 (OPI3) with EMMC and H6, instead of a raspberry.
While developing the fabulous software armbian and retrorangepi that I appreciate all the effort, I found that to play with the new toy easily for a novice like me there were currently very few options in a simple way you burn an img and play.
This is my experience with OPI3 to imitate an arcade similar to retrorangepi, since I did not want a tv box with kodi:

Within my ignorance, in I saw that the operating system could install: Android or Linux.
Like most developments of emulators and FrontEnd that I found were for linux, because that's where I started.
Install Ubuntu and well, I noticed the slow system. And I was not able to install retroarch, or retropie or recalbox with emulationstation for my inexperience I think.

Probe with Debian, same result, problems installing with certificates that I could not solve, slowness of the system appreciable.

I only had to try Android that I just did not like.
In android probe several emulators and frontend but I did not quite like the final result, some failed the mapping of the controls, others could not remain as an independent arcade.
Probe Romflix, where the Kodi recognized the 4 cores but did not properly map the controls (start button in the emulators) and I did not know how to solve it. And I did not like it because it launched external emulators separately and had to be configured one by one.
Try the Gamesome and the afba, same result as with the Romflix, it did not map correctly.
I also tried RetroArch_aarch64.apk and it said that it was not compatible with the Android 7 installed, we can not install it.

The best option that I could do and it has been pretty good to be Andoid and waiting and thanking the great effort of the developers of Armbian and Retrorangepi for OPI3

has been the following:
Android 7 in OPI3 + Retroarch + ArcBrowser. Configuring controls correctly in Retroarch and put ArcBrowser as Startup application in the Android.
It is fabulous, fast, playable, stable, while we are waiting for your specific retrorangepi.
To burn the image of Android 7 you have to use the PhoenixCard and mark the Startup option, and once the Android "Initiate" SD in Storage to get all your space.
Important to know that once the ArcBrowser is set as the Startup application (Home app), in order to exit the ArcBrowser to update roms or whatever, a multimedia USB keyboard is necessary, and while booting the OPI3 in the bootanimation press the "Windows" + "Volume Down" key . You will enter in Safe Mode that the settings will not work correctly to modify the startup application, but in the next restart it will start with the default and problem solved.

NOTES: The retroarch detects only 1 core because I do not know why (maybe it is not aarch64), although it is very good and fluid. The 1GB network card on Android works as if it were 100Mbps or even less (5-6 MB / s).

As the protective case were still being developed, I caught this one of raspberry that doing with the dremel a few holes is perfect. They have just taken out the one that is totally closed for OPI3 but I think it is much better. I attach a photo.

This post contains more resources

You have to Login for download or view attachment(s). No Account? Register








Registered member

Rank: 2

Post time 2019-5-25 02:05:37 | Show all posts
he scans my English but I use an online translator.
I have an op3 with android, I wanted to use opi3 as a retro consol. , but retroorange does not exist for op3.
I read your article and find it interesting.
I have a problem, after setting up Italian, the google play icon appears in the home. but it doesn't work, I can't install retroarch.
if I download the retroarch apk file the installation starts but then deletes.
do you have any advice for me?
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-2-25 23:15 GMT+8 , Processed in 0.030658 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list