Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 441|Reply: 0

Thermal serial printer OPIZ+

[Copy link]

2

Threads

3

Posts

46

Credits

Novice

Rank: 1

Credits
46
Post time 2019-6-6 02:18:35 | Show all posts |Read mode
Hi everybody.
I brought a thermal printer receip (as used for all tutorials for rasberry) and I got a lot of issues sending print orders on my OrangePi Zero+.

With UART1 enabled i connected 5V, Ground and TX from the orange respectively to each pin of the printer (5V, Ground and RX).
After that run the command: echo "Hello world > /dev/ttyS1" to the port of UART1 and it printed. Until here everything is OK but...
With the command cat file.txt > /dev/ttyS1 all the system crashed. Printer just moved the paper a little and nothing then, the serial acces (UART0) and SSH connections get frozen and I was unabled to create another SSH connection.

With all those problems I tryed another options:
1. Printer connected to UST to TTL on my PC. Flawless (Printer OK and 5V output is enough to feed the printer)
2. Printer connected to UART on Raspberry. Works great. (I said "It's maybe a bug" but is not)
3. Command cat file.txt > /dev/ttyS0 to send the text to screen with my UBS to TTL converter. Shows everything OK (The command is OK)

At this point I said "maybe it is a power issue, then I tryed this...
4. Separated sources
|_OPIZ+ connected to a 5V 750mA (An old phone charger)

|_ Printer connected separatedly to my actual 5V 2A phone charger and data cable to OPI pin
|_RESULT: OPI works great, Printer turns ON but nothing prints

5. More risky (both chargers connected to OPI) On paper its like 5V@2.75A
|_ 5V, Ground and Data cable poperly connected to OPI
|_ RESULT: System crashed as expained before

6. Ground of both power sources connected to OPI
|_ 5V of 750 mA connected to OPI
|_ 5V of 2A connected to printer
|_ Ground of printer connected to ground in OPI
|_ Data cable properly connected to OPI serial pin
|_ RESULT: WORKS!!!

I have not enough knowledge about electronics (my field is more programming) but i guess it is an Amperage issues but how can i fix it in order to use just one power source?

*Is a 3A 5V power source safe?
*Do I can to connect the printer power and ground to OPI pins? or in parallel to the OPI?
*Do i need an resistor for OPI in order to get less Amperes?

Can anybody help me with it?
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2019-8-24 06:02 GMT+8 , Processed in 0.024020 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list