Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 973|Reply: 5

RK3399 - Flashing eMMC with HDMI - IN

[Copy link]

1

Threads

3

Posts

23

Credits

Novice

Rank: 1

Credits
23
Post time 2019-7-9 00:59:28 | Show all posts |Read mode
Hi,

Testing RK3399 for a big use case (1k+ devices) regarding HDMI-IN and HLS (live streaming)


RK3399 attended all requirements, but, I couldn't flash a image into the eMMC:


- Using upgrade_tool give me a Loading firmaware error,
- Tryed then a armbian image, worked using the armbian script, but, without HDMI-IN because armbian doesn't support it
- Tryed again upgrade_tool, but now, none devices are listing

What can I do now? I really fucked up installing armbian on eMMC?
Could I change this script somehow? https://github.com/orangepi-xunlong/OrangePiH3_scripts/blob/master/install_to_emmc


Thanks in advance...

12

Threads

91

Posts

489

Credits

Intermediate member

Rank: 3Rank: 3

Credits
489
Post time 2019-7-26 03:42:39 | Show all posts
You should try to get your board into MASKROM mode with the test pads.
For some other boards, there is a script that will write zeros in specific parts of the eMMC, so that the board thinks the eMMC is empty/defective, and then gets into MASKROM mode.
I did not manage to get it working with my OrangePi RK3399 boards.

1

Threads

3

Posts

23

Credits

Novice

Rank: 1

Credits
23
 Author| Post time 2019-7-30 21:38:50 | Show all posts
Just can't update emmc.

Either using the mega.nz images or compiling my own with the https://github.com/orangepi-xunlong/OrangePi_Build.

Using flash_tool.sh

./flash_tool.sh -c rk3399 -p system -i ../output/images/OrangePi_rk3399_xenial_server_v1.0.img
PARTITIONS OFFSET: 0 sectors.
The device does not support this operation!

With upgrade_tool, device shows up, but keep getting:
Rockusb>UF OrangePi_rk3399_xenial_server_v1.0.img
Loading firmware...
Loading firmware failed!

Don't know how to proceed now, feeling that money was wasted on this board.

1

Threads

3

Posts

23

Credits

Novice

Rank: 1

Credits
23
 Author| Post time 2019-7-31 04:39:39 | Show all posts
Managed to write OS on eMMC:

Tried (several times) starting the board on MASKROM mode (steps from manual):
  • Power off the device
  • Use metal tweezers to keep TP50265 and GND connected
  • Power on the board with DC
  • Wait a moment then release the metal tweezers
  • Use a micro USB Type-C cable to connect device and host PC
  • Device should enter MASKROM mode

PS.: Only worked on my USB 2.0 port.

Once entered MASKROM mode, I ran the command:

./flash_tool.sh -c rk3399 -p system -i ../../OrangePi-rk3399_Debian9_20181016.img

The image above was downloaded from the mega.nz.


Board restarted and booted debian from emmc.

Feeling dumb now, not wasted money at all


At last but not least, a quote from my country:

"Obrigado a todos os envolvidos"




1

Threads

6

Posts

25

Credits

Novice

Rank: 1

Credits
25
Post time 2019-8-28 12:53:47 | Show all posts
Hi Silvio,

Glad to see that you have solved your problem as well.
I faced a similar issue, and followed similar steps as well.

1

Threads

6

Posts

25

Credits

Novice

Rank: 1

Credits
25
Post time 2019-8-28 12:55:31 | Show all posts
Another thing, Silvio, did you managed to get the HDMI IN working?
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2019-12-8 13:11 GMT+8 , Processed in 0.030748 second(s), 24 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list